Create gnome theme (gnomestripe)

RESOLVED FIXED in 1.0b7

Status

Calendar
Calendar Views
RESOLVED FIXED
10 years ago
7 years ago

People

(Reporter: Pander, Assigned: Paenglab)

Tracking

unspecified
1.0b7
Bug Flags:
wanted-calendar1.0 +

Details

(Whiteboard: [no l10n impact])

Attachments

(4 attachments, 2 obsolete attachments)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.5) Gecko/2008121622 Ubuntu/8.10 (intrepid) Firefox/3.0.5
Build Identifier: 0.9 Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.18pre) Gecko/20080917 

The font in Sunbird is not according to GNOME while Firefox and Thunderbird it is. In Sunbird the font is too fat, see screenshot.

This is for the natively build Sunbird 0.8 from the Ubuntu debian package but also for the 0.9 latest stable download the case.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

10 years ago
Created attachment 354651 [details]
Screenshot
Do you have a windows box available? If these differences also show up in the same way there, we can fix this bug easily. Please attach a screenshot of windows in that case.

If not, then this a duplicate of the bug I can't find about the need to create a theme specifically for gnome (i.e "gnomestripe"). We should morph this bug in case the bug I can't find doesn't exist.
(Reporter)

Comment 3

10 years ago
Created attachment 354688 [details]
Windows screenshot
(Reporter)

Comment 4

10 years ago
In Windows this is not the case, see screenshot.
Since I haven't found a bug, we'll use this one for now. Unfortunately we don't have developer resources to take care of this now.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Component: General → Calendar Views
Ever confirmed: true
QA Contact: general → views
Summary: Font is not according to GNOME while Firefox and Thunderbird it is → Create gnome theme (gnomestripe)
Duplicate of this bug: 434692
(Reporter)

Comment 7

9 years ago
For me this is solved since Thunderbird and Firefox are now in an identical look as Songbird is. That is, they have changed. Fine with me.

Please verify for Ubuntu 9.04 with:
  sunbird 0.9+nobinonly-0ubuntu2
  thunderbird 2.0.0.23+build1+nobinonly-0ubuntu0.9.04.1
  firefox 3.0.15+nobinonly-0ubuntu0.9.04.1
or more recent version.
Okay, let's start this effort with a simple copy of winstripe and the needed wiring up for gnomestripe. Any volunteers?
Do we really want to do that? I've been wanting to do consolidate the themes for some time, I guess I can do that just after the beta, unless someone else steps up.

Comment 10

9 years ago
Styling is also inconsistent when using a high contrast theme. This makes it difficult or impossible to read the month preview.
(In reply to comment #10)
Already covered by Bug 435096.
Depends on: 533096
Flags: blocking-calendar1.0+
Whiteboard: [not needed beta][no l10n impact]
Nice to have, but not strictly blocking 1.0
Flags: blocking-calendar1.0+ → wanted-calendar1.0+
Whiteboard: [not needed beta][no l10n impact] → [no l10n impact]
(Assignee)

Comment 13

7 years ago
Created attachment 552523 [details] [diff] [review]
Add gnomestripe

This patch copies/moves the files from winstripe to gnomestripe.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #552523 - Flags: review?(philipp)
(Assignee)

Comment 14

7 years ago
Created attachment 552612 [details] [diff] [review]
Add gnomestripe

Forgot the Lightning tree
Attachment #552523 - Attachment is obsolete: true
Attachment #552612 - Flags: review?(philipp)
Attachment #552523 - Flags: review?(philipp)
Created attachment 553874 [details] [diff] [review]
Add gnomestripe - v2

Makefiles and directory typo fixed, this version works for me on linux. r=philipp
Attachment #552612 - Attachment is obsolete: true
Attachment #553874 - Flags: review+
Attachment #552612 - Flags: review?(philipp)
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/81300e6b49c7>

-> FIXED
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
OS: Linux → All
Resolution: --- → FIXED
Target Milestone: --- → Trunk
(Assignee)

Updated

7 years ago
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(Assignee)

Comment 17

7 years ago
Created attachment 553918 [details] [diff] [review]
Fix the typos

The comments in the Makefiles have still typos :(
Attachment #553918 - Flags: review?(philipp)
Comment on attachment 553918 [details] [diff] [review]
Fix the typos

r=philipp
Attachment #553918 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/f949fa447663>
-> FIXED
Status: REOPENED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Backported to comm-aurora <http://hg.mozilla.org/releases/comm-aurora/rev/a709a5fdca1c>
Target Milestone: Trunk → 1.0b6
You need to log in before you can comment on or make changes to this bug.