Closed Bug 4722 Opened 21 years ago Closed 20 years ago

[FEATURE] Cut, copy, paste, & select all in URL entry

Categories

(SeaMonkey :: UI Design, defect, P1)

defect

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: sfraser_bugs, Assigned: don)

References

Details

(Whiteboard: [pdt+]Waiting for 20471 to be fixed)

Apprunner, Mac. URL bar issues:
1. Type a URL. You have to hit return twice before it loads
2. Cannot copy & paste in URL bar
3. URL bar does not update to show URL of current page.
Assignee: don → radha
Component: Apprunner → XPApps
OS: Mac System 8.5 → All
Priority: P3 → P2
Hardware: Macintosh → All
Summary: Various URL bar problems → Cannot copy & paste in URL bar
Target Milestone: M5
Re-assinged to radha@netscape.com, set target milestone to M5, changed component
to XPApps, priority to P2, platform and OS to All, and changed summary line.

Radha, copy and paste actually work on Windows via the keyboard equivalents
only, i.e. the menu commands are not hooked up.

----------

Simon,

1. Type a URL. You have to hit return twice before it loads -- this is a
duplicate of bug #4544 that Radha is working on now.

3. URL bar does not update to show URL of current page. -- this is a duplicate
of bugs #4054 and #4071.
*** Bug 4857 has been marked as a duplicate of this bug. ***
*** Bug 4859 has been marked as a duplicate of this bug. ***
Status: NEW → ASSIGNED
QA Contact: 3853 → 1698
[QA Assigning to self.]
Summary: Cannot copy & paste in URL bar → URL bar does not update to show URL of current page
updating title to show part 3.   that the only thing not working now, right?
Summary: URL bar does not update to show URL of current page → Can not cut & paste in to URL bar
Changed title again. It is the second part that is not working . Rest have been
fixed.
Target Milestone: M5 → M7
*** Bug 6516 has been marked as a duplicate of this bug. ***
*** Bug 7663 has been marked as a duplicate of this bug. ***
*** Bug 7691 has been marked as a duplicate of this bug. ***
Priority: P2 → P1
Target Milestone: M7 → M8
Move this out to M8 when Radha will be working on the URL bar.
Priority: P1 → P2
BTW, copy and paste actually work on Windows and Linux after a fashion.  The
menu commands don't work, but the keyboard equivalents work on Windows and the
middle button mouse shortcut works on Linux.
Summary: Can not cut & paste in to URL bar → [FEATURE]Can not cut & paste in to URL bar
Marking as FEATURE. To be newly implemented..
Summary: [FEATURE]Can not cut & paste in to URL bar → [FEATURE] Cannot cut & paste in to URL bar
There is more work to this than hooking up menu items. First, the cut & paste
features are not there. There is some code for copy. To cut,copy & paste in the
right way,  we need to figure  who has the focus and the last drag, the content
area or url bar or a text field inside content area etc... Based on who had the
last mouse drag, the appropriate hooking up to either nsIPresShell or the text
widget needs to be done. Once all this is done, the menu options should be
hooked.  I don't see all this happening in the near future. Moving to M10.
cc'ing mcafee for more input.
There is more work to this than hooking up menu items. First, the cut & paste
features are not there. There is some code for copy. To cut,copy & paste in the
right way,  we need to figure  who has the focus and the last drag, the content
area or url bar or a text field inside content area etc... Based on who had the
last mouse drag, the appropriate hooking up to either nsIPresShell or the text
widget needs to be done. Once all this is done, the menu options should be
hooked.  I don't see all this happening in the near future. Moving to M10.
cc'ing mcafee for more input.
Blocks: 10575
Summary: [FEATURE] Cannot cut & paste in to URL bar → [FEATURE] Cut, copy, & paste in URL entry
Radha, are there some known "feature" bugs by toolkit folks that this should be
dependent upon?
Whiteboard: Does this have a Gecko dependency?
Depends on: 12022
Target Milestone: M10 → M11
depends on 12022.
The deal is, For the content area only the copy operation is permitted. For the
urlbar and any text form element, cut, copy and paste are allowed. Which
explains why presentation shell has only copy operation. For the urlbar I
believe we will go thro' ender once the gfx switch is flipped. What about the
form elements. Can some one answer?

Browser needs to know when something is selected. So that it can decide whether
to  enable only the copy menuitem (if selection is in the content area) or cut
copy and paste menu items if the selection is in a text field. How can I get
that info?
*** Bug 4663 has been marked as a duplicate of this bug. ***
Blocks: 12669
Priority: P2 → P1
Summary: [FEATURE] Cut, copy, & paste in URL entry → [FEATURE] Cut, copy, paste, $ select all in URL entry
How much XPToolkit support do we need to implement this?
Target Milestone: M11 → M10
Whiteboard: Does this have a Gecko dependency? → Waiting for input on gfx widgets
This depends on the gfx text widget's clipboard APIs it is not sure at this time
if those are in place.
Depends on: 2253
you can find out if something is selected in the URL bar (or any gfx text
control) by  adding a listener on the onSelect notification from the gfx text
control.
I get notifications on select event. But I need a way to get to the text widget
from DOMNode. I think there is already  a bug against buster for that.
Target Milestone: M11 → M12
12022 is going to get fixed in M12. So will this be.
Blocks: 19423
we're unblocked here now, radha's on vacation, back ? 2nd week of december?
Chris, can you own this for beta?
Assignee: radha → mcafee
Status: ASSIGNED → NEW
Hmmm ... why is this bug re-assinging? ...
Assignee: mcafee → radha
Status: NEW → ASSIGNED
I have some changes for this in my tree and having some problems. I'll keep
posted. Let it stay in my palte for now, so that I can keep track...
No longer blocks: 10575
Summary: [FEATURE] Cut, copy, paste, $ select all in URL entry → [FEATURE] Cut, copy, paste, & select all in URL entry
Whiteboard: Waiting for input on gfx widgets
Re-summarized.
*** Bug 22776 has been marked as a duplicate of this bug. ***
Depends on: 20471
Whiteboard: Waiting for 20471 to be fixed
*** Bug 23294 has been marked as a duplicate of this bug. ***
[note to self: be sure to verify dupes of this bug while verifying it.]
Assignee: radha → mcafee
Status: ASSIGNED → NEW
Chris, this is waiting for some M13 work from Hyatt.
Target Milestone: M13 → M14
Moving to M14 ...
Depends on: 14026
No longer depends on: 2253, 12022
buster: why is this dependent on 20471?  I don't see that bug mentioned here.
Marking dependant on saari's focus bug, 14026.
This bug is not strictly dependent on 20471, in the sense that no progress can
be made on this bug until 20471 is fixed.  However, the fix for this bug won't
work right from the user's perspective until 20471 is also fixed.  They can be
fixed in parallel.

As you fix this bug, you'll want to test it.  So you'll make edits to the URL
bar, but the commands won't be updated automatically as they should.  Instead,
you'll have to point focus elsewhere (like the tree control in the sidebar, for
example), then back to the URL bar to get the URL bar to update it's commands.

QA would have a hard time marking this bug verified until 20471 is fixed,
because commands won't be enabled/disabled at the expected times.
*** Bug 25529 has been marked as a duplicate of this bug. ***
don will track this.
Assignee: mcafee → don
Nominating as "beta1" blocker.
Keywords: beta1
Whiteboard: Waiting for 20471 to be fixed → [pdt+]Waiting for 20471 to be fixed
OK, this is fixed.
Status: NEW → RESOLVED
Closed: 20 years ago
Resolution: --- → FIXED
This definitely works using the 2.17.00 build. 

After checking this bug (and nearly all bugs marked as duplicate of this bug) on 
all 3 primary platforms, I'm Verifying.

There are several side-issues:
	* You can copy via keyboard shortcut when the menu item is disabled
	* If you paste text on Windows into a text field until you exceed the right 
(or bottom) edge of the text field, the text field won't scroll to display the 
text you're entering. Of course, if you exceed the edge through typing, it will.

Will see if bugs exist for both of these, and if not, will submit them.
Verified fixed.

	- first side-issue noted by trudelle to be an existing bug; bug number 
unknown.
	- second side-issue now contained in bug #28317.
Status: RESOLVED → VERIFIED
Product: Core → Mozilla Application Suite
You need to log in before you can comment on or make changes to this bug.