Closed Bug 472674 Opened 11 years ago Closed 11 years ago

Greasemonkey does not work.Error: Could not convert JavaScript argument = NS_ERROR_XPC_BAD_CONVERT_JS

Categories

(Core :: XPConnect, defect, P1)

x86
All
defect

Tracking

()

RESOLVED FIXED

People

(Reporter: alice0775, Assigned: mrbkap)

References

Details

(Keywords: fixed1.9.1, regression)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.6pre) Gecko/2009010705 Gecko/2008010101 Firefox/3.0.5
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.2a1pre) Gecko/20090108 Minefield/3.2a1pre

Greasemonkey does not work on Minefiled Build 20090106155755.


Reproducible: Always

Steps to Reproduce:
1.Make sure set "extensions.checkCompatibility" and "extensions.checkUpdateSecurity" to false.
2.Install Greasemonkey0.8.20080609.0 from https://addons.mozilla.org/en-US/firefox/addon/748
3.Restart Firefox
4.Install some user.js from http://userscripts.org/
Actual Results:  
Greasemonkey does not work and an error message comes out in the Error console.

Error: Could not convert JavaScript argument = NS_ERROR_XPC_BAD_CONVERT_JS
Source file: file:///C:/Documents%20and%20Settings/fuku/Application%20Data/Mozilla/Firefox/Profiles/qjd59xri.aaa/extensions/%7Be4a8a97b-f2ed-450b-b12d-ee082ba24781%7D/components/greasemonkey.js
Line: 108

Expected Results:  
No error.

Greasemonkey works well with 20090106 Trunk.
Greasemonkey does not work with 20090107 Trunk Build 20090106155755.

I supposed regression of 
Bug 470720 - Don't automatically unwrap XOWs or SJOWs in XPCNativeWrappers.
Bug 471366 - Deal with XPCNativeWrapper.prototype correctly.
Whiteboard: regression?
Version: unspecified → Trunk
No duplicates found. Confirming and marking NEW.

Seeing this on OS X too, so OS -> All.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
This is mine.
Assignee: nobody → mrbkap
Blocks: 470720
Flags: blocking-firefox3.1?
Keywords: regression
Whiteboard: regression?
Blocks: 472979
Component: Extension Compatibility → XPConnect
Flags: blocking-firefox3.1?
Product: Firefox → Core
QA Contact: extension.compatibility → xpconnect
Flags: blocking1.9.1?
Flags: blocking1.9.1? → blocking1.9.1+
Priority: -- → P1
This bug also breaks other extensions, such as Line Marker: https://addons.mozilla.org/en-US/firefox/addon/1931
http://hg.mozilla.org/mozilla-central/rev/122cf69f6692
http://hg.mozilla.org/mozilla-central/rev/427d147720e3
(patch in bug 472792)

Greasemonkey works again in today's nightly :)
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Blocks: 471366
You need to log in before you can comment on or make changes to this bug.