If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Re-add support to reorder newsgroups using drag drop

VERIFIED FIXED in Thunderbird 3.0b2

Status

Thunderbird
Mail Window Front End
VERIFIED FIXED
9 years ago
8 years ago

People

(Reporter: sid0, Assigned: Ian Neal)

Tracking

(Blocks: 1 bug, {regression})

Trunk
Thunderbird 3.0b2
regression
Dependency tree / graph
Bug Flags:
wanted-thunderbird3 +
in-litmus +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

Bug 150274 added support to reorder newsgroups through drag and drop. With the js folder pane, support for this was lost. This bug is to re-add support for this.
Flags: wanted-thunderbird3?
Flags: in-litmus?

Updated

9 years ago
Blocks: 414038
Flags: wanted-thunderbird3? → wanted-thunderbird3+
Keywords: regression
Target Milestone: --- → Thunderbird 3.0rc1
(Assignee)

Comment 1

9 years ago
Created attachment 360013 [details] [diff] [review]
Add support for newsgroups to drag and drop patch v0.1

This patch:
* Adds text/x-moz-newsfolder to drag and drop types used.
* Adds support re-organising newsgroups via drag and drop.
Assignee: nobody → iann_bugzilla
Status: NEW → ASSIGNED
Attachment #360013 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 2

9 years ago
Patch from bug 465015 needs to be applied for this to work.
Depends on: 465015
(Assignee)

Updated

9 years ago
Attachment #360013 - Flags: review?(mkmelin+mozilla)
(Assignee)

Comment 3

9 years ago
Created attachment 360028 [details] [diff] [review]
Add support for newsgroups to drag and drop patch v0.1a

Changes since v0.1:
* Unbitrotted after push of patch on bug 465015.
* When dropping multiple newsgroups, selected folders stay in the same order.
Attachment #360013 - Attachment is obsolete: true
Attachment #360028 - Flags: review?(mkmelin+mozilla)

Updated

9 years ago
Attachment #360028 - Flags: review?(mkmelin+mozilla) → review+

Comment 4

9 years ago
Comment on attachment 360028 [details] [diff] [review]
Add support for newsgroups to drag and drop patch v0.1a

Looks good to me, works fine too:) r=mkmelin

Updated

9 years ago
Target Milestone: Thunderbird 3.0rc1 → Thunderbird 3.0b2
(Assignee)

Updated

9 years ago
Attachment #360028 - Flags: superreview?(neil)

Comment 5

9 years ago
Comment on attachment 360028 [details] [diff] [review]
Add support for newsgroups to drag and drop patch v0.1a

>+        // Don't allow dragging newsgroup to before/after itself.
>+        let row = aRow + aOrientation;
This is actually checking that you're not dragging to just before the item after (or just after the item before). I take it that something else prevents you from dropping before/after itself?
Attachment #360028 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 6

9 years ago
Created attachment 360812 [details] [diff] [review]
Add support for newsgroups to drag and drop patch v0.1b (Push: Comment 7)

Changes since v0.1a:
* Adds check for before/after item.
* Corrects comment for before the item after and after the item before.
Attachment #360028 - Attachment is obsolete: true
Attachment #360812 - Flags: superreview?(neil)
Attachment #360812 - Flags: review+

Updated

9 years ago
Attachment #360812 - Flags: superreview?(neil) → superreview+
(Assignee)

Updated

9 years ago
Attachment #360812 - Attachment description: Add support for newsgroups to drag and drop patch v0.1b → Add support for newsgroups to drag and drop patch v0.1b (Push: Comment 7)
(Assignee)

Comment 7

9 years ago
Comment on attachment 360812 [details] [diff] [review]
Add support for newsgroups to drag and drop patch v0.1b (Push: Comment 7)

http://hg.mozilla.org/comm-central/rev/33ebcd9e22ba
(Assignee)

Updated

9 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
Verified fixed with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090208 Shredder/3.0b2pre ID:20090208025606 and Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090208 Shredder/3.0b2pre

One more bug I noticed while verifying this fix is bug 477499.
Status: RESOLVED → VERIFIED
Blocks: 510793
Added https://litmus.mozilla.org/show_test.cgi?id=9510 to BFT and FFT
Flags: in-litmus? → in-litmus+
You need to log in before you can comment on or make changes to this bug.