Reording newsgroups while download headers dialog pops-up blocks all mouse events

VERIFIED DUPLICATE of bug 100180

Status

Thunderbird
Mail Window Front End
--
major
VERIFIED DUPLICATE of bug 100180
9 years ago
9 years ago

People

(Reporter: whimboo, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090208 Shredder/3.0b2pre

If you want to reorder the newsgroups and start a drag&drop action for a new subscribed group, the download headers dialog pops-up after a while. As long as you hold down the left mouse button, the UI will not react on any mouse event anymore. You have to use the keyboard to close the dialog.

Steps:
1. Create a newsgroup account and subscribe to some groups with high traffic
2. Click one group and hold down the left mouse button
3. Wait until the "Download Headers" dialog pops-up

With step 3 the UI is locked for any other mouse event. The only way to get rid of it is to use the keyboard and close the dialog.

Ian, could this be a regression from bug 473001?
Flags: blocking-thunderbird3?
I'd totally love it if we could blame it on IanN and make him fix it, but he probably knows it's been like that for at least seven or eight years.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Flags: blocking-thunderbird3?
Resolution: --- → DUPLICATE
Duplicate of bug: 100180
(Reporter)

Comment 2

9 years ago
What a bummer! Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.