Last Comment Bug 473060 - Download error -228 if you leave the add-on's public page before download completion
: Download error -228 if you leave the add-on's public page before download com...
Status: RESOLVED FIXED
: fixed1.9.0.9, fixed1.9.1, regression
Product: Core Graveyard
Classification: Graveyard
Component: Installer: XPInstall Engine (show other bugs)
: 1.9.1 Branch
: All All
: P2 normal (vote)
: mozilla1.9.2a1
Assigned To: Dave Townsend [:mossop]
:
:
Mentors:
https://addons.mozilla.org/en-US/fire...
Depends on:
Blocks: 462739
  Show dependency treegraph
 
Reported: 2009-01-11 04:56 PST by Thomas Goldstein
Modified: 2015-12-11 07:21 PST (History)
9 users (show)
dtownsend: blocking1.9.1+
dtownsend: in‑testsuite+
See Also:
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch rev 1 (1.83 KB, patch)
2009-01-29 04:34 PST, Dave Townsend [:mossop]
dveditz: review+
dveditz: superreview+
dveditz: approval1.9.0.9+
Details | Diff | Splinter Review

Description Thomas Goldstein 2009-01-11 04:56:49 PST
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090110 Shiretoko/3.1b3pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b3pre) Gecko/20090110 Shiretoko/3.1b3pre (.NET CLR 3.5.30729)

For example, go to: https://addons.mozilla.org/en-US/firefox/addon/1865
Start the install, and then, while the download bar fills, go to another page (go back, or go to Google, whatever).
Result: the download will stop, and a "Download error" message box will pop up.

Reproducible: Always
Comment 1 Dave Garrett 2009-01-11 10:45:30 PST
because: Download error
-228

I can confirm this. Have to be quick on the trigger to click to another page if it you download fast, but it does error if I go to my homepage before getting to the end. (during download or "wait" period in the beginning) Tested in 3.1b3pre on Linux.
Comment 2 Dave Garrett 2009-01-11 11:07:31 PST
Not sure if this is on the add-ons manager end or the AMO end. Might also be a dupe, but I can't find one.
Comment 3 Dave Garrett 2009-01-11 11:19:41 PST
After a bit of testing in a new profile, I've been able to reproduce this in both 3.1b3pre and 3.2a1pre but not 3.0.5.
Comment 4 Ria Klaassen (not reading all bugmail) 2009-01-11 11:33:08 PST
Seems to be something from last week November.
Comment 5 Fred Wenzel [:wenzel] 2009-01-11 11:42:26 PST
(In reply to comment #2)
> Not sure if this is on the add-ons manager end or the AMO end.

That sounds a lot like a client bug.
Comment 6 Ria Klaassen (not reading all bugmail) 2009-01-11 12:03:52 PST
Regression range is http://hg.mozilla.org/mozilla-central/pushloghtml?startdate=2008-11-28+05%3A00%3A00&enddate=2008-11-28+21%3A00%3A00
There is a Bug 462739, a Bug 454546 and a Bug 463882. 
BTW, for some reason I need to delete the profile after every test.
Comment 7 Dave Garrett 2009-01-11 12:07:31 PST
(In reply to comment #6)
> BTW, for some reason I need to delete the profile after every test.

Odd, I had no such problem here.
Comment 8 Ria Klaassen (not reading all bugmail) 2009-01-11 12:39:27 PST
(In reply to comment #7)
> (In reply to comment #6)
> > BTW, for some reason I need to delete the profile after every test.
> 
> Odd, I had no such problem here.

Clicking Cancel on the dialog in a unaffected build gave a false negative in a affected build.
Comment 9 Dave Townsend [:mossop] 2009-01-12 06:11:44 PST
Will backout bug 462739 to resolve this
Comment 10 Dave Townsend [:mossop] 2009-01-16 07:13:59 PST
Actually have a potential fix for this, but still working on developing unit tests for it.
Comment 11 Dave Townsend [:mossop] 2009-01-19 02:51:57 PST
I don't think we need this for b3, but we'll probably want to relnote it if it isn't fixed by then.
Comment 12 Dave Townsend [:mossop] 2009-01-29 04:34:18 PST
Created attachment 359502 [details] [diff] [review]
patch rev 1

This patch works by removing the request from the page's load group once the request has begun. This is after any necessary cookies have been added to the headers so does not regress bug 462739, but means that when the page is navigated away from the load group will no longer cancel the xpi request.

Tests for this exist in the test suite in bug 474763
Comment 13 Daniel Veditz [:dveditz] 2009-02-23 15:15:45 PST
Comment on attachment 359502 [details] [diff] [review]
patch rev 1

r/sr=dveditz
Comment 14 Dave Townsend [:mossop] 2009-02-24 08:58:34 PST
Landed: http://hg.mozilla.org/mozilla-central/rev/cd824b1dd0bb
Comment 15 Dave Townsend [:mossop] 2009-02-26 08:46:23 PST
Landed on branch: http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d1d3a589d096
Comment 16 Dave Townsend [:mossop] 2009-02-27 11:29:41 PST
Comment on attachment 359502 [details] [diff] [review]
patch rev 1

We need this on branch if we also want to fix bug 462739 there
Comment 17 Daniel Veditz [:dveditz] 2009-03-09 11:46:14 PDT
Comment on attachment 359502 [details] [diff] [review]
patch rev 1

Approved for 1.9.0.8, a=dveditz for release-drivers
Comment 18 Dave Townsend [:mossop] 2009-03-10 02:03:21 PDT
Landed on branch:

Checking in xpinstall/src/CertReader.cpp;
/cvsroot/mozilla/xpinstall/src/CertReader.cpp,v  <--  CertReader.cpp
new revision: 1.13; previous revision: 1.12
done
Checking in xpinstall/src/nsXPInstallManager.cpp;
/cvsroot/mozilla/xpinstall/src/nsXPInstallManager.cpp,v  <--  nsXPInstallManager.cpp
new revision: 1.167; previous revision: 1.166
done
Comment 19 Al Billings [:abillings] 2009-03-23 18:36:31 PDT
(In reply to comment #0)
> User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1b3pre) Gecko/20090110 Shiretoko/3.1b3pre (.NET CLR 3.5.30729)
> Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
> rv:1.9.1b3pre) Gecko/20090110 Shiretoko/3.1b3pre (.NET CLR 3.5.30729)
> 
> For example, go to: https://addons.mozilla.org/en-US/firefox/addon/1865
> Start the install, and then, while the download bar fills, go to another page
> (go back, or go to Google, whatever).
> Result: the download will stop, and a "Download error" message box will pop up.
> 
> Reproducible: Always

I cannot confirm this bug with these repro steps in 1.9.0.7 on XP (which is not surprising based on comment 3).

Note You need to log in before you can comment on or make changes to this bug.