Closed Bug 47418 Opened 19 years ago Closed 6 years ago

Application toolbars should be dockable/undockable/closable, as in Word or Photoshop

Categories

(SeaMonkey :: UI Design, enhancement, P5)

enhancement

Tracking

(Not tracked)

RESOLVED WONTFIX
Future

People

(Reporter: jhrussell, Unassigned)

References

Details

(Keywords: arch, helpwanted)

Disclaimer: kerz' idea

In posting this I'm thinking of new applications being made from Mozilla. We're 
proving very quickly that we (you, rather) can make a cross-platform UI rock, 
the next step would to be able to allow the user to undock any toolbar, and 
close it if they want, or restore it via the View menu. This should go all the 
way to fullscreen, in fact I think this bug could easily encompass bug 3341. The 
ability to close/restore toolbars would naturally involve being able to close 
them all, and have a Webtop, or whatever you want to call it.
Priority: P3 → P5
this would be cool... adding other potentially interested folx. also adding
helpwanted to see if other contributors could help out here.
Keywords: helpwanted
QA Contact: sairuh → claudius
requires docking windows. not sure if there's a RFE on that or not. 
See also bug 7696, which can probably be marked as a dup of this one (which has 
less noise) if this one is is expanded to include menus as well.
Has any work been done on this ?

Please e-mail me with good news, or a copy of the MDI XBL that was discussed in 
n.p.m.xpfe some time ago if anyone has it....
MDI? As in Quarterdeck's browser? :-)
Blocks: 92077
Keywords: arch, mozilla1.0, softui
-> Future.
Status: NEW → ASSIGNED
Target Milestone: --- → Future
adding self to cc list
Seems this one is far from making it for Mozilla 1.0? Let's keep the mozilla1.0
query as small as possible :)
Voting for this and adding self to cc list. 

This is probably one of the most important features (along with ability to
add/remove buttons) in order to give Mozilla a much wider audience. Too bad no
one cared about this in the beginning.

Actually, all elements should be movable/dockable, including the address field
and the menu. But I guess there's a different RFE for that.
Adding myself to the CC. What's the status of this now that 1.1 is out?
I think the way this could be done is to remove the toolbox widget and replace
it with these attributes on other elements:

    Dock: Top
          Bottom
          Left
          Right
          Float

    Row: numeric value
    Position: numeric value

The dock attribute would determine the edge of the parent element that the
toolbar was on.  Float being a floating toolbar within an element.

The row value would be the row of the toolbar when you have multiple toolbars. 
Like the top of the navigator window currently.

The position would be the position within a row.  If you had multiple toolbars
within the same row.
Any work being done on this? I think it would be great for a 2.0 target at least.
It appears that this would not ever appear on SeaMonkey, but on Firebird it
sounds a chance. Is it possible to re-assign the product to Firebird?
*** Bug 179411 has been marked as a duplicate of this bug. ***
What roadblocks exist to stop this bug from being fixed in the SeaMonkey branch?
Product: Core → Mozilla Application Suite
Assignee: bugs → guifeatures
Status: ASSIGNED → NEW
Filter "spam" on "guifeatures-nobody-20080610".
Assignee: guifeatures → nobody
QA Contact: claudius → guifeatures
Component: XP Apps: GUI Features → UI Design
Killing. Old.
Status: NEW → RESOLVED
Closed: 6 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.