Open Bug 477073 Opened 15 years ago Updated 1 year ago

"Check Spelling before sending" does not check misspelled words in the Subject

Categories

(Thunderbird :: Message Compose Window, defect)

x86
All
defect

Tracking

(Not tracked)

REOPENED

People

(Reporter: kyp, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: version3.0b2pre

I have the "Check Spelling before sending" option select.  This causes a spell check dialog box to appear after the send is selected.  The spelling of the body is done, but not the subject.

I would like this dialog to also check the subject line for misspelled words.


Reproducible: Always

Steps to Reproduce:
1. select "write" to compose a new mail message
2. enter a mis-spelled word, i.e. cheker
3. send the message
4. the misspelled word in the subject is not caught/checked
Actual Results:  
 the misspelled word in the subject is not caught/checked


The spell check dialog should flag the misspelled words and process it like misspelled words in the body.
I suspect the solution to bug 368915 will resolve this.
I see this in current trunk
Status: UNCONFIRMED → NEW
Component: General → Message Compose Window
Ever confirmed: true
OS: Mac OS X → All
QA Contact: general → message-compose
Maybe I'm wrong, but I thought it was supposed to highlight misspelled words even before hitting "send", but either way, the subject line is no longer being checked & I know it was working before b/c I remember celebrating when you guys added the feature in since Outlook always had it : )

P.S. I really really wish you'd get a better spell check. I've been complaining about this for years. Half the time this thing doesn't even find the simplest of mistakes & it has a lot of misspelled words in it's DB that I can't remove or fix.

Now I'm finding a lot of words that are correct that it's finding as mistakes & the DB has it like xxxx ed instead of "xxxxed" which is the correct word.

This happens a lot now & it wastes my time b/c then I have to go look it up in dictionary b/c I think I've made the mistake LOL.

Thanks guys


Michelle
Per comment 1, this little bugger is already known as bug 368915.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
I misunderstood this bug in my comment 4 -> reopening.

This bug is caused by the technical implementation whereby Subject and Body are technically two different texts, but for most purposes they should be considered as one.

Reporter is right that "Spell-check before sending" must certainly spell-check the Subject, too, not just the body (this bug).

Even if the spell-check dialog is triggered manually from body, I'd probably expect that we go through the subject as well. When triggered with focus in subject (currently not possible, unrecorded bug, the other half of bug 368915), just checking subject might do, probably with a notification like "finished checking subject" for clarity.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
See Also: → 369876
Severity: normal → S3

A friend of mine just recently complained about the same thing. He said the subject gets the red dots under misspelled words, but is not checked in 'Check spelling before sending'. I have confirmed this. It turned out this is by design:
https://searchfox.org/comm-central/source/mail/components/compose/content/MsgComposeCommands.js#5678
But I also think we should change this. If we check the spelling in the subject line, we also need to include it for 'Check spelling before sending', otherwise it's inconsistent. I will see if I can make patch for this.

You need to log in before you can comment on or make changes to this bug.