Closed Bug 478843 Opened 11 years ago Closed 11 years ago

/toolkit/xre/nsAppRunner.cpp:1424:6: error: #elif with no expression

Categories

(Toolkit :: Startup and Profile System, defect)

x86
Linux
defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: m_kato, Assigned: m_kato)

References

Details

(Keywords: fixed1.9.0.12, fixed1.9.1)

Attachments

(1 file)

Attached patch patch v1Splinter Review
When I build mozilla-central using gcc 4.4, nsAppRunner.cpp causes the following compiler error.

/home/makoto/mozilla-central/toolkit/xre/nsAppRunner.cpp:1424:6: error: #elif with no expression
gmake[1]: *** [nsAppRunner.o] Error 1
gmake[1]: Leaving directory `/home/makoto/mozilla-central/objdir-fx32/toolkit/xre'

$ gcc --version
gcc (GCC) 4.4.0 20090213 (Red Hat 4.4.0-0.18)
Copyright (C) 2009 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.
Attachment #362687 - Flags: review?(benjamin)
Attachment #362687 - Flags: review?(benjamin) → review+
checked in
http://hg.mozilla.org/mozilla-central/rev/9c0be870182f
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Comment on attachment 362687 [details] [diff] [review]
patch v1

Could we please have that in 1.9.1 as it would reduce the needed patching for upcoming Linux distributions.
Attachment #362687 - Flags: approval1.9.1?
Duplicate of this bug: 486688
Attachment #362687 - Flags: approval1.9.1? → approval1.9.1+
Keywords: fixed1.9.1
Comment on attachment 362687 [details] [diff] [review]
patch v1

Same for 1.9.0...
Attachment #362687 - Flags: approval1.9.0.12?
Attachment #362687 - Flags: approval1.9.0.11?
Attachment #362687 - Flags: approval1.9.0.11?
Attachment #362687 - Flags: approval1.9.0.12? → approval1.9.0.12+
Comment on attachment 362687 [details] [diff] [review]
patch v1

Approved for 1.9.0.12, a=dveditz for release-drivers
Assignee: nobody → m_kato
Keywords: checkin-needed
Whiteboard: [needs 1.9.0 landing]
fixed on 1.9.0.x branch

Checking in nsAppRunner.cpp;
/cvsroot/mozilla/toolkit/xre/nsAppRunner.cpp,v  <--  nsAppRunner.cpp
new revision: 1.218; previous revision: 1.217
done
Whiteboard: [needs 1.9.0 landing]
mistake keyword.
Duplicate of this bug: 489613
Blocks: songbird
Duplicate of this bug: 533222
You need to log in before you can comment on or make changes to this bug.