All users were logged out of Bugzilla on October 13th, 2018

250k increase in tracemalloc leaks from bug 468705

RESOLVED FIXED

Status

()

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: karlt, Unassigned)

Tracking

({regression})

Trunk
x86
All
regression
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 478948])

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
http://graphs.mozilla.org/#show=1473418,1473670,1474269&sel=1234540503,1234592474

Tinderbox shows an increase from revision b0337b6287f3 to 57e905485264.
http://tinderbox.mozilla.org/showbuilds.cgi?tree=Firefox&maxdate=1234607987&legend=0&norules=1
There are no intermediate revisions so this implicates bug 468705.
Perhaps it is caused by bug 478948, but this separate bug can track whether it is the same issue.

Comment 1

10 years ago
well if statements are not finalized the connection is not closed, so most likely we could leak history service
(In reply to comment #1)
> well if statements are not finalized the connection is not closed, so most
> likely we could leak history service
That's not true - at worst we might leak some of the sqlite connection.  If it was caused by bug 468705, this should be fixed by bug 478948.

Otherwise, I don't see how JS could be causing tracemalloc leaks.
(Reporter)

Comment 3

10 years ago
Created attachment 363351 [details]
diffbloatdump

From http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1234566926.1234568727.1948.gz

All the new leaks are using sqlite3Malloc.
Looks to me like this has been fixed.  Karl, can you confirm please?
(Reporter)

Comment 5

10 years ago
Yes, looks good to me, thanks.

-249664 malloc
  -249976 sqlite3MemMalloc[sqlite3 +0x415D]
    -249976 sqlite3Malloc[sqlite3 +0x47F4]
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED

Updated

10 years ago
Whiteboard: [fixed by bug 478948]
Filed bug 479543 to make the warnings go to errors.
You need to log in before you can comment on or make changes to this bug.