mail.identity.id?.sig_bottom cannot be set to "false" with "account settings : manage identities : edit : Composition & Addressing" dialog

RESOLVED DUPLICATE of bug 278453

Status

Thunderbird
Preferences
--
minor
RESOLVED DUPLICATE of bug 278453
9 years ago
9 years ago

People

(Reporter: Siegfried, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686 (x86_64); en-US; rv:1.8.1.4) Gecko/20070515 Firefox/2.0.0.4
Build Identifier: Thunderbird 2.0.0.19 (20081209)

Using multiple IDs associated to one account with TB 2.0.0.19 (20081209), I think I found a bug:
When using the "account settings : manage identities : edit : Composition & Addressing" dialog, the property mail.identity.id?.sig_bottom cannot be set to "false".

Setting the value to "false" for the default ID in the "account settings : Composition & Addressing" works fine.

When using the config editor to set the value for non-default IDs, it works properly, until the next time the first mentioned dialog is used.

(I suppose it's at the place in the code, where the choice status is evaluated.)



Reproducible: Always

Steps to Reproduce:
1. Use the "account settings : manage identities : add" dialog to create multiple identities for an account
2. Use the "account settings : manage identities : edit : Composition & Addressing" dialog to check "automatically quote..." and choose start my reply above the quote and place my signature below my reply (above the quote).
3. Use the ID you thus created (not hte default ID) to reply to a mail. You will see, that the signature is placed below the quote.
4. use the config editor to set the "mail.identity.id?.sig_bottom" property of the ID ? (? to be replaced by a number) of the ID you used. When you find the property you will see it set to true. If you change it to false, the behaviour will be as described in the dialog at step 2.
5. When you open the dialog from step 2 again, then you will find the choice set accordingly. When you quit it with "Ok", the property will be reset to "true" (use config editor or step 3 to check).
Actual Results:  
described within the steps to reproduce

Expected Results:  
described within the steps to reproduce
(Reporter)

Updated

9 years ago
Version: unspecified → 2.0

Comment 1

9 years ago
This has been fixed in Thunderbird 3.0.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 278453
You need to log in before you can comment on or make changes to this bug.