Can't save Signature Placement preference: reverts to default on multiple identities

VERIFIED FIXED in Thunderbird 3

Status

VERIFIED FIXED
14 years ago
5 years ago

People

(Reporter: chris, Assigned: rob)

Tracking

Thunderbird 3

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

14 years ago
I use Thunderbird with an IMAP email account.  I have several identities setup
in addition to the primary identity.  I set the composition and signature
settings for my reply and signature to both be above the quote.  It remembers
this setting on the primary identity, however on the additional identities it
only remembers the reply position.  I select to put the signature above and test
but it still puts it below the quote.  I go back into the settings and it has
reverted back to the default below quote setting.

Comment 1

14 years ago
I just want to pile on here.  I saw the exact same behavior on Thunderbird
20041206.  Any chance of getting this bug confirmed so that it can get fixed?

Comment 2

14 years ago
Is this related to bug 277187 ?

Comment 3

14 years ago
Not that I can tell.  It's not that the box is disabled, but that when you
change the position that it's not being saved correctly.  It only happens on the
alternate identities.  The primary identity works just fine.

Comment 4

14 years ago
Second that.  Exact same behavior on latest release.  Let's confirm this sucker
and get it fixed.

Comment 5

14 years ago
I confirm this behaviour. However directly in the jprefs.js file editing
the entry 
user_pref("mail.identity.id4.sig_bottom", false);
into false instead of true
results in the correct behaviour.
Apperently the update via the GUI does not work.

Comment 6

14 years ago
(In reply to comment #3)
> Not that I can tell.  It's not that the box is disabled, but that when you
> change the position that it's not being saved correctly.  It only happens on
> the alternate identities.  The primary identity works just fine.

I am seeing the exact opposite -- *only* the primary identity does not save that 
particular setting, as noted at bug 284058 comment 8; and the problem occurs 
only via the Manage Identities dialog -- if the change is made on the Account 
Settings' Composition Settings page, it sticks.  I see this with TB 1.0.2 and TB 
1.0+0414, Win2K.  Can you please retest?

Comment 7

14 years ago
*** Bug 291282 has been marked as a duplicate of this bug. ***

Comment 8

14 years ago
The only place that I saw the problem was in the Manage Identities dialog. I 
retested in 1.0.2 (20050322) and saw the exact same problem.  I'm running on 
Linux, not Windows. 

Comment 9

13 years ago
*** Bug 278293 has been marked as a duplicate of this bug. ***

Comment 10

13 years ago
Confirming this bug based on repeated reports, and updating the platform/OS 
based on comment 8.  As noted earlier, I cannot reproduce this exact symptom.  
Anyone who is encountering this bug, please state whether it's also taking place 
with TB 1.1a or other current nightlies.
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All

Comment 11

13 years ago
I am using TB 1.0.6 on Windows XP SP2 on a Dell Inspiron 510m running a Pentium
M processor 1.5Ghz and encounter the same problem where the secondary identities
do not save the settings for "place signature below my reply".

The following are the steps I took to reproduce the bug on the system.

Go to Tools -> Account Settings ->

Click on Manage Identities (doesnt matter which account)

If no additional identities exist, Add a new identity
Else, edit the ADDITIONAL identity only (in simple english, the email address
which is NOT the default)

In the Identity Settings dialog, select the Composition and Addressing Tab.

Select the checkbox Automatically quote the original message when replying.

Then select the dropdown "start my reply above the quote"

Then select the dropdown ... and place my signature "below my reply (above the
quote)"

Select the OK button.

Go to a message in the inbox and REPLY to a message WITH the additional identity
as the sender.

You will find that the signature is below the quote instead of above the quote.

My signature is a small html file conforming to snippets of W3C recommended
markup XHTML 1.0







Comment 12

13 years ago
I can confirm this bug.
I also confirm Comment #5: editing prefs.js manually works. After that, opening
the GUI-config changes it back according to the bug again.

One addition: Within the GUI-Account-Settings-editing, after I Edit the
signature-location for Identity foo@example.com, and click "OK", I go back to
"Identities for example.com". Then I can't click on foo@example.com anymore, it
won't turn "blue" as being selected.

(OS: Gentoo Linux, tested both TB 1.0.6 and the latest nightly build)

Comment 13

13 years ago
I second this bug.  I'm on TB 1.0.2 (20050317) for XP SP2 and those darn sigs
keep dropping below the reply! Editing prefs.js works.

Comment 14

13 years ago
Solvation:
Comment #5 is correct BUT just remember.....

Windows:
C:\Documents and Settings\[USERNAME]\Application Data\Thunderbird\Profiles\[SOMENUMBER].default

Open: prefs.js

IF you have several accounts then remember to edit:
(Standard is: "true")
user_pref("mail.identity.id1.sig_bottom", false);
user_pref("mail.identity.id2.sig_bottom", false);
user_pref("mail.identity.id3.sig_bottom", false);
user_pref("mail.identity.id4.sig_bottom", false);
etc.....

Comment 15

13 years ago
Thanks, that solves it!

Comment 16

13 years ago
I can confirm this behaviour in 1.5 as well. Tried the .js fix and it worked, but would be nice if the GUI would do that though.

Comment 17

13 years ago
*** Bug 324374 has been marked as a duplicate of this bug. ***

Comment 18

13 years ago
Im running TB 1.5 (20051201) and i can confirm that the .js fix, fix the problem, however when changing identities inside the composition windue it does add the new marked signature, but it forgets to remove the other signatur ... :(

Comment 19

13 years ago
(In reply to comment #18)
> Im running TB 1.5 (20051201) and i can confirm that the .js fix, fix the
> problem, however when changing identities inside the composition windue it
> does add the new marked signature, but it forgets to remove the other
> signatur ...

That's bug 218346.

Comment 20

12 years ago
*** Bug 344123 has been marked as a duplicate of this bug. ***

Comment 21

12 years ago
There's been a patch checked in (11 Jul) for bug 284058, which is similar to 
but distinct from this bug.  Scott said he couldn't see the fix working for 
that bug, but it seemed to fix it for me.

Could anyone who's experienced this problem check with 2a1 or a trunk build to see if it's still occurring?

Comment 22

12 years ago
I have this same issue and can confirm that in thunderbird-3.0a1.en-US.linux-i686.tar.bz2 it still exists.

Comment 23

12 years ago
*** Bug 353653 has been marked as a duplicate of this bug. ***

Comment 24

12 years ago
updating summary for searchability
Summary: Signature Preference reverts to default on multiple identities → Can't save Signature Placement preference: reverts to default on multiple identities

Comment 25

12 years ago
Still existing in Windows Thunderbird Beta 2

Updated

12 years ago
Duplicate of this bug: 373573

Updated

12 years ago
Duplicate of this bug: 373647
(Assignee)

Comment 28

12 years ago
Created attachment 258563 [details] [diff] [review]
Patch to save signature placement in secondary identities

We are implicitly casting a string to boolean when copying the control value back to the identity object during save. This doesn't work because any non-empty string evaluates to true. So I added an explicit conversion to the proper boolean value.
Attachment #258563 - Flags: review?
(Assignee)

Updated

12 years ago
Attachment #258563 - Flags: review? → review?(mscott)

Updated

12 years ago
Attachment #258563 - Flags: superreview?(neil)

Comment 29

12 years ago
Maybe it's because i am new. but how do i install this patch?

Comment 30

12 years ago
Comment on attachment 258563 [details] [diff] [review]
Patch to save signature placement in secondary identities

>+  identity.sigBottom = (document.getElementById('identity.sig_bottom').value == 'true') ? true : false;
The ?: is unnecessary because == already returns a boolean.
Attachment #258563 - Flags: superreview?(neil) → superreview+

Comment 31

12 years ago
Comment on attachment 258563 [details] [diff] [review]
Patch to save signature placement in secondary identities

r=mscott if you address Neil's comment
Attachment #258563 - Flags: review?(mscott) → review+
(Assignee)

Updated

12 years ago
Attachment #258563 - Attachment is obsolete: true
(Assignee)

Comment 32

12 years ago
Created attachment 258671 [details] [diff] [review]
Revised patch for saving signature placement

Removed unnecessary code per review comments. Please review and apply at your convenience.
Attachment #258671 - Flags: superreview?(neil)
Attachment #258671 - Flags: review?(mscott)

Comment 33

12 years ago
Comment on attachment 258671 [details] [diff] [review]
Revised patch for saving signature placement

You can remove the parens too. I don't need to re-review it. Thanks for the patch!
Attachment #258671 - Flags: review?(mscott) → review+

Comment 34

12 years ago
Comment on attachment 258671 [details] [diff] [review]
Revised patch for saving signature placement

And whomever removes the parens can remove that blank line I overlooked last time too, and that definitely doesn't need rereview, so when you're done, just put [checkin needed] on the whiteboard and one of the Mozilla interns should spot that and check it in for you.
Attachment #258671 - Flags: superreview?(neil) → superreview+
(Assignee)

Comment 35

12 years ago
Created attachment 258705 [details] [diff] [review]
Changed formatting

Changed formatting.
Attachment #258671 - Attachment is obsolete: true
(Assignee)

Comment 36

12 years ago
(In reply to comment #34)
> just put [checkin needed] on the whiteboard and one of the Mozilla interns should
> spot that and check it in for you.

Hmmm... how do I set the whiteboard field? Don't seem to have access. (Excuse my ignornace. This is my first patch to Mozilla.)

Comment 37

12 years ago
Thanks so much for the patch Rob!
Whiteboard: [checkin needed]

Updated

12 years ago
Assignee: mscott → rhasselbaum

Comment 38

12 years ago
Checked in, thanks Rob.
mozilla/mailnews/base/prefs/resources/content/am-identity-edit.js  1.11

> ...and one of the Mozilla interns
Or someone else, you know.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Whiteboard: [checkin needed]

Updated

12 years ago
Duplicate of this bug: 374791

Comment 40

12 years ago
Thank you, I've fixed this manually by changing .js file, but I think this is must fixed to allow user to change this option via the GUI, am I right?
(Assignee)

Comment 41

12 years ago
As I understand it, the fix was checked into the trunk, but not the branch used for TB 2.0. So it is not in 2.0.
Duplicate of this bug: 393995

Comment 43

11 years ago
(In reply to comment #14)
> Solvation:
> Comment #5 is correct BUT just remember.....
> 
> Windows:
> C:\Documents and Settings\[USERNAME]\Application
> Data\Thunderbird\Profiles\[SOMENUMBER].default
> 
> Open: prefs.js
> 
> IF you have several accounts then remember to edit:
> (Standard is: "true")
> user_pref("mail.identity.id1.sig_bottom", false);
> user_pref("mail.identity.id2.sig_bottom", false);
> user_pref("mail.identity.id3.sig_bottom", false);
> user_pref("mail.identity.id4.sig_bottom", false);
> etc.....
> 

Nikolaj, 

I was on version 2.0.0.6 (20070728) and this silly bug has still not been fixed!?  I followed your method above and it worked beautifully for me.  Finally this has been solved.  Thanks!
(Assignee)

Comment 44

11 years ago
See comment #41.

Updated

11 years ago
Duplicate of this bug: 430666

Updated

10 years ago
Duplicate of this bug: 440775

Updated

10 years ago
QA Contact: account-manager
Target Milestone: --- → Thunderbird 3

Updated

10 years ago
Duplicate of this bug: 444476

Updated

10 years ago
Duplicate of this bug: 441242
See Bug 441242 for additional info.
This is confirmation that the issue has been resolved in Vista Home Premium,
Shredder version 3.0a2pre (2008071503). Thank you.

Updated

10 years ago
Duplicate of this bug: 453443

Updated

10 years ago
Duplicate of this bug: 471637

Updated

10 years ago
Duplicate of this bug: 473954

Updated

10 years ago
Duplicate of this bug: 476194

Comment 55

10 years ago
Thank you for resolution of this bug!

Updated

10 years ago
Status: RESOLVED → VERIFIED

Updated

10 years ago
Duplicate of this bug: 479612

Comment 57

10 years ago
Please, reopen this bug for Shredder 3.0b3pre (20090327)
I have:
- 2 identities, one with signature, other without
- signatures to start above quoted text
- place signature above quoted text (below reply)

When replying, the signature doesn't go away when switching to tne 'no signature' identity and I end up with 2 signatures stacked if I change back and they keep stacking if I keep changing.

Updated

10 years ago
Flags: wanted-thunderbird3?
(In reply to comment #57)
Your issue seems like it is somewhat different. I am using TB trunk, and not seeing any issue at all at all. So maybe open a new bug.
Flags: wanted-thunderbird3?

Updated

9 years ago
Duplicate of this bug: 499625

Updated

9 years ago
Duplicate of this bug: 521530

Updated

9 years ago
Duplicate of this bug: 524046

Updated

8 years ago
Duplicate of this bug: 565110

Updated

5 years ago
Duplicate of this bug: 365927
You need to log in before you can comment on or make changes to this bug.