Global History context menu

VERIFIED FIXED in mozilla0.9.4

Status

()

Core
History: Global
P2
normal
VERIFIED FIXED
18 years ago
17 years ago

People

(Reporter: torbjorn, Assigned: Blake Ross)

Tracking

({polish})

Trunk
mozilla0.9.4
polish
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
(This is Mozilla M17, Build ID 2000080712, with Fullcircle. For some reason, my
only obtion listed above is "other" which, while perfectly true, doesn't seem
very helpful.)

Right-clicking in the History window brings up a tiny (approximately 5x5 pixels)
square. My guess is that it's the world's smallest pop-up menu and a placeholder
for future features, but I figured I'd mention it anyway.

I've configured Mozilla to use the "Classic" GUI, which might make a difference.
I haven't tried it with the default one. (Yeah, I know, I should have.)
over to slamm..
Assignee: radha → slamm

Comment 2

18 years ago
confirming with build from the tip 8/9 on NT4
Status: UNCONFIRMED → NEW
Ever confirmed: true

Comment 3

18 years ago
doh... cc myself
(Assignee)

Comment 4

18 years ago
Yeah.  We need some items for this menu.  slamm's gone, over to me.
Assignee: slamm → blakeross
Severity: trivial → normal
OS: Windows 98 → All
Hardware: PC → All
Summary: Right-click in history windows brings up tiny square → History items need functional context menu
Target Milestone: --- → mozilla1.0
(Assignee)

Comment 5

18 years ago
*** Bug 48791 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
Suggested context menu (updated from the version in bug 61178):

  Open                  [disabled if no Navigator window is open]
  Open in New Window
----------------------
  Add to Bookmarks
  Copy Link
  Delete

This isn't a final spec by any means (items will probably need rearranging in the 
future to make them more consistent with other context menus), but it's much 
better than nothing.
Blocks: 61178

Comment 7

18 years ago
taking this from blake for now.. lemme know if you beat me to it
Assignee: blakeross → alecf
Summary: History items need functional context menu → Global History context menu
nav triage team: yes we shd fix this
Keywords: nsbeta1
Priority: P3 → P2
(Assignee)

Comment 9

18 years ago
didn't even see this leave my list...

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.8

Updated

18 years ago
Component: History: Session → History: Global

Comment 10

18 years ago
*** Bug 68017 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
moving key 0.8 bugs that didn't make it to 0.9
(yes, these are important enough to keep, yadda yadda)
Target Milestone: mozilla0.8 → mozilla0.9

Comment 12

18 years ago
that's right, yadda, yadda, right past beta1. Marking nsbeta1-, resetting target
milestone
Keywords: nsbeta1 → nsbeta1-, polish
Target Milestone: mozilla0.9 → ---

Updated

18 years ago
Target Milestone: --- → mozilla1.0

Comment 13

17 years ago
putting back on radar, marking nsbeta1+
Keywords: nsbeta1- → nsbeta1+

Updated

17 years ago
Blocks: 71401
(Assignee)

Comment 14

17 years ago
Taking if alec doesn't mind, will do this as part of the rewrite to use 
outliner...
Assignee: alecf → blakeross
Status: ASSIGNED → NEW
(Assignee)

Comment 15

17 years ago
*** Bug 61178 has been marked as a duplicate of this bug. ***
(Assignee)

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: mozilla1.0 → mozilla0.9.3
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla1.0
(Assignee)

Updated

17 years ago
Target Milestone: mozilla1.0 → mozilla0.9.3
(Assignee)

Updated

17 years ago
Target Milestone: mozilla0.9.3 → mozilla0.9.4
(Assignee)

Comment 16

17 years ago
usability/polish, 0.9.4.
(Assignee)

Comment 17

17 years ago
Right now I'm just going to disable add bookmark for multiple items.  Or is it
okay to not show the dialog when you have multiple items?
(Assignee)

Comment 18

17 years ago
Created attachment 43916 [details] [diff] [review]
patch
(Assignee)

Comment 19

17 years ago
Fix checked in.  Please file a new bug on me to support context menus on folders.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED

Comment 20

17 years ago
VERIFIED Fixed with 20010907 builds. I filed bug 98776 on blake to support
context menus on folders since they still aren't supported and i couldn't find
another bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.