Samba links are handled incorrectly

RESOLVED DUPLICATE of bug 122022

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 122022
8 years ago
7 years ago

People

(Reporter: Joel Goguen, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.0.6) Gecko/2009020519 Ubuntu/9.04 (jaunty) Firefox/3.0.6
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090220 Lightning/1.0pre Shredder/3.0b3pre

Emails from windows users in the corporate setting often include links to files on windows servers. Linux users should be able to operate transparently in this space. So in outlook if I drag in a link to a file in an email you get a hyper link like this:
"\\servername\path\to\file\file.ext"

When receiving such an email I have to edit the link to "smb://servername/path/to/file/" and paste into Nautilus.  Thunderbird should follow those links transparently to the user.

On the composing side, if I drag in a link from Nautilus I get "smb://servername/path/to/file/file.ext" which should get changed to "\\servername\path\to\file\file.ext" so as to be universally usable.

Reproducible: Always

Steps to Reproduce:
1. Receive an email containing a link in the form: \\servername\path\to\file\file.ext
Actual Results:  
When receiving, the link is not clickable, and it is not in a form recognized by Nautilus or Dolphin. When sending, the link is not converted into the form expected by Windows clients.

Expected Results:  
When receiving, the link should be able to be opened by clicking on it, regardless of whether it's "smb://servername/path/to/file/file.ext" or "\\servername\path\to\file\file.ext".  When sending, links should be converted to the latter format so Windows clients can also use them as-is.

Updated

8 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 73003

Comment 2

8 years ago
Not a dupe 73003.
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
(Reporter)

Comment 3

8 years ago
Created attachment 365312 [details]
Web page demonstrating the bug in Firefox

This is also a problem in Firefox.  I'm not sure if that makes this bug against Core or something else, but putting links of either form in a web page and viewing with Firefox does not work as expected.  Links in the form \\servername\path\to\file\file.ext are converted to HTTP links relative to the current web page directory, and links of the form smb://servername/path/to/file/file.ext are displayed as SMB links, but clicking them does nothing.

Comment 4

8 years ago
As I see, there's 3 different bugs:
1. Make UNC-paths clickable (hmmm....maybe bug 379337)
2. Nautilus links are SMB instead of UNC (bug 378425)
3. smb:// links in Firefox doesn't work (probably bug 84128 or bug 122022)
Version: unspecified → Trunk

Comment 5

8 years ago
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1b3pre) Gecko/20090324

I can reproduce this issue on the above version.
(In reply to comment #4)

> 3. smb:// links in Firefox doesn't work (probably bug 84128 or bug 122022)

Hansen why did you not dup it to those ?

Comment 7

8 years ago
Because I didn't know which one to dupe as. I was hoping Joel would resolve it.
Joel if you think this is incorrect please reopen.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 84128
(Reporter)

Comment 9

8 years ago
I'm honestly not certain which one I would dupe this as, so I'll happily accept this.  I've got some ideas I'll submit to bug 84128 later tonight.

Comment 10

8 years ago
How can a Thunderbird bug be duped to a Seamonkey bug? Are you sure?
(In reply to comment #10)
> How can a Thunderbird bug be duped to a Seamonkey bug? Are you sure?

Right got confused by the title of bug 122022
Duplicate of bug: 122022

Updated

7 years ago
You need to log in before you can comment on or make changes to this bug.