The default bug view has changed. See this FAQ.

Cannot attach files from smb://

NEW
Unassigned

Status

Thunderbird
Message Compose Window
10 years ago
a year ago

People

(Reporter: Bart Heinsius, Unassigned)

Tracking

(Depends on: 1 bug, Blocks: 1 bug)

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; nl; rv:1.8.1.3) Gecko/20061201 Firefox/2.0.0.3 (Ubuntu-feisty)
Build Identifier: version 2.0.0.4pre (20070422)

Sending email with attachmant located on an smb location gives error:

Sending of message failed.
There was an error attaching smb://arsenaal/test.txt. Please check if you have access to the file.

thanks for your support.
regards Bart.


Reproducible: Always

Steps to Reproduce:
1. Compose a new email
2. Drag a document from Nautilus browsing an smb location, to the email
3. Send
Actual Results:  
Send Message Error:
Sending of message failed.
There was an error attaching smb://arsenaal/test.txt. Please check if you have access to the file.

Expected Results:  
Email was sent with attachment

Updated

9 years ago
Assignee: mscott → nobody

Comment 1

8 years ago
Dear Thunderbird developers,

indeed, I am encountering the same problem. First, through the usual "add attachment" dialogue it is not possible to attach a file from a Samba filesystem.

The "solution" to drag and drop files from Nautilus to Thunderbird does not work either as described above.

At work, all data are saved in Samba filesystems, and it is very annoying not being able to access those from within Thunderbird. Always making a local copy of the file is not a solution.

Thanks for your work
Aldi
Duplicate of this bug: 494273

Comment 3

8 years ago
Isn't the package thunderbird-gnome-support (debian/ubuntu) supposed to provide access to the GnomeVFS? If so, it does not work.

Are there any solutions or workaround to this problem?

Updated

8 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Cannot attach smb file → Cannot attach files from smb://

Comment 4

7 years ago
As I described little over a year ago that this issue still prevails. Is there any workaround? Is there anybody working on this issue?

In my opinion, this is a very important bug/feature if one wants to use Thunderbird under Linux in office environments!
Blocks: 564148

Comment 5

7 years ago
Workaround:

Are we talking about Ubuntu Linux here?
If you use the standard GUI way to add a smb-share
Places > Connect to Server > Windows-Share then the
problem still exists in TB 3.0.8 and TB 3.3a1pre.
Adding a file by drag and drop results in the
shortcut pointing to smb://... and saving/sending
results in the error message.

But a possible workaround is to really mount the
smbshare and not use that crippled GUI-stuff :)

I describe the temporary mount here, to permanemtly
mount the share use an entry in /etc/fstab.

------

First you need mount.cifs
(Description is for Ubuntu/Debian)

sudo apt-get install smbfs

Then create a mount point, e.g.

mkdir ~/mount

Then mount the share

sudo mount.cifs //192.168.0.2/shared /home/<username>/mount -o username=user3,password=secret

Further questions answered here :)

man mount.cifs

The share is now mounted to ~/mount. Drag and drop from that
directory works like a charm.

Comment 6

6 years ago
Sending a ping regarding this bug. Network storage is becoming more and more important. In many work environments, most of the documents are located on SMB-shares. Please have a look at this bug and please consider fixing it.

@Markus W.: Thank you very very much for your workaround. I used your workaround and it worked fine, although I always encounter problems with the German umlauts äüöß and it is difficult to handle, if there are many SMB-shares in the network (like it is here). But, indeed, until this bug will be fixed, it seems to be the only possibility. Thanks.

Comment 7

5 years ago
As SMB-Shares in offices and also for home use are becoming more important everywhere, could this bug be considered for future Thunderbird versions? I would be very grateful. 
Thanks, Gerald

Comment 8

5 years ago
Bug #682838 is related. We need working GIO file handling.
Depends on: 682838

Comment 9

5 years ago
This 2012 and this bug is still very much alive. This has been a huge problem in Thunderbird (Mac) for years and I can't solve it. I have had to forgo many very important business or personal emails because they simply wouldn't send with the attachments or photos. Isn't this a basic service that all email programs should provide? I can't change email providers because so many thousands of email in TB. Please help Thunderbird, in layperson's language. I need a solution.

Comment 10

5 years ago
It's a shame, this still doesn't work. Here's a workaround that requires maybe less manual work than described above:

1. In nautilus (click home folder icon), open the share. This will automatically mount the share to $HOME/.gvfs
2. In thunderbird click attach, click you home, press Ctrl+l, type .gvfs, hit enter, find the files you need, select them and click open

The above solution is almost identical to what Markus described with the difference, that the mounting is done by gnome. The drawback is the hidden directory where the share is mounted.

Comment 11

2 years ago
I am using XUbuntu 14.10, Thunderbird 31.3.0 and dragging and dropping from a Thunar mounted SMB share gives the same error like described in the original bug report.

The only workaround it seems is to navigate to /run/user/1000/gvfs/ (where 1000 is equal to the logged in user ID) and find the mount folder there.

Comment 12

a year ago
Seems like the gio handling is done but the user interface hides the remote locations. It is probably just a one liner fix with an additional call to 

https://developer.gnome.org/gtk3/stable/GtkFileChooser.html#gtk-file-chooser-set-local-only

Comment 13

a year ago
This affects to firefox as well!

Comment 14

a year ago
(In reply to Feng Yu from comment #12)
> Seems like the gio handling is done but the user interface hides the remote
> locations. It is probably just a one liner fix with an additional call to 
> 
> https://developer.gnome.org/gtk3/stable/GtkFileChooser.html#gtk-file-chooser-
> set-local-only

It's not so easy - see Bug 682838

Comment 15

a year ago
(In reply to Feng Yu from comment #13)
> This affects to firefox as well!

And affects Windows as well too! I cannot attach files from SMB drives on Windows nor Linux. FF44.

Comment 16

a year ago
Hi All,
I have this problem on OSX 10.6.8 and I found a workaround: I created an "alias" pointing to the shared folder on the Desktop, and from the Thunderbird dialog, "opening" the alias (instead of the actual shared folder) magically gives it access to the shared folder as if no problem ever existed. 
Cheers
You need to log in before you can comment on or make changes to this bug.