Insert Image no longer works in 2.0 or 3.0b2

RESOLVED INCOMPLETE

Status

--
major
RESOLVED INCOMPLETE
10 years ago
9 years ago

People

(Reporter: jfoster, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3pre) Gecko/20090223 Thunderbird/3.0b2

Write new email to gnail, yahoomail or dotmac address
Type some text
Insert image (the image shows up as it should)(the attach check box is checked)
type more text
Recipient does not see the inserted image
Sender does not realize that the data has been lost in transmission of email
Sender is unaware of the bug even occurring
This has worked for me for years and now no longer works. It seems to work just fine for other testers, so the problem seems not to be in the app, but in the other Thunderbird related files not affected by the app version
Is their some file repair or migration procedure available to fix this problem?

Reproducible: Always

Steps to Reproduce:
1.Insert image (the image shows up as it should)(the attach check box is checked)
2.type more text
3.Recipient does not see the inserted image
4.Sender does not realize that the data has been lost in transmission of email
5.Sender is unaware of the bug even occurring
Actual Results:  
1.This has worked for me for years and now no longer works.
2.It seems to work just fine for other testers, so the problem seems not to be in the app, but in the other Thunderbird related files not affected by the app version
3.Is their some file repair or migration procedure available to fix this problem?

Expected Results:  
I expected that trying the 3.0b2 would cure this defect that suddenly occurred in 2.0

1.This has worked for me for years and now no longer works in 2.0 or 3.0b2.
2.It seems to work just fine for other testers, so the problem seems not to be in the app, but in the other Thunderbird related files not affected by the app version
3.Is their some file repair or migration procedure available to fix this problem in the files or file structure not related to the app itself?

Comment 1

10 years ago
Do you see the image in the copy stored in your Sent folder? This is the encoding how the message went out to the mail server.

In addition, if it only happens to certain e-mail domains, it would appear probable that some intermediate server strips off the images whereas others don't. In this case, you should see the images in the Sent folder copies.

If they don't show up in the Sent folder either, check your settings in Thunderbird > Preferences > Composition > General > Send Options. The domains you mention may be listed as plain-text domains.

Comment 2

10 years ago
can you cite something more specific that 2.0 - 2.0 covers a 2 year time span
Severity: critical → major
(Reporter)

Comment 3

10 years ago
On looking carefully at settings in
Thunderbird > Preferences > Composition > General > Send Options, when I selected the drop down menu item to the choice of "Send message in both plain text and HTML" the defect went away with this work around.

A user has no way of knowing that his inserted image will not be sent with some settings of those send options. A warning about inserting images not being appropriate ( yeah I know, state the obvious) for receipt by text only recipients, might keep others from noticing that trap that suddenly, after a long time of usage, unaware that inserted images were not being sent.

Insert image needs some sort of caution pop up, or menu explanation for the user to avoid unintended results of the inserted image not being sent.

Updated

10 years ago
Whiteboard: dupeme
(Reporter)

Comment 5

10 years ago
From reading the two xref bugs, it looks like this unintended pitfall for users has been around for a long time.

Will anyone care to tidy up the UI to avoid this unintended consequence of not knowing an inserted image has in fact not been sent?

Or, 2000 bug reports later than 274992 will this issue again be just blown off?

Comment 6

10 years ago
(In reply to comment #4) This here doesn't seem to be related to either bug:
> Bug 310948

was specific for Mac OSX and resolved by a combination of various other fixes. Since reporter states "the image shows up as it should" this can be excluded as the cause here.

> Bug 274992

Appears to be on pasting into the editor of a page (e.g., web-mail interface).
It is my understanding that Thunderbird's editor was used, not in a web access.

> (In reply to comment #3) On looking carefully at settings in
> Thunderbird > Preferences > Composition > General > Send Options, when I
> selected the drop down menu item to the choice of "Send message in both plain
> text and HTML" the defect went away with this work around.

Do you remember what the setting of that option was before you changed it?
(Reporter)

Comment 7

10 years ago
It was "Convert the message to plain text".

I have no memory of ever playing with the Thunderbird Preferences let alone drilling down that far to change something, the consequences of which were unknown to me ( including at least the unintended blocking of inserted images from being sent).

Is there some sort of configuration log file for Thunderbird that would track what really went on in the history of my use? My perception of my interaction with Thunderbird is not necessarily reality.

Is there any other alert button choice I might have clicked through without knowing how that affected the preferences?

Thunderbird has been my choice from the git go, To get he same "Insert Image" feature in Gmail with images from my hard drive for example, I have to prepare the document in Google docs, or have the images already up there somewhere in the web cloud, not on my local hard drive. So this "unintended pit fall" is a big deal for me. (grin)

Updated

10 years ago
Whiteboard: dupeme

Comment 8

10 years ago
the bugs I cited were merely examples - there are more. the following query adds seamonkey. pick and choose. 

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=anywordssubstr&short_desc=image+gif+jpg+graphic&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&product=MailNews+Core&product=SeaMonkey&product=Thunderbird&resolution=INVALID&resolution=WONTFIX&resolution=EXPIRED&resolution=---&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=enhancement&emailreporter1=1&emailtype1=substring&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=short_desc&type0-0-0=anywordssubstr&value0-0-0=insert+past+copy&field1-0-0=short_desc&type1-0-0=nowordssubstr&value1-0-0=crash


product=core 

https://bugzilla.mozilla.org/buglist.cgi?query_format=advanced&short_desc_type=anywordssubstr&short_desc=image+gif+jpg+graphic&long_desc_type=allwordssubstr&long_desc=&bug_file_loc_type=allwordssubstr&bug_file_loc=&status_whiteboard_type=allwordssubstr&status_whiteboard=&keywords_type=allwords&keywords=&product=Core&component=Drag+and+Drop&component=Editor&component=Selection&resolution=INVALID&resolution=WONTFIX&resolution=EXPIRED&resolution=---&bug_severity=blocker&bug_severity=critical&bug_severity=major&bug_severity=normal&bug_severity=minor&bug_severity=enhancement&emailreporter1=1&emailtype1=substring&email1=&emailassigned_to2=1&emailreporter2=1&emailqa_contact2=1&emailtype2=substring&email2=&bugidtype=include&bug_id=&votes=&chfieldfrom=&chfieldto=Now&chfieldvalue=&cmdtype=doit&order=Reuse+same+sort+as+last+time&field0-0-0=short_desc&type0-0-0=anywordssubstr&value0-0-0=insert+past+copy&field1-0-0=short_desc&type1-0-0=nowordssubstr&value1-0-0=crash
John anything looking like the list of bug wayne posted ?
Whiteboard: closeme 2009-07-02

Comment 10

9 years ago
Resolving incomplete after this had been marked "closeme" for a while now, and there is not enough information to figure out what actually happened and why the preference setting apparently flipped. Feel free to reopen if further steps to reproduce become available.

-> INCO
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INCOMPLETE
Whiteboard: closeme 2009-07-02
You need to log in before you can comment on or make changes to this bug.