Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Unix Mailspool never retrieves new mail by time delay or during startup

VERIFIED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Movemail
VERIFIED FIXED
9 years ago
7 years ago

People

(Reporter: RichJ, Assigned: Markus W)

Tracking

Trunk
Thunderbird 3.3a1
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.6) Gecko/2009011912 Firefox/3.0.6
Build Identifier: version 2.0.0.19 (20081209)

'Check for new mail on startup' and 'check for new mail every 2 mins' are set.
I restarted it several times and waited upto 10 minutes for new mail. The only method to get new mail is by click the 'Get Mail' button.   I verified there was new mail in the mbox with mailx from cmd line, a new letter was sitting in the Inbox for 10 minutes, the poller does not see it.



Reproducible: Always

Steps to Reproduce:
1. Set the account check mail on startup
2. Set the account to check mail every 2 or 5 minutes

Actual Results:  
On startup the message in the status display, "There are no new messages on server"

Expected Results:  
There should be new mail as one email was sitting in mbox for 10 minutes.



Also, after some testing I decided to change back the settings so the pop3 poller can retrieve the mail.  I disabled the poller in the Unix mailspool account.  This seems to have affected the pop3 poller as it stopped automatically retrieving mail.  I removed the mailspool account, the poller was still not working.  I then restarted TB and the poller began to operate as normal.  I tried reading the mailspool account, but I poller worked as normal for the pop3. So it might be an initial setting.
Ricj - can you reproduce ? and if you can can you attach pop" logs to this bug , this is documented at https://wiki.mozilla.org/MailNews:Logging ?
Component: General → Networking: POP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.pop
Version: unspecified → 1.8 Branch

Updated

9 years ago
Component: Networking: POP → Movemail
QA Contact: networking.pop → movemail

Comment 2

9 years ago
(A very old fixed issue was bug 201055).

Do try a build from 
http://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-comm-central/
http://www.mozillamessaging.com/en-US/thunderbird/early_releases/
Duplicate of this bug: 481916
I can confirm this on trunk in at least some circumstances (my test account currently only holds a movemail account and the requisite local folders). An error thrown from nsIPK11Token.checkPassword on line 576 of msgMail3PaneWindow.js seems to cause the login code to fail to be executed...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 522530

Comment 6

8 years ago
(In reply to comment #5)
> *** Bug 522530 has been marked as a duplicate of this bug. ***

Thanks Joshua for the pointer (to here).

I can confirm that this bug still exists in TB 3.0b4 (built from source on linux and from the distributed linux binary).

Comment 7

8 years ago
This bug still exists in TB 3.0rc1

Comment 8

8 years ago
This bug still exists in TB 3.0rc2

Comment 9

8 years ago
Also note that TB 3.0 rc2 uses the 1.9.1 branch.

Comment 10

8 years ago
I can confirm this is still a bug in the Thunderbird 3.0 release binary (running on a SuSE 11 linux desktop).
Not necessary to report the problem still exists, unless you know of a fix that was applied that is expected to resolve the issue.
Duplicate of this bug: 561838
(Assignee)

Comment 13

7 years ago
Possible workaround (works fine for me):

Found here:
http://forums.mozillazine.org/viewtopic.php?f=39&t=476029

I will describe it again:

You have to add some values to your prefs.js.
Adding them with a text editor did not work for me, they are removed
at Thunderbird startup.

Add the values with Thunderbirds buildin-configuration-editor:

Tools > Options > Advanced > General > Config Editor

The following key should already be present, else - add it.
(Right click - Add - Boolean)

Change "server3" to fit your account.

user_pref("mail.server.server3.check_new_mail", true);

Add the following key, set to "false" first, it was removed
when I was trying to add as "true"...

user_pref("mail.server.server3.download_on_biff", false); 

Then restart Thunderbird, the key should still be present,
and set to "true.

user_pref("mail.server.server3.download_on_biff", true);

Restart Thunderbird again. New mails should be fetched on startup.

I additionally added 

user_pref("mail.server.server3.check_time", 2);

so I did not have to wait the standard interval of
10 minutes to see if it works. DonĀ“t know if its necessary.

Hope this helps.

Comment 14

7 years ago
Thanks a bunch, it works for me!
(Assignee)

Comment 15

7 years ago
I will try to fix this bug and submit a patch.

How can I assign the bug to myself?
Assignee: nobody → homerun4711
Status: NEW → ASSIGNED
(Assignee)

Comment 16

7 years ago
Created attachment 482086 [details] [diff] [review]
Add "Automatically download new messages" to Unix Movemail accounts (equals "download_on_biff")

Due to the missing "Automatically download new messages" checkbox 
in ServerSettings - Unix Movemail accounts, new messages could not
be retrieved at Thunderbird startup or at specified time intervals.

The checkbox was set to "hidefor movemail" in the file "am-server.xul"
and was present in the section named <!-- POP3 -->

Now there is a new section named
<!-- Necessary for POP3 and Movemail (Bug 480945) -->
and the attribute hidefor movemail is removed.

The patch works fine. Mails are retrieved as expected.
The checkbox is visible and if checked,
the value "download_on_biff" "true" is added to the prefs.js.
Attachment #482086 - Flags: ui-review?(clarkbw)
Attachment #482086 - Flags: review?(dmose)
(Assignee)

Updated

7 years ago
Version: 1.8 Branch → Trunk
Comment on attachment 482086 [details] [diff] [review]
Add "Automatically download new messages" to Unix Movemail accounts (equals "download_on_biff")

This seems fine to me.  AFAIK The change is pretty limited and only adds an option to Movemail accounts which is already available for POP accounts.  So ui-r+ from me.
Attachment #482086 - Flags: ui-review?(clarkbw) → ui-review+
Comment on attachment 482086 [details] [diff] [review]
Add "Automatically download new messages" to Unix Movemail accounts (equals "download_on_biff")

This seems fine, r=Standard8
Attachment #482086 - Flags: review?(dmose) → review+
Keywords: checkin-needed
Checked in: http://hg.mozilla.org/comm-central/rev/7ef9af322783

Thanks for the patch.
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago
Keywords: checkin-needed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
Mozilla/5.0 (X11; Linux i686; rv:2.0b8pre) Gecko/20101026 Firefox/4.0b8pre SeaMonkey/2.1b2pre - Build ID: 20101026021317

Nowadays (and, of course, with the proper "Server settings" for my Movemail account) SeaMonkey downloads and empties /var/spool/mail/<username> without human intervention, and the "internal emails" appear in its mail folders. => VERIFIED.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.