Move folders between gmail IMAP accounts leaves source messages behind

RESOLVED INVALID

Status

RESOLVED INVALID
10 years ago
9 years ago

People

(Reporter: lifers, Unassigned)

Tracking

1.8 Branch
x86
Windows Vista

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: dupme)

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-GB; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: version 2.0.0.19 (20081209)

When drag and dropping folders between two GMail IMAP accounts, the source messages and folder are left undeleted. TB performs a copy.

Further, the status bar says "Copying message 1 of x to y".

When the messages are selected and right-click -> Move to -> Select Folder, the messages are moved correctly but the status bar also says "Copying message..."

Reproducible: Always

Steps to Reproduce:
1. Connect to 2 GMail IMAP accounts via SSL, set Max Connections to 10, Set Delete to Immediately
2. Drag a folder from one GMail to another

Actual Results:  
Destination is copied to correctly however source folder remains. 

Expected Results:  
Destination copied to and source deleted.
Component: General → Networking: IMAP
Product: Thunderbird → MailNews Core
QA Contact: general → networking.imap
Whiteboard: dupme
Version: unspecified → 1.8 Branch
Blocks: 402793
(In reply to comment #0)
> When drag and dropping folders between two GMail IMAP accounts, the source
> messages and folder are left undeleted. TB performs a copy.

Read Bug 471162 Comment #5, please. See also Bug 471336.
To lifers@gmail.com(bug opener):
Are you requesting new "move" functionality for "Drag&Drop of mail folder between accounts"? If yes, this bug should be Severity=Enhancement, because Tb currently works as designed.

This bug is never Gmail IMAP related, so removing dependency to Bug 402793.
No longer blocks: 402793
Lifers could you answer Wada's question ?

Comment 5

9 years ago
drag drop between accounts always does a copy by default. Shift drag+drop will do a move between accounts.
This works - resolving invalid.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.