Last Comment Bug 483355 - Clear Recent History/Private Data no longer optional at browser close
: Clear Recent History/Private Data no longer optional at browser close
Status: RESOLVED WONTFIX
:
Product: Firefox
Classification: Client Software
Component: Private Browsing (show other bugs)
: unspecified
: x86 Linux
: -- normal (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
Mentors:
: 499286 502219 (view as bug list)
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-13 21:55 PDT by Michael K
Modified: 2010-02-24 06:29 PST (History)
10 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Michael K 2009-03-13 21:55:13 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3

Previously user could select optio to allow Preferences to automatically clear Recent History/Private Data (RH/PD)or to have a dialog pop up to ask if you wanted to clear RH/PD.  This has been removed from FF3.1b3.

There are times wher one may want to generally clear RH/PD on exit, but due to browser issue or other reason, to NOT want to clear the RH/PD for that session, and to have it re-appear upon next browser reload.

Please reinstate the option to ask the user if they want to clear their RH/PD.

Reproducible: Always

Steps to Reproduce:
1. If "Always clear my private data" is checked.  
2. Close Browser
3. No option is offered to save or delete RH/PD for this session as in prior versions.

Actual Results:  
See above for explanation.

Expected Results:  
See above for explanation.

Also I see some confusion to the terminology (RH/PD) - do get that resolved. :)
Comment 1 Michael K 2009-03-13 22:22:29 PDT
http://forums.mozillazine.org/viewtopic.php?f=23&t=1128505
"Say I am debugging a video issue that crashes browser and I am in the process of filing a bug report on this. when browser closes I now have to go log in again and find my bug, because this one time I did NOT want things cleared."
Comment 2 :Ehsan Akhgari 2009-03-14 00:04:43 PDT
This was done in bug 469158.  Based on the rationale in that bug, I think this is WONTFIX.
Comment 3 Alex Faaborg [:faaborg] (Firefox UX) 2009-03-14 20:34:42 PDT
The plan for privacy prefpane UI is to allow users to clear their private data on close (as a separate option in addition to the option of being in always on private browsing mode) since this data can be useful during the browsing session, like purple hyperlinks and form auto-complete being valuable to the user.  However, we are planning on removing the dialog that asks the user every time before clearing private data, in an effort to eventually remove all open and close dialogs in Firefox.

>http://forums.mozillazine.org/viewtopic.php?f=23&t=1128505
>"Say I am debugging a video issue that crashes browser and I am in the process
>of filing a bug report on this. when browser closes I now have to go log in
>again and find my bug, because this one time I did NOT want things cleared."

The problem with this type of boundary case design is that it makes the interface more complicated for the 99.9999% of users who don't hit that specific type of boundary case (privacy conscious user debugging a browser crash).  The more you play "what if" the more bloated the interface gets.  But to address the specific question, developers often rely on the profile manger (creating a new fresh profile) for these types of tasks.
Comment 4 Michael K 2009-03-14 21:15:40 PDT
(In reply to comment #3)
> However, we are planning on removing the dialog that asks the user every
> time before clearing private data, in an effort to eventually remove all open
> and close dialogs in Firefox.

Are you dumbing FF down for the masses?  Where's the choices, the options, the  "do you really want to do this" type things - make them optionnal, but don't ELIMINATE them! I think the user community should have a say such a globally encompassing choice of interface change.  At a time where Microsoft is starting to listen to its customers , the last thing you want to do is alienate them!


> ...makes the interface more complicated for the 99.9999% of users ...

I am almost hearing a condescending tone here, but suffice to say, allowing choice; maybe even an "expert" mode that ALLOWS choices is preferable to a dummy mode where "Ya gets waht youse has AN dat's dat..."

I'll see what they say over at Mozillazine...
Comment 5 Alex Faaborg [:faaborg] (Firefox UX) 2009-03-14 21:26:00 PDT
>Are you dumbing FF down for the masses?

yes

>I am almost hearing a condescending tone here

my apologies, I didn't mean to sound condescending but rather wanted to explain that with several hundred million users creating a simple product ultimately makes some people upset.  I believe the "listen to your customers" perspective (while based on good intentions) can easily lead to an incredibly bloated interface.

Two mechanisms that we have for dealing with the disconnect between creating a simple product and attempting to make everyone happy simultaneously are about:config, and extensions.
Comment 6 Michael K 2009-03-15 08:30:41 PDT
Mozillazine post:
http://forums.mozillazine.org/viewtopic.php?f=38&t=1142405
Oh well, I tried.
Comment 7 Bartłomiej Brzozowiec (BartZilla) 2009-03-15 20:37:49 PDT
(In reply to comment #5)
> (...)
> Two mechanisms that we have for dealing with the disconnect between creating a
> simple product and attempting to make everyone happy simultaneously are
> about:config, and extensions.

The problem is that you (Mozilla) consider Firefox with even one pref changed as "modified version" and forbids redistribution of such version. It definitely not makes me happy.
Comment 8 Mike Connor [:mconnor] 2009-03-16 00:03:21 PDT
That's entirely orthogonal to this bug.  Please keep trademark policy politics out of design discussions.

It isn't about "dumbing down" or "lowest common denominator" design.  Alex is, I think, feeding the troll here.  We are not trying to design a product that is all things to all people.  That's a recipe for an unsuccessful product (See also: Netscape 7).  Of course, that particular case?  If you blindly hit Enter on that dialog 99% of the time, the basic cognitive reality is that you won't react differently in most cases.

The idea behind getting rid of startup/shutdown dialogs is that interrupting starting or quitting the browser is getting in the users' way.  It isn't just "never have them, ever" it's "find other ways to achieve the goals of the UI that requires modal dialogs and use that instead."

Now, as for this bug, designing for the exceptional case, rather than the general case, is wrong.  My comment above about the habitual nature of dialogs is generally held as true, and I don't believe that the "ask me" option is really that useful.  I'm going to WONTFIX this, as it was intended, and no one's given a really compelling argument for why this particular modal dialog is good UI or truly desirable from a user perspective.

Of course, I think that the crash situation should tie to session restore, if you restore the session, we shouldn't clear the history data.  That's trickier, UI-wise, because session restore is non-modal, but we should think about it.
Comment 9 :Ehsan Akhgari 2009-03-16 05:48:37 PDT
*** Bug 483541 has been marked as a duplicate of this bug. ***
Comment 10 Kevin Brosnan 2009-07-03 10:45:58 PDT
*** Bug 502219 has been marked as a duplicate of this bug. ***
Comment 11 Michael K 2009-07-03 11:31:16 PDT
OK it's WONTFIX, but others at least agree in point that this was a bad choice; to eliminate a feature.

How hard would it be to re-add ONE little feature - maybe in about:config?

Rant warning:
This condescending, elitist tone here ("users probably don't read that dialog") really is unprofessional - OK I am a "user" and have yes, become emotional over this, but YOU are the [albeit unpaid] professionals, and as such need to respect us, not "dis" us.
Comment 12 Mike Connor [:mconnor] 2009-07-03 17:11:58 PDT
We need fewer hidden, little-used codepaths in Firefox, not more.  I'm sure an extension could do this as well, without adding code to maintain/test.

It's not a matter of being elitist.  Users generally don't read dialogs, especially dialogs that are expected as a result of an action.  This isn't condescending, it's more based on cognitive psychology and the tendency to learn patterns until they become unconscious reflex.  You can pretend people think differently than they do, but that doesn't make good UI.  I'm as bad as anyone at clicking the Whatever button, FWIW. :)
Comment 13 Jo Hermans 2009-07-04 02:45:32 PDT
*** Bug 499286 has been marked as a duplicate of this bug. ***
Comment 14 evilroy12 2010-02-22 20:02:27 PST
>"The idea behind getting rid of startup/shutdown dialogs is that interrupting
starting or quitting the browser is getting in the users' way."

Excuse me, but this argument rings a bit hollow.  The behavior in question (the pop-up at close asking if the user would like to clear private data) was disabled by default in previous versions.  Ergo, only those users that specifically activated this feature ever had to worry about it, and they of course DIDN'T worry about it seeing as how they were the ones that had activated it in the first place.  I mean seriously, is it really that hard to put the button back that says "Ask me before clearing private data" and have it unchecked by default?  What could possibly be less work than leaving something intact from a previous version?

Taking away the option to decide on a per-session basis if one wanted to clear PD or not effectively removes the option to automatically clear PD for every single user who had in previous versions asked FF to query them as to whether they wanted PD cleared or not.  The whole reason that we opted to have FF ask us every time was that there were enough times that we DIDN'T want PD cleared to make it worth our while.  Now we can't take the chance that some automatic process will nuke our history, so we simply cannot use the "Never remember history" option or even the "Use custom settings" option which, given the lack of a prompt at close, amount to the same thing.

There IS such a thing as addition by subtraction--this is not that thing.
Comment 15 Mike Beltzner [:beltzner, not reading bugmail] 2010-02-22 23:13:33 PST
This is definitely WONTFIX so removing whiteboard label. Sounds like a perfect case for a Jetpack or add-on, though!
Comment 16 Michael K 2010-02-23 15:28:38 PST
Wow, resurrected - Yea, nothing like removing something useful and adding other "pretty things" that do nothing for productivity and security.
However some kind and aware person wrote an add on. 
"AskForSanitize": https://addons.mozilla.org/en-US/firefox/addon/13015

Note You need to log in before you can comment on or make changes to this bug.