Can't drag-scroll/-select in single-select, non-d&d trees

REOPENED
Unassigned

Status

()

Core
XUL
P3
normal
REOPENED
17 years ago
8 years ago

People

(Reporter: Blake Ross, Unassigned)

Tracking

Trunk
Future
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

17 years ago
Bug 44454 talked about having drag-scroll and drag-select in HTML listboxes.  
This is the bug asking for the same exact functionality in trees.  In fact, I'd 
expect the fixes (or the concepts and logic behind them, at least) would be 
pretty similar; perhaps rod can share how he accomplished it.  Please see bug 
44454 for all the detail you need to know about how this functionality should 
work.

(and by non-d&d trees, I mean trees in which you can't drag items within the 
tree -- if that's even possible at the moment.  This is because you can't start 
drag-scrolling/drag-selecting AND initiate a drag at the same time)

Comment 1

17 years ago
The implementation of trees and lists are completely different. There will 
probably be a time in the somewhat near future where they will use the same 
code, but at the moment, I am afraid the the solution for list will probably not 
be much help to trees.

Updated

17 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → Future

Comment 2

17 years ago

*** This bug has been marked as a duplicate of 48912 ***
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

17 years ago
Future is fine, but I don't think these are the same.  This is for single-
select listboxes, whereas the other is for multiselect.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
(Reporter)

Comment 4

16 years ago
*** Bug 76673 has been marked as a duplicate of this bug. ***

Updated

9 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets

Updated

8 years ago
Assignee: hyatt → nobody
You need to log in before you can comment on or make changes to this bug.