[feature] implement drag-based multiple selection in trees

RESOLVED WONTFIX

Status

()

P3
normal
RESOLVED WONTFIX
19 years ago
5 months ago

People

(Reporter: bugzilla, Assigned: janv)

Tracking

(Blocks: 1 bug)

Trunk
Future
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta3-])

(Reporter)

Description

19 years ago
Build ID: 2000081308

Although the trees in the Customize Search, Customize Sidebar, and Customize 
Character Coding dialogs are all multiselect (using Shift+Click or Ctrl+Click), 
you can't drag select within them...because of this, maybe people will fail to 
realize that they can transfer more than one item at a time.   

I wasn't sure if this is a general tree regression, or if each dialog's owner 
needs to update its xul to support the newer trees (well, 'newer' about 2 
months ago).
(Reporter)

Comment 1

19 years ago
nominating for beta3 -- most users won't even realize that some trees are 
multiselect (few people know of the modifier+click functionality), causing 
widespread loss of functionality, usability, and productivity throughout the 
product.
Keywords: nsbeta3
Hardware: Other → PC

Comment 2

19 years ago
4.x does not support drag-based selection in trees (at least on Win32).  Hard to 
argue that a feature that doesn't exist in 4.x should suddenly be added at the 
last minute to 6.0.

It's also nontrivial feature work.  We can't be feature creeping now when we're 
close to shipping.

Sorry, I'm minusing this request.
Status: NEW → ASSIGNED
Whiteboard: [nsbeta3-]
Target Milestone: --- → Future
(Reporter)

Comment 3

19 years ago
Sorry -- I thought it used to exist in 6.0, so figured it would just be a 
regression fix.  Didn't realize it never did...

Comment 4

19 years ago
Just to clarify, you were never able to do this in Seamonkey, so this 
constitutes an RFE.  Updating summary to reflect this.

Summary: No longer able to drag select in multiselect trees? → [feature] implement drag-based multiple selection in trees

Comment 5

19 years ago
*** Bug 48341 has been marked as a duplicate of this bug. ***
*** Bug 54814 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Keywords: 4xp
OS: Windows 98 → All
Hardware: PC → All

Comment 7

18 years ago
*** Bug 42116 has been marked as a duplicate of this bug. ***

Updated

18 years ago
Blocks: 42080
(Assignee)

Comment 8

17 years ago
taking
Assignee: hyatt → varga
Status: ASSIGNED → NEW

Comment 9

17 years ago
> taking

That's great.

Would it be right to list bug 114637 (a clear 4xp issue on the mac, imho) as
depending on this one?
Yes.
Blocks: 114637

Updated

11 years ago
Component: XP Toolkit/Widgets: Trees → XUL
QA Contact: jrgmorrison → xptoolkit.widgets
(Assignee)

Comment 11

5 months ago
I don't think anyone is going to work on this given the plan to remove XUL tree widget.
Status: NEW → RESOLVED
Last Resolved: 5 months ago
Resolution: --- → WONTFIX
(Assignee)

Updated

5 months ago
See Also: → bug 1446335
You need to log in before you can comment on or make changes to this bug.