Closed Bug 483671 Opened 14 years ago Closed 14 years ago

Password engine isn't getting correct hostname

Categories

(Cloud Services :: General, defect, P1)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: miha.valencic, Assigned: Mardak)

References

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1b3) Gecko/20090305 Firefox/3.1b3
Build Identifier: Weave 0.2.113, FF3.1b3

Running two instances of Weave (both FF3.1b3, Weave0.2.113 and Mac OS X

At first, it worked OK, but after 1 day, I get WARN messages in activity log:
2009-03-16 21:07:14 Engine.Passwords INFO Applied 96 records, reconciled 0 records
2009-03-16 21:07:14 Engine.Passwords WARN Error while applying incoming record: 'Can't add a login with a null or empty hostname.' when calling method: [nsILoginManager::addLogin]
2009-03-16 21:07:14 Store.PasswordStore DEBUG Adding login for undefined

There are a lot of "Adding login for undefined" messages in the log file (apx 65 of them).

On a notebook (Macbook), I get
Engine.Passwords INFO Applied 161 records, reconciled 1
which is interesting. Even if I run it more than once.

Reproducible: Always

Steps to Reproduce:
1. Wait for the scheduled sync to kick in or...
2. trigger the sync manually
3.
Actual Results:  
Passwords don't get synced across.

Expected Results:  
Passwords should get synced and hostnames should be resolved properly
Using Trace enabled logging, I found out that apparently, the client gets the wrong data from the server.
Password entries look like:
{"id":"fd358969-52fb-fb40-847a-09737e8aef76","modified":1237236462.08,"payload":"[null]"}


which is probably wrong.
I'm resolving this as this message resulted from the invalid data that was received from the server and is hence correct.
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → INVALID
Actually, "[null]" is a valid payload--it means that item has been deleted.

It looks like the client is not correctly processing deleted records.
Status: RESOLVED → UNCONFIRMED
Resolution: INVALID → ---
Blocks: 468694
OS: Mac OS X → All
Priority: -- → P1
Hardware: x86_64 → All
Target Milestone: -- → 0.3
Attached patch v1Splinter Review
Seems like a missing cleartext -> null payload check from bug 478327. This fix gets rid of the warning and lets passwords successfully sync for me.
Assignee: nobody → edilee
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
Attachment #369283 - Flags: review?(thunder)
Blocks: 478327
Version: unspecified → Trunk
Comment on attachment 369283 [details] [diff] [review]
v1

Oops!  Missed this one, thanks.
Attachment #369283 - Flags: review?(thunder) → review+
http://hg.mozilla.org/labs/weave/rev/e0075854c225
Status: ASSIGNED → RESOLVED
Closed: 14 years ago14 years ago
Resolution: --- → FIXED
Duplicate of this bug: 483669
Blocks: 482670
Component: Weave → General
Product: Mozilla Labs → Weave
Version: Trunk → unspecified
QA Contact: weave → general
You need to log in before you can comment on or make changes to this bug.