If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Can't load about: urls from the location bar

RESOLVED FIXED

Status

()

Core
General
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Natch, Assigned: bz)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 482659])

(Reporter)

Description

9 years ago
I'm setting this as a blocker to bug 482659 on a hunch, correct me if I'm wrong. about: urls no longer work in the browser on a recent update to tip. Not really sure which component this belongs in.
Flags: blocking1.9.1?
(Reporter)

Comment 1

9 years ago
Seems like the private browsing tests were failing, maybe because of this?

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1237268523.1237272101.21651.gz#err0

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1237261324.1237269919.17495.gz#err0

Comment 2

9 years ago
This was fixed due Backout from Bug 482659, changeset:
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/77866c0feb8e
in current Tinderbox-Builds. 

Tested with Windows SeaMonkey 2.0b1pre 20090317035450, about:urls working again. Have not tested with FF or other Apps, so I leave this open until someone have tested with Firefox.

Updated

9 years ago
Duplicate of this bug: 483774
Fixed by the backout.
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → FIXED
(Reporter)

Updated

9 years ago
Assignee: nobody → bzbarsky
(Reporter)

Updated

9 years ago
Flags: blocking1.9.1?
Whiteboard: [fixed by bug 482659]
Verified for Linux on both SeaMonkey and Firefox tinderbox-builds, as follows:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090318 SeaMonkey/2.0b1pre - Build ID: 20090318013021 is free from the bug. (I checked Help=>About SeaMonkey, about:, about:config, about:buildconfig and about:mozilla, and they all worked as expected).

The 2009-03-17 Sm Linux trunk nightly showed a flat empty grey background not only for "about:" or "about:config" from the URL bar but also for "Help => About SeaMonkey" from the menu bar. Sorry I didn't check other URLs or save the UA string.

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090317 Minefield/3.2a1pre - Build ID: 20090317030812 had the bug, or at least part of it: could show about:mozilla or about:buildconfig but not about:config or plain about: (Help => About Minefield gives a popup, not a page, unlike with Suiterunner.)

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090318 Minefield/3.6a1pre - Build ID: 20090318015555 is free from the bug: about: and about:config work here (they didn't in the nightly). I don't understand the big jump in the Minefield version so I'll let you devs decide if and when to set VERIFIED.
OS: Windows Vista → All
You need to log in before you can comment on or make changes to this bug.