Make smilies appear in msgCompose's smiley menu

RESOLVED FIXED in seamonkey2.0b1

Status

RESOLVED FIXED
10 years ago
10 years ago

People

(Reporter: stefanh, Assigned: neil)

Tracking

Trunk
seamonkey2.0b1
x86
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

10 years ago
Created attachment 367902 [details] [diff] [review]
Fix style rules to the better for everyone

I suspect that the native menu code doesn't expect anyone to set the image on the icon class directly... or maybe it's the -moz-image-region stuff? Actually, I have no idea, but the have never appeared afaik. Anyway, this will make them appear and it's more correct styling :-)
Attachment #367902 - Flags: superreview?(neil)
Attachment #367902 - Flags: review?(mnyromyr)
(Assignee)

Updated

10 years ago
Attachment #367902 - Flags: superreview?(neil) → superreview+

Comment 1

10 years ago
Created attachment 368371 [details]
broken smilies

This doesn't work for me under 10.4.11, see attached screenshot. 
Classic or Modern doesn't matter.

Comment 2

10 years ago
The normal smiley dropdown inside the mail editor still works correctly, though.
(Reporter)

Comment 3

10 years ago
How does icons in your window menu looks? Because they are in the same kind of menuitems... unless the sub-menu matters, of course.
(Reporter)

Comment 4

10 years ago
Hmm, maybe the problem is that the icons are 19x19
(Reporter)

Comment 5

10 years ago
(In reply to comment #4)
> Hmm, maybe the problem is that the icons are 19x19

It seems that the icons are scaled down to 16x16 (since that's the dimension they should have). So, what you see is probably some kind of Tiger-only issue related to scaling.
(Reporter)

Comment 6

10 years ago
I don't think there's anything we can do about this except getting a new set of 16x16 icons. Sigh.
Status: ASSIGNED → NEW
Target Milestone: seamonkey2.0b1 → ---
(Reporter)

Updated

10 years ago
Attachment #367902 - Flags: review?(mnyromyr)

Comment 7

10 years ago
I can confirm that using true 16x16 icons would make my problem go away.

Updated

10 years ago
Depends on: 484484
(Reporter)

Comment 8

10 years ago
Neil fixed this in bug 484484.
Assignee: stefanh → neil
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
(Reporter)

Updated

10 years ago
Target Milestone: --- → seamonkey2.0b1
(Reporter)

Updated

10 years ago
Duplicate of this bug: 206813
You need to log in before you can comment on or make changes to this bug.