Closed Bug 484484 Opened 12 years ago Closed 12 years ago

Upgrade MailNews smileys (emoticons)

Categories

(SeaMonkey :: Themes, defect)

defect
Not set
normal

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0b1

People

(Reporter: mnyromyr, Assigned: neil)

References

Details

Attachments

(2 files)

Our current mailnews smileys (both mail display and mail composition) are rather out of sync with the general smoothness of our themes.
Furthermore, they're 19x19 gifs, which causes more problems:
- size breaks Mac Tiger menuitems (bug 483888)
- gif lacks some features png has (bug 199958)

We do, otoh, already ship a decent set of 16x16 png smileys as part of Chatzilla.

Thus I propose to just copy over the limited subset we do use in MailNews.

Unfortunately, MailNews does not recognise most of Chatzilla's icons, nor does Chatzilla recognise some of the MailNews' ones. The attached concept proposes how to map the known ones; I could derive those missing from the existing Chatzilla ones if we agree on this path of action here (and I'd provide the actual CSS patch then).

But first we need to know for sure if the Chatzilla icons are MPLed, thus requesting r? from James. Requesting ui-r? and sr? for the path of action, real patch will follow after that. 
(BTW: I'd propose using a single image map for the smileys and using -moz-image-region, if Mac menuitems understand that.)

(Sadly, we can't do 'hg copy' anyway since Chatzilla is not in hg yet.)
Attachment #368607 - Flags: ui-review?(stefanh)
Attachment #368607 - Flags: superreview?(neil)
Attachment #368607 - Flags: review?(silver)
Comment on attachment 368607 [details]
Concept of how to map Chatzilla icons

I'm OK with using the cz icons. Note: You can't use -moz-image-region, because that won't work in native mac menus.
Attachment #368607 - Flags: ui-review?(stefanh) → ui-review+
What about the PNGs from Thunderbird? e.g. mail/themes/*/mail/icons/smiley-*.png
(In reply to comment #2)
> What about the PNGs from Thunderbird? e.g.
> mail/themes/*/mail/icons/smiley-*.png

They're 18x18.
Does Mozilla Messaging have the original high resolution sources?
(In reply to comment #4)
> Does Mozilla Messaging have the original high resolution sources?
No idea. If the don't have them, maybe the author have them (Kevin?).
(In reply to comment #2)
> What about the PNGs from Thunderbird?

They're kind of fuzzy and generally "less nice" than the current Chatzilla ones 
(or in short: ugly, IMO).
Furthermore, a consistent smiley look throughout the app is definitely a plus. ;-)
Comment on attachment 368607 [details]
Concept of how to map Chatzilla icons

IRC log of #chatzilla:
[29.03.2009 21:15] <Mnyromyr> Silver: btw: do the Chatzilla smileys fall under the MPL? or under which licence else?
[29.03.2009 21:21] <Silver> Mnyromyr: They're dual CC [Attribution-Share Alike 3.0]/LGPL, I believe.
[29.03.2009 21:23] <Silver> Mnyromyr: http://phoenity.com/icons/classic -> Other cool stuff -> Smilies.
[29.03.2009 21:24] <Mnyromyr> Silver: thanks
Attachment #368607 - Flags: review?(silver)
We might be able to use the Tango smilies in Thunderbird just checked in (Tango icons are in vector format so we should not have problems resizing them. Looking through the dependencies I think the tango icons used in Firefox (and hence Thunderbird) have been relicensed as MPL/GPL/LGPL.
Depends on: 484800
I decided to keep our basic existing icon names, but I changed the _n.gif suffix to .png and added the smiley- prefix.

editorFormatToolbar.css was really undecided for some reason.

I also corrected a misspelling in a comment.
Attachment #370874 - Flags: review?(stefanh)
Attachment #370874 - Flags: review?(mnyromyr)
Comment on attachment 370874 [details] [diff] [review]
Appropriate Tango icons

I must say I think I prefer the cz ones, but I'll leave the ui decision to Karsten ;-)

>+.insert-laughing {
>+  list-style-image: url("chrome://communicator/skin/icons/smileys/smiley-laughing.png"); 

Nit: There are some whitespace leftovers after the list-style-image rule (both files, multiple instances).

>   -moz-image-region: auto; /* cut off inheritance */

Is there any reason we need this (default is auto)?
Attachment #370874 - Flags: review?(stefanh) → review+
Comment on attachment 370874 [details] [diff] [review]
Appropriate Tango icons

Since CZ wants to switch to another icon set soonishly, we'd be inconsistent then again anyway - and the Tango icons are probably ;-) better than anything I could do, and they're of course *way* better than our current ones, so I guess we should them.

r=me with stefanh's comments addressed.
Attachment #370874 - Flags: review?(mnyromyr) → review+
Pushed changeset a58fe62266a8 to comm-central.
Assignee: mnyromyr → neil
Status: ASSIGNED → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Target Milestone: --- → seamonkey2.0b1
Comment on attachment 368607 [details]
Concept of how to map Chatzilla icons

Removing obsolete request.
Attachment #368607 - Flags: superreview?(neil)
Duplicate of this bug: 199958
You need to log in before you can comment on or make changes to this bug.