Last Comment Bug 484089 - Google Calendar fails in Shredder 3.0b3pre with Lightning 1.0pre if a master password is set
: Google Calendar fails in Shredder 3.0b3pre with Lightning 1.0pre if a master ...
Status: VERIFIED FIXED
[not needed beta][no l10n impact]
:
Product: Calendar
Classification: Client Software
Component: Provider: GData (show other bugs)
: Trunk
: All All
: -- major (vote)
: 1.0b1
Assigned To: Philipp Kewisch [:Fallen]
:
Mentors:
: 435557 487205 (view as bug list)
Depends on:
Blocks: 487205
  Show dependency treegraph
 
Reported: 2009-03-18 15:50 PDT by David Flory
Modified: 2010-03-06 08:00 PST (History)
5 users (show)
philipp: blocking‑calendar1.0+
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
Fix - v1 (2.20 KB, patch)
2009-10-12 08:43 PDT, Philipp Kewisch [:Fallen]
Mozilla: review+
Details | Diff | Review

Description David Flory 2009-03-18 15:50:50 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090318 Shiretoko/3.5b4pre (.NET CLR 3.5.30729)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b4pre) Gecko/20090317 Lightning/1.0pre Shredder/3.0b3pre

I installed Lightning 1.0pre (with GData 0.6pre) into Shredder 3.0b3pre and installed several Google remote calendars.  If I enable a master password I get multiple password prompts (probably related to bug 356097) and none of the Google calendars will load.  If I disable the master password there is no problem.

Reproducible: Always

Steps to Reproduce:
1. Install Lightning and GData into Shredder
2. Create several Google remote calendars
3. enable a master password
4. restart Shredder and look at calendars
Actual Results:  
JavaScript errors and the calendars do not load.  

Expected Results:  
See the calendars.

Here are some of the JavaScript error messages.

Error: [Exception... "'[JavaScript Error: "this.treebox is null" {file: "chrome://calendar/content/widgets/calendar-list-tree.xml" line: 562}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1231"  data: yes] STACK: 1: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1234] notifyFunc
2: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1237] calListenerBag_notify
3: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [null:0] null
5: [chrome://calendar/content/calendar-management.js:109] initHomeCalendar
6: [chrome://calendar/content/calendar-management.js:91] loadCalendarManager
7: [chrome://calendar/content/calendar-chrome-startup.js:43] commonInitCalendar
8: [chrome://lightning/content/messenger-overlay-sidebar.js:121] ltnOnLoad

Source File: file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1234
-------------------------------------------------
Error: [Exception... "'[JavaScript Error: "dayHeaderBox.mItemBoxes is null" {file: "chrome://calendar/content/calendar-multiday-view.xml" line: 2853}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1231"  data: yes] STACK: 1: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1234] notifyFunc
2: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1237] calListenerBag_notify
3: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:184] anonymous
5: [file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:187] anonymous
6: [null:0] null
7: [chrome://calendar/content/calUtils.js:1848] getCompositeCalendar
8: [chrome://calendar/content/calendar-task-tree.xml:154] 

Source File: file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Documents%20and%20Settings/Flory/Application%20Data/Thunderbird/Profiles/iizrn4ib.Flory3/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Line: 1234
-------------------------------------------------------------------------
Comment 1 Philipp Kewisch [:Fallen] 2009-03-19 11:47:31 PDT
Timing/Threading problems....I've seen this kind of error once in a while, especially if I set a breakpoint quite early in the startup process that doesn't hinder the rest of the UI to get set up.

We need to investigate this. David, would you be interested in finding out the cause for this problem yourself using the javascript debugger? If so, please send me an email.
Comment 2 Kris 2009-04-19 10:23:14 PDT
I can confirm this using trunk from 20090419035013.
Comment 3 Stefan Sitter 2009-04-25 01:23:45 PDT
Confirmed using Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090424 Shredder/3.0b3pre with Lightning 1.0pre (20090424) and Provider for Google Calendar (20090424).

Error: [Exception... "'[JavaScript Error: "this.treebox is null" {file: "chrome://calendar/content/widgets/calendar-list-tree.xml" line: 562}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///[...]/calendar-js/calUtils.js :: notifyFunc :: line 1231"  data: yes] 

STACK: 
1: [file:///[...]/calendar-js/calUtils.js:1234] notifyFunc
2: [file:///[...]/calendar-js/calUtils.js:1237] calListenerBag_notify
3: [file:///[...]/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [null:0] null
5: [chrome://calendar/content/calendar-management.js:109] initHomeCalendar
6: [chrome://calendar/content/calendar-management.js:91] loadCalendarManager
7: [chrome://calendar/content/calendar-chrome-startup.js:43] commonInitCalendar
8: [chrome://lightning/content/messenger-overlay-sidebar.js:121] ltnOnLoad
Comment 4 Philipp Kewisch [:Fallen] 2009-05-18 05:18:46 PDT
Master password is quite an important feature. It would be bad if lightning is unusable for google calendar users that use a master password.
Comment 5 Philipp Kewisch [:Fallen] 2009-05-18 05:21:43 PDT
David, reading over this bug again, not yet sure how to best debug this. I've had the feeling that using the javascript debugger interferes with timing so much, that its not reliable to reproduce.

You could possibly spread cal.LOG() calls all over the calendar code temporarily, to see in which order things start up, to see why the treebox is still null while the calendars are already added.
Comment 6 Philipp Kewisch [:Fallen] 2009-06-17 05:35:33 PDT
While unfortunate, we won't be taking this for beta1.
Comment 7 Kris 2009-06-17 06:38:00 PDT
Unfortunate?

What good is a calendar in which the reminders do not function properly? It's no good at all. The key to a calendar is being able to get reminders. This is a showstopper, not unfortunate.
Comment 8 Kris 2009-06-17 06:38:56 PDT
Whoops! Wrong thread. Sorry!
Comment 9 Peter Lairo 2009-06-19 05:39:02 PDT
I've seen the same problem with Google CalDAV calendars, but without GData.
Comment 10 Martin Schröder [:mschroeder] 2009-06-23 01:11:03 PDT
What is the relation to bug 349641?
Comment 11 Philipp Kewisch [:Fallen] 2009-10-12 08:43:02 PDT
Created attachment 405859 [details] [diff] [review]
Fix - v1

Postponing the retrieval of the password to just before the login works around this problem and makes Lightning function again. Not a fix, but shifts the problem again to mozilla-central :)
Comment 12 Philipp Kewisch [:Fallen] 2009-10-12 10:27:50 PDT
*** Bug 487205 has been marked as a duplicate of this bug. ***
Comment 13 Markus Adrario [:Taraman] 2009-10-15 07:02:06 PDT
Comment on attachment 405859 [details] [diff] [review]
Fix - v1

Fixes this issue.

the one from Bug 349641 persists, but that is another story.

r=markus
Comment 14 Philipp Kewisch [:Fallen] 2009-10-20 10:57:44 PDT
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/b18b4bc60e70>

-> FIXED
Comment 15 David Flory 2009-10-20 14:39:37 PDT
I just did a clean install of Thunderbird, Lightning, and gdata.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091020 Lightning/1.0pre Shredder/3.0pre

I then installed a Google calendar which worked fine UNTIL I added a master password.  I then got the same problem as originally reported.

Do you want my Error Console report?
Comment 16 David Flory 2009-10-20 14:50:31 PDT
If I remove the master password the errors disappear.
Comment 17 Martin Schröder [:mschroeder] 2009-10-20 15:42:16 PDT
(In reply to comment #15)
> I just did a clean install of Thunderbird, Lightning, and gdata.
> Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091020
> Lightning/1.0pre Shredder/3.0pre

David, please wait for tomorrow's gdata provider nightly build, and try again! It's likely that the fix is not in today's. Please mark this bug VERIFIED if it's working otherwise feel free to reopen and leave a comment. Thanks! :)
Comment 18 David Flory 2009-10-21 10:10:05 PDT
The latest build works for me.  I am getting multiple requests for my master password but no errors.  The requests are probably a different bug.

Good work and many thanks.

David
Comment 19 Philipp Kewisch [:Fallen] 2010-03-06 08:00:23 PST
*** Bug 435557 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.