Closed Bug 487205 Opened 12 years ago Closed 12 years ago

Mac: uncaught exception, views borked when using master password

Categories

(Calendar :: Provider: GData, defect)

x86
macOS
defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 484089

People

(Reporter: dbo, Unassigned)

References

Details

(Whiteboard: [not needed beta][no l10n impact])

Strange, but if (and only if) I run a current gdata-provider on Mac, I get this exception (which does not sound like a gdata problem):

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER)"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://lightning/content/messenger-overlay-sidebar.js :: swapPopupMenus :: line 507"  data: no]

<http://mxr.mozilla.org/comm-central/source/calendar/lightning/content/messenger-overlay-sidebar.js#507>
Flags: blocking-calendar1.0?
This seems to be related to the master password bug 349641. If I don't use one everything is fine. If I use one I get messages like

calGoogleRequest: Requesting POST https://www.google.com/accounts/ClientLogin
loginAndContinue called while logging in
loginAndContinue called while logging in
loginAndContinue called while logging in
Depends on: 349641
Daniel, whats the status of this?
Flags: blocking-calendar1.0? → blocking-calendar1.0+
Summary: Mac: uncaught exception, views borked → Mac: uncaught exception, views borked when using master password
While unfortunate, we won't take this for beta1. Sorry.
Whiteboard: [not needed beta][no l10n impact]
Daniel, can you still reproduce this issue? The exception can't occur anymore because the function has been removed, but maybe you see new symptoms.
I don't know whether this still relates to using a master password, but I get the following error using a google calendar on startup (+ using a master password):

Error: [Exception... "'[JavaScript Error: "this.treebox is null" {file: "chrome://calendar/content/widgets/calendar-list-tree.xml" line: 562}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js :: notifyFunc :: line 1221"  data: yes] STACK: 1: [file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js:1224] notifyFunc
2: [file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js:1227] calListenerBag_notify
3: [file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [null:0] null
5: [chrome://calendar/content/calendar-management.js:104] initHomeCalendar
6: [chrome://calendar/content/calendar-management.js:89] loadCalendarManager
7: [chrome://calendar/content/calendar-chrome-startup.js:43] commonInitCalendar
8: [chrome://lightning/content/messenger-overlay-sidebar.js:184] ltnOnLoad

Source File: file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/modules/calUtils.jsm -> file:///data/dbo/moz_cc/sbird-cc-debug_Darwin/mozilla/dist/xpi-stage/lightning/calendar-js/calUtils.js
Line: 1224

Views and calendar list are borked.
Well, comment #5 sounds like bug 484089.
Depends on: 484089
I think this might again be a threading problem. This is the same error I get when setting a breakpoint in venkman somewhere (not sure where, but probably either in xul startup or component startup) and them starting the app with --venkman.
Yeah, looks like the same error I got with bug 484089. Marking duplicate as the other bug has a patch.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 484089
You need to log in before you can comment on or make changes to this bug.