Closed Bug 349641 Opened 13 years ago Closed 8 years ago

Lightning asks for master password again

Categories

(Calendar :: Lightning Only, defect, blocker)

defect
Not set
blocker

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: fritz.heinrichmeyer, Assigned: philmsgs)

References

Details

(Whiteboard: [not needed beta][no l10n impact])

Attachments

(2 files)

User-Agent:       Mozilla/5.0 (compatible; Konqueror/3.5; Linux) KHTML/3.5.4 (like Gecko)
Build Identifier: thunderbird 1.0.5

i protect my password db with a master password. I am asked for this when reading my imap mail.

I consider it as bug that lightning extension asks for this again before it rereads my remote calendars.

I use lightning from 11. August 06, but this behaviour was there also before ...

Reproducible: Always

Steps to Reproduce:
1. start thunderbird
2. type in master password for email
3. type in master password for lightning


Expected Results:  
one time input of master password per session should be enough

nothing
forgot to mention:
i use lightning for windows-xp ...
from
ftp://ftp.mozilla.org/pub/mozilla.org/calendar/lightning/nightly/latest-mozilla1.8/windows-xpi/
problem persists with build 2006082107 under windows xp and thunderbird 1.0.5
Component: General → Lightning Only
QA Contact: general → lightning
I'm also experiencing this. In Thunderbird 1.5 and Thunderbird 2 alpha 1 (20060724), using both Lightning 0.3 release, and Lightning 0.4a1 (2006120103) on XP.

Confirmed per comment#3.
Severity: normal → minor
Status: UNCONFIRMED → NEW
Ever confirmed: true
Keywords: qawanted
bug again visible with recent lightning 0.7pre daily build
Same here with TB version 2.0.0.14 (20080421) and Lightning 0.8

Password shouldn't be required by both, as Lightning can use the Thunderbird password, It is easy to check:

- Deactivate Lightning
- Restart TB
- Activate Lightning
- Restart TB

Now the password is only asked once.

Next time you start TB, It will ask you twice.....

Just a guess: I have the impression that Lightning does not wait for TB to ask the password, and issues a request for password. That request should be queued, and correcly handled.
Does this issue also happen on trunk? I believe something about the master password dialog changed that makes it not show twice.
Same problem, with lightning on Win/Macosx/Linux
Any ideas? It's a very very tiresome bug!
It will ask you user/pass random, it seems happen every reload.
for me the combination of

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b3pre) Gecko/20090127 Shredder/3.0b2pre

and

Lightning1.0pre (that was a somewhat current nightly build - sorry for not being more specific but i can't find any more details on the version...)

still shows this behavior, i.e. when lightning is enabled and the calendar passwords are protected by a master password the master password is asked multiple times; i'd say as many times as passwords are 'needed' by lightning.
Flags: blocking-calendar1.0?
OS: Windows XP → All
Hardware: x86 → All
Summary: lightning extension asks for master password again → Lightning asks for master password again
after creating a new profile with new shredder two days ago and fresh lightning nightly and using google-data-provider i also suspect lightning for unnecessary asking for password.

If i deinstall the calendar extension master password is only required once per session.
this report comes a little late because first i forgot to setup a master password on the new profile.
(In reply to comment #10)
> ... i also suspect lightning for unnecessary asking for password.

Do you have multiple e-mail accounts? IMAP or POP?

google-data-provider = Google CalDAV?
I'm also experiencing this issue with trunks of Thunderbird and Lightning as of the date of posting this comment. I have a master password enabled. This issue DOES NOT occur without Lightning. I have remote calendar services, which are fetched via password protected FTP of which the credentials are stored by Thunderbird.

Not only that, but the prompt for a password reappears whenever Lightning tries to resync the calendar from the remote location, even though the password is saved. Highly irritating.
Duplicate of this bug: 468036
This is probably a joint effort. I think some sort of static variable needs to be set when the password is asked for that we can check for and then let the code block until the asking is done.

While unfortunate, I'm not sure if this should block 1.0 yet.
Duplicate of this bug: 485755
I am using Google Calendar with Google Calendar Provider extension. This problem started to occur to me as a regression when I upgraded from Tb 2/Lightning 0.9 to Tb 3.0 beta 2/Lightning nightly (2009-03-27). I get 3 password prompts. When Lightning is disabled I get 1 prompt.
Blocks: 487205
IMO this bug is not triggered by lightning but by google data provider, but this is the only provider i use apart from the default provider.
When this provider is activated even without an active calendar, there is an error in error console (at the end of this comment). I am asked for a password within a half drawn password dialog. Then navigating to calendar is only possible after the following workaround:

1. open adressbook from extra menu
2. close main window
3. from addressbook extra menu open thunderbird again.
I posted this recently as a comment for a closed bug #473973.

Fehler: [Exception... "'[JavaScript Error: "this.treebox is null" {file: "chrome://calendar/content/widgets/calendar-list-tree.xml" line: 562}]' when calling method: [calICompositeObserver::onCalendarAdded]"  nsresult: "0x80570021 (NS_ERROR_XPC_JAVASCRIPT_ERROR_WITH_DETAILS)"  location: "JS frame :: file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js :: notifyFunc :: line 1231"  data: yes] STACK: 1: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1234] notifyFunc
2: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js:1237] calListenerBag_notify
3: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:209] cCC_addCalendar
4: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:184] anonymous
5: [file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/components/calCompositeCalendar.js:187] anonymous
6: [null:0] null
7: [chrome://calendar/content/calUtils.js:1848] getCompositeCalendar
8: [chrome://calendar/content/calendar-task-tree.xml:154] 

Quelldatei: file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/modules/calUtils.jsm -> file:///C:/Dokumente%20und%20Einstellungen/heinricf.HDNS2344/Anwendungsdaten/Thunderbird/Profiles/a7gmuuyw.default/extensions/%7Be2fda1a4-762b-4020-b5ad-a41df1933103%7D/calendar-js/calUtils.js
Zeile: 1234
(In reply to comment #18)
> IMO this bug is not triggered by lightning but by google data provider, ...

I have to enter the master password for every calendar I have subscribed to although I do not use the google data provider. I am not seeing the given error messages either.
i observed the mentionend output of the *error console* (in german Fehlerkonsole, only after selecting this console they can be seen) on windows xp and linux amd64 with todays lightning/gdata_provider and thunderbird3b02.
(In reply to comment #20)
I already looked for the messages in the error console, there are no such messages.
Severity: minor → blocker
Duplicate of this bug: 492624
I agree this is annoying, but from what I've heard, its nearly impossible to fix this from calendar side without very evil hacks. Therefore we shouldn't block the release on it.

It would be very nice to find out the exact reasoning though and find out if maybe we can fix this in toolkit/core or thunderbird.
Flags: wanted-calendar1.0+
Flags: blocking-calendar1.0?
Flags: blocking-calendar1.0-
Fritz, do you have two master password dialogs shown at the same time. Maybe the stacked, and you have to move the topmost dialog.

Bug 348997 and its depending/blocking bugs are the reason for this behavior. The code is in Core:Security, and at the moment there is no workaround available for Lightning/Thunderbird.
there are no dialogs stacked. But i also have since a long time the problem of javascript errors mentioned in my Comment #18 that seem to occur only in my special case (until release of lightning 1.0, then there will be a lot of reports of this kind) and i tend to use more and more outlook/evolution for calendar and email integration.
(In reply to comment #24)
> Fritz, do you have two master password dialogs shown at the same time. Maybe
> the stacked, and you have to move the topmost dialog.

i have - and have been having for quite a while - with trunk TB&Lightning: /all/ my passwd dialogs show up. at the moment this are 8 windows of which i can focus 6 - two are /not/ responsive until i close the others (don't know how long /this exact/ behavior has been around, though).

> Bug 348997 and its depending/blocking bugs are the reason for this behavior.
> The code is in Core:Security, and at the moment there is no workaround
> available for Lightning/Thunderbird.

...that's a bummer!
sorry, this is not relevant for the bug but might help some people: /forcing/ the installation of the StartupMaster Add-on (https://addons.mozilla.org/en-US/thunderbird/addon/9808) on current TB&Lightning nighties seems to work and cuts down the master password prompts - for me from 8 - to two.
Same here with Thunderbird+Lightning nigthlies (august 26, 2009).

Thanks for this StartupMaster extensions, works fine under FF 3.5.2, but does'nt work on my Shredder, I still have my 6 popups, one for each calendar, we here use Zimbra as the CalDav server, I access 6 shared calendars, all with the same login/password.
Duplicate of this bug: 512922
the  this.loginMasterPassword(); is not executed when using lightning in shredder, giving as many master password prompts as available calendars.
That patch fixes it for me under Linux with latest comm-central. Thanks Tim!
does not work here with Mozilla/5.0 (X11; U; Linux i686; de; rv:1.9.1.4pre) Gecko/20090907 Lightning/1.0pre Shredder/3.0b4pre
in the error console i have:
Components.classes["@mozilla.org/satchel/form-fill-controller;1"] is undefined
Whoops, my bad...  when I recompiled Thunderbird and Lightning with the patch applied, and replaced the old Thunderbird with the new one, I forgot to actually install Lightning...so naturally I only saw the one master password prompt.  :-P  Sorry about that, doesn't seem to be quite fixed yet.

However, Fritz, the message you mentioned in the error console also appears when Lightning is not installed, so I don't believe that is related.

The behavior after applying that patch is that upon opening Thunderbird, only one master password entry dialog appears at first.  After entering the password there, the second prompt for the master password then appears along with the following dialog box:

   An error occurred during a connection to mail.gatech.edu:443.
   The operation failed because the PKCS#11 token is not logged in.
   (Error code: sec_error_token_not_logged_in)

(The hostname above refers to my Zimbra server running CalDAV.)
(In reply to comment #32)
> Components.classes["@mozilla.org/satchel/form-fill-controller;1"] is undefined

Not related to Lightning. See Bug 510378 Comment #5.
I have the same problem.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4

TB+Lightning => TB prompts twice for the master password.
Uninstalling Lightning addon an restart => TB prompts only once (correct)
Installing Lighting addon again => TB prompts twice again.

So my conclusion: this behavior is due to Lightning addon.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.5pre) Gecko/20091022 Lightning/1.0pre Shredder/3.0pre ID:20091022031603

With Google Calendars from two different accounts installed I get two extra prompts for a Master Password in addition to the original prompt for my email accounts.
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4pre) Gecko/20090915 Lightning/1.0pre Thunderbird/3.0b4 Lightning 1.0pre

I also do experence two master password prompts. So far nothing new, just like comment 35. 

But did you notice: It does not matter what I enter in the second prompt. Keeping it empty or just hitting some key works fine to get rid of it.

The master password addon mentioned earlier does not work for me (when tricked to install anyway)
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4) Gecko/20091017 Lightning/1.0pre SeaMonkey/2.0

The error occurred, also in the combination of Seamonkey 2,0 & Lightning1.0pre.

I have 4 ICS calendars via ftp, protected by the master password of Seamonkey. A normal master-password-inquiry when starting of Seamonkey, afterwards 4 x password inquiry of Lightning.
The inquiry repeats itself in the rhythm, how those is adjusted calendar actualization interval. The password is reserved. I must confirm only each time 4 x.
(In reply to comment #30)
> Created an attachment (id=397247) [details]
> path that makes sure that the this.loginMasterPassword() is executed
> 
> the  this.loginMasterPassword(); is not executed when using lightning in
> shredder, giving as many master password prompts as available calendars.

This patch reduces the number of password prompts to 2 for me, down from one for each CalDAV calendar I have. I do have to enter my password twice now - before I applied the patch could enter it in one of the many prompts and cancel the rest.
I'm using Thunderbird 3 RC2 and the latest Lightning build available as of today.
Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.4) Gecko/20091017
Lightning/1.0pre SeaMonkey/2.0

(In reply to comment #39)
What is with the questions when the actualization interval is arrived or when you set a new Task or Event? Did ask Lightning again? Please check it and gave us a new Comment.
Duplicate of this bug: 533651
I'm also experiencing multiple (being asked twice) when TB3.0 starts up. If I disable the remote calendars or the google provider add-on then I only get asked for the master password once as it should be.
Using TB3.0, lightning 1.0b1pre and google provider 0.6pre on openSUSE 11.1.

I never had this problem when using TB 2 and Lightning 0.9.
Confirmed on Windows XP 32-bit, Thunderbird 3.0, Lightning 1.0b2pre with the Provider for Google Calendar addon enabled. One master password, has to be entered twice, hitting cancel on the second one results in a password dialog for my Google Calendar account.
Is there any way to determine whether the problematic code that is requiring multiple logins lives in Thunderbird or in the Lightning extension?  (I realize that the problem only manifests when Lightning is installed, but that doesn't mean that the code that is causing this behavior is in Lightning rather than Thunderbird.)

If it lives in Thunderbird, IMHO this should block the release of Thunderbird 3.0.

What needs to happen for this bug to transition from NEW to ASSIGNED?  There are quite a few people following this as the bug has a broad impact.
For reference, bug 534462 might have improved the situation in nightly builds (1.9.1 and trunk). If we spin rc2, we want to take that patch for the release branch also.

Using this bug for tracking.
Flags: wanted-calendar1.0+
Flags: blocking-calendar1.0-
Flags: blocking-calendar1.0+
Whiteboard: [maybe needed beta 1 rc2][no l10n impact]
(In reply to comment #45)

Nothing has changed with the new nightly-build.

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.1.6) Gecko/20091206 Lightning/1.0b2pre SeaMonkey/2.0.1
I had a look into this and it seems to be a problem with multithreading for me.

Here's why:
when you start up TB with lightning and a google calendar, two password dialogs appear at the same time.
When you add a google calendar after being logged in, no password prompt appears.

That leads me to the conclusion that during startup the mail window and lightning are loaded and see that the password is not yet entered. Outcome: both ask for it.

There are two solutions that I could imagine:
1.:
make the password dialog block execution until it is closed.

2.:
make the token thread safe.
looking at the code I believe it is not by default, but has a locking mechanism.

in both cases this would become a toolkit bug.
who and when will this bug be fixed? this exists for four years now and no one able to fix it???
I really think that this master password prompt at the startup of Thunderbird should be removed as it doesn't really do anything useful. It's just a barrier to the usability of TB.
(In reply to comment #49)
> I really think that this master password prompt at the startup of Thunderbird
> should be removed as it doesn't really do anything useful. 

I don't agree. I also check my personal mailboxes and calendar at work, I don't want any easy access to it when I am not there. Not that I have anything to hide, just a question of privacy.
(In reply to comment #50)
> I don't agree. I also check my personal mailboxes and calendar at work, I don't
> want any easy access to it when I am not there. Not that I have anything to
> hide, just a question of privacy.
A simple screenlock would take care of that as well as preventing anybody gaining access to anything else on your PC.

Also, simply by cancelling the password prompt gives you access to the mail folders anyway so where is the security in that? OK, so you cannot send or download new messages but all the mail folders are all open in their full glory as well as the calendars.

I agree if this worked as one would expect and actually doesn't complete loading TB until, the password is entered then by all means keep it but as it is, it doesn't offer much security and is just an annoyance, especially when it asks for the password multiple times.

We should at least have the option to opt-in or out to being prompted for a password on TB start-up. The opt-in or out should not affect being asked for the master password when revealing the mail account passwords though. Those should always be protected.
(In reply to comment #49)
> I really think that this master password prompt at the startup of Thunderbird
> should be removed as it doesn't really do anything useful. It's just a barrier
> to the usability of TB.

The current prompt at startup is a workaround for a more annoying bug (bug 338549) where it would prompt you multiple times for the master password. As the majority of users automatically connect to the server at start up (and hence would see no difference anyway) this is the best work around, whilst we work out the more complex fix to resolve the multiple prompts.

AFAIK this bug should be pretty much fixed with the latest nightlies of both Thunderbird & Lightning - there should only be one prompt on startup assuming you enter it right first time.
I just wanted to point out that if you click cancel on the first dialog, and then key in the master password on the second, you get access to both emails and lightning.
i repeat myself. it's a bug since 4 years!? any solutions would be better then the current one!
(In reply to comment #47)
> 2.:
> make the token thread safe.
> looking at the code I believe it is not by default, but has a locking
> mechanism.

A closer look revealed that the token has no option to lock it [1]

So we could either make it a toolkit bug and wait for a solution or think about a workaround (like check for an open password dialog before calling login again.)


[1]:
http://mxr.mozilla.org/comm-central/source/mozilla/security/manager/ssl/public/nsIPK11Token.idl
Whiteboard: [maybe needed beta 1 rc2][no l10n impact] → [not needed beta][no l10n impact]
There is a toolkit bug for this already: bug 499233. However, Lightning could at least queue its credential requests (analogous to bug 475053) so that we don't get a master password prompt for each calendar. I get three additional master password prompts because of Lightning 1.0b1, that's quite annoying.

Btw, the patch in attachment 397247 [details] [diff] [review] doesn't work for me - I get a prompt on startup and then the "usual" number of password prompts when the Thunderbird window shows up.
(In reply to comment #56)
> There is a toolkit bug for this already: bug 499233. However, Lightning could
> at least queue its credential requests (analogous to bug 475053) so that we
> don't get a master password prompt for each calendar. I get three additional
> master password prompts because of Lightning 1.0b1, that's quite annoying.

I'm not convinced bug 499233 is the right bug for this - its dealing with a different situation. Doing the async like bug 475053 is probably the way to go once we get past gecko 1.9.1.

> Btw, the patch in attachment 397247 [details] [diff] [review] doesn't work for me - I get a prompt on
> startup and then the "usual" number of password prompts when the Thunderbird
> window shows up.

Have you tried Thunderbird 3.0.1 (out in beta) and latest Lightning nightlies (i.e. post 1.0b1)? They have the fixes (i.e. a fix went into each one) for bug 534462 which should be improving the situation.
In answer to #57: I also faced this annoying problem with TB3.0. After upgrading to 3.0.1b (and corresponding lightning/gdata provider) and adding the StartupMaster extension, the problem seems gone ...
(PS: not sure whether StartupMaster is really necessary for TB. It is though certainly still necessary for latest FF beta, hinting that the underlying toolkit problems are still not really holistically fixed ...)
I haven't any problem with thunderbird 2.23 - now I update TB to version 3.0 and I have been asked for:
1. Master password
2. 1st Password to google calendar in lightning for 1st google calendar
3. 2nd Password to google calendar in lightning for 2nd google calendar

I have 3-rd google calendar yet (totally i have 3 calendars), but for 2 of them I use the same google login - so Thunderbird prompts me about passwords for callendars ony 2 times.

I think I should be prompt only once to type master password.
Installing lightning 1.0b1 has solved the problem of being prompted for the master password multiple times. I now only get one prompt when TB starts up.
Running TB 301b1 and Lightning+Google calendar provider latest nightlies... problem still happening: 

With master password activated, I'm still being asked for the password many times: 

- once for the IMAP/POP access I suppose
- once per Google Calendar which require authentication (non-public calendar)
It seems I was a little hasty in saying my set up was work. I just discovered that after upgrading Lightning to 1.0b1 that it broke the google provider. Having now updated GP to the equivalent release has caused TB to request the master password multiple times again.
Running TB 3.0.1/Lightning 1.0b1 (official Solaris 10 build by Sun, January 18, 2010) - I'm still being asked for the password many times: for each WebDAV-based calendar in a separate dialog window.

TB 2.x/Lightning 0.9 (Solaris, Windows) works fine.
Same here.
TB 3.0
Lightning 1.01b
Provider 0.6b1
Now I also tried the latest nightlies, same problem
Duplicate of this bug: 541919
Confirmed:
TB 3.0.1
Lightning 1.0b
Windows Vista

Password is requested once for email and once for each calendar.  In this case I have two CalDAV calendars, both at Google.  I am prompted three times for the password.
Confirmed:
TB 3.0.1
Lightning 1.0b
Provider for Google Calendar 0.6b1
Win7 Pro

*extremely* annoying.  I have several gCal calendars configured so have to answer many Master Pw prompts to get TB going now.
Confirmed:
TB 3.2a1pre
Lightning 1.1a1pre
Provider for Google Calendar 0.7pre

One prompt for the email accounts and then one more for each separate Google calendar.

Mozilla/5.0 (Windows; U; Windows NT 6.1; en-US; rv:1.9.3a1pre) Gecko/20100202 Lightning/1.1a1pre Shredder/3.2a1pre
Duplicate of this bug: 541814
Duplicate of this bug: 546181
I think this is more of a Mozilla password manager "feature".  If a request is made to get saved passwords when the master password hasn't been entered it results in a request for the master password.  If there are multiple attempts to get saved password information on startup then you will get multiple requests.

Firefox has this problem too.  If you have several saved tabs using saved password information that try to load when Firefox starts you will end up with multiple requests for the master password.
I confirmed Firefox 3.6 does *not* prompt for the password multiple times when loading multiple tabs that require saved passwords.

Tested with three tabs using Basic HTTP authentication with three different credentials across three different domains.  Master password was requested once and all authentication prompts were filled.
I'm using Ubuntu so I've been using the nightly build from the PPA to get my 3.6.

It's a 3.6.1pre build from 20100122.

If I start Firefox with *ONLY* two tabs for the following URLs I get two password requests:

https://login.yahoo.com/config/login?.pd=c%3DaMtFxUmp2e6zaBL942f2v6LoDw--&.src=my&.intl=us&.done=http%3A%2F%2Fmy.yahoo.com

https://www.google.com/accounts/ServiceLogin?service=mail&passive=true&rm=false&continue=https%3A%2F%2Fmail.google.com%2Fmail%2F%3Fui%3Dhtml%26zy%3Dl&bsv=zpwhtygjntrz&ss=1&scc=1&ltmpl=default&ltmplcache=2&hl=en


You need to have credentials saved for both GMail and your Yahoo account on your My Yahoo page.

You need to have logged out first so that you aren't starting with and cookie based sessions.
There are a few firefox bugs (tracked in bug 177175) on multiple saved passwords, some situations were fixed, others were not. This is something that should be fixed in toolkit, but if we find a workaround then we'll gladly take it.
This is happening for me, incredibly annoying. Almost enough to roll back to TB 2.x

TB 3.0.1
Lightning 1.0b1
Google 0.6b1
There are two work-arounds for this problem:

1. use an empty Master password

2. use StartupMaster add-on (TB 3.0.1)
   https://addons.mozilla.org/en-US/firefox/addon/9808

   (in install.rdf minVersion is wrong and has to be
   fixed to 3.0.1)

/André
Confirmed

TB 3.0.2
Lightning 1.0b1
Google 0.6b1

StartupMaster solves the problem
StartupMaster goofed something on my end somehow. It goofed how TB was displaying my email so badly that I had to remove it and re-enable the old behavior. I don't know what caused it but StartupMaster was the only change to the system and the problem went away when I removed it. I would have tested it more indepth except it had hidden(where and how, I have no idea) some of my email for some unknown reason and I needed it back ASAP. So it doesn't work for me..:(
StartupMaster hasn't solved my problem. I get prompted for master password before TB starts and then still get a second prompt after TB has started.

Using Mozilla/5.0 (X11; U; Linux i686; en-GB; rv:1.9.1.5) Gecko/20091130 SUSE/3.0.0-1.1.1 Lightning/1.0b2pre Thunderbird/3.0
Duplicate of this bug: 549904
Is this bug really only related to the Lightening add-on? I think this is a common problem of the Thunderbird framework and has to be solved there. So IMO the scope of this bug has to get changed.
Is this still assigned to "nobody"?  Seems like quite a few people are having large enough issues with it...
Thunderbird has "solved" this by creating a component that takes care of the async prompting. Their force master password hack was removed in bug 560746.

We could possibly use their msgAsyncPrompter, but given this is only available for Lightning, it might not be easy to make use of this without making the calendar code too thunderbird specific (i.e seamonkey and sunbird might not have the prompter)
(In reply to comment #84)
> We could possibly use their msgAsyncPrompter, but given this is only available
> for Lightning, it might not be easy to make use of this without making the
> calendar code too thunderbird specific (i.e seamonkey and sunbird might not
> have the prompter)

SeaMonkey has the prompter (or else Thunderbird has broken them without realising).

The prompter code is standalone, so in theory Sunbird could always take it up later if someone started developing it.
I just want to chime in and say this is confirmed (and annoying) in Fedora linux:

thunderbird 3.0.4
Lightning 1.0b2pre
Provider 0.6b2pre

2 email accounts
2 google calendar accounts
2 remote ics calendars
1 local calendar

Prompted 5 times.  I don't think this is just a google calendar problem.
Confirmed with
Ubuntu 10.04 and MS Win XP
actual Thunderbird
actual Ligthning

1 google calendar Account

Cheers
The problem is the same than with email account: thunderbird and lightning should not display anything before the master password is typed successfully by the user when it's set. Firefox works like that.
One other question is why do we need to load calendars when the calendar tab is not displayed ? 
It's easy to delay this from one minute or two.
I experience this problem.

Windows 7 x64
Thunderbird 3.04
Lightning 1.0b1

3 prompts
2 Google Calender Accounts in lightning
Philipp, Mark:  have you determined if msgAsyncPrompter is consistent between Thunderbird and SeaMonkey, and if this component could be added to Sunbird?

If so, how complicated is the switch to using msgAsyncPrompter?

I apologize that I am not familiar with the code.
(In reply to comment #90)
> Philipp, Mark:  have you determined if msgAsyncPrompter is consistent between
> Thunderbird and SeaMonkey, and if this component could be added to Sunbird?

Thunderbird and SeaMonkey use the same version if they are based off the same branch.

Sunbird could have it, but there's no active development there. If someone stepped up to take on Sunbird development, I think it could be put somewhere that Sunbird could include it, but I see no reason to concern ourselves with that at the moment.

> If so, how complicated is the switch to using msgAsyncPrompter?

It depends on how your auth code is written. See bug 338549 and surrounding for some of the way TB did it - but note that's all in c++ whereas I've a feeling Lightning may be doing it in javascript.
I would love to do some work on this bug, because it bugs me also.

Unfortunately this looks to me to be somewhat beyond my knowledge right now.
But if someone or more than one could help me starting this and maybe do some mentoring, I would try.

Any volunteers? ;-)
Keywords: helpwanted
Here are my results:

Installed version:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1.9) Gecko/20100317 Lightning/1.0b1 Thunderbird/3.0.4

I have multiple IMAP accounts with Lightning and use a master password and did not have to enter it more than once. However, upon adding several remote calendars that use CALDAV and authentication, I have lost count of the number of master password prompts that show up on startup, though it definitely seemed related to the number of remote calendars that used authentication.

The good news is that installing the Startupmaster add-on has brought the number of master password prompts back to 1. 

Just thought I would share this in case it helps anyone.
Carl - GENIUS!

Startupmaster is the fix!

Go here: 
Right click the "Add to firefox link" and "save target as..."
Save it to your desktop or something.
Go to thunderbird -> addons -> install.
Select this file.

Restart, and fixed!!
I think Startupmaster is a workaround.
We should not require our users to install an addon to ensure proper behaviour.

Please refrain from posts stating you have the same problem for now, since it is well conceived it exists.

I'll see if I can get into this.
Assignee: nobody → Mozilla
Status: NEW → ASSIGNED
I think, that it is more general problem. Password manager unlocking should be a "singleton" action  - so that, when master password is asked then password manager goes into state, that shows it. If some module tries to get password, while waiting master password, then the request should be queued or given temporary error (try again later) (depending, which is more suited in Thunderbird). 
Anyway, things are much worse in Thunderbird 3.1, where the prompt is shown for every IMAP/POP3 account that is set to check new messages on startup. I don't have Lightning that works with this version, bu I guess, that it would be same there.
Duplicate of this bug: 570875
I'm using: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.1.10) Gecko/20100528 Lightning/1.0b1 Thunderbird/3.0.5 (on Ubuntu 10.04 amd64)

I get one password prompt for EVERY calendar i have defined in Lightning, and even if i enter the correct password in EVERY password dialog, Lightning never displays the calendar.  This makes it impossible to use Lightning in conjunction with a master password.  If i remove the master password, everything works fine.
I forgot to add: StartupMaster resolves the problem for me.
I've been experiencing this problem only since Thunderbird 3.
The master password for the email addresses is accepted and not requested again per session. My calendars are downloadeded remotely from ftp://xxxxxx@xxxxxxxxxxx and for every calender I need to enter/confirm the password (remember password box is checked) every time the calendar refreshes.
I first logged a question about this in the forums in 2006, and have been hoping for a fix ever since.  I don't use Lightning or calendars, and I have only 1 account that I use with Thunderbird.  The only addons I have are Adblock Plus and Archive This, both of which were added within the last year or so.  Here's the behavior I observe, now with TB 3.0.6 on Windows XP SP3:

1.  Thunderbird launches, and the Software Security Device prompt appears.  If I enter my password within 5 minutes, the prompt goes away and the product performs as expected.

2.  If I don't enter my password within 5 minutes, at the 5-minute mark another SSD prompt appears on top of the first one.  If I enter my password into that box within 5 minutes, I can simply press Return to dispense with the other one.

3.  If I still don't enter my password, at the 10-minute mark yet another SSD prompt appears on top.  

4.  The 3rd box is the last one that will appear.  Further delaying a response to the prompts doesn't trigger any more.

5.  If the password is entered into the top (most recent) SSD box, the others can be dismissed with a Return.  However, if one or more top boxes are dismissed with a Return, then the password must be entered as many times as there were boxes dismissed.  For example, if there are 3 SSD boxes showing and I dismiss the top 2 with a Return, then I have to enter my password 3 times in the first box that appeared.

TB is one of a bunch of apps that I have set to launch on startup, so I usually turn my computer on in the morning and then do other things while the apps are loading.  I often don't sit down at my desk until 20 minutes or more have gone by, so the 3-box situation is one that I encounter almost daily.  It's less annoying since I discovered that the superfluous SSD boxes can be dismissed with a Return, but it's still annoying.  There may be some connection to Lightning and/or calendars, but the problem exists with vanilla TB.
Jim, the dialog probably shows up again after 5 minutes because you have configured Thunderbird to check for new mail every 5 minutes. Please consider upgrading to latest Thunderbird 3.1 release that contains fixes for e.g. Thunderbird Bug 522243 and Thunderbird Bug 553575
I have the latest Thunderbird 3.1.1 and Lightning 1.02b and it still throws up that password window every time the calendar refreshes. Doesn't matter if I type the password immediately after the window pops up, if I press enter, if I wait 5 minutes or 15 or 50. If I wait 50 minutes, I have 10 pop up boxes waiting for me to get rid of.
For clarification: Comment 102 is in reply to the Thunderbird issue mentioned in Comment 101. It is not related to the Lightning issue reported in this bug.
I upgraded to TB 3.1.1.  Now instead of 3 SSD boxes, I get 4.  I guess that's one measure of progress!
I use TB 3.1.1 with LG 1.0b2 against an IMAP server and a Sun Calendar Server (WCAP). My passwords are saved in the password manager and protected by a master password. 
Thunderbird requests a master password input for IMAP accounts and an other for Lightning (only if one or more WCAP calendar is activated). So most of the time, I have two master password requests at TB launch.
Latest TBird, Latest Lightning with Google provider and it prompts for password for every calendar. At work with calendars on FTP, it prompts for password every time it does a refresh on them. We had to turn off automatic refreshes.

This is with a master password set and telling it to save the calendar passwords as well.
This bug has been marked as "NEW", which means: this bug is confirmed (reproducible) and should be resolved. I don't want to be rude, but please don't add your testimony, it won't help the bug to be fixed earlier.

Markus Adrario wrote 2 months ago: /Please refrain from posts stating you have the same problem for now, since it is well conceived it exists/.
so heres what I found out in the meantime:

The master-password prompt comes from the loginManager.
This loginManager has a variable "uiBusy" to indicate, a master password prompt is open.
Unfortunately this is currently only used for filling in user data in webpages as far as I can see.

So we would either have to see that this is fixed in toolkit. There are several bugs related to multiple master-password-prompts in bugzilla, so maybe one of these will fix this problem.

Else we could query "uiBusy" in calAuthUtils and defer a further password query until the master password dialog is closed.

The latter would have to implement an observer for the password dialog and hold the following password-queries.
If anyone can help me with this solution, I would appreciate it.
ok, it seems that the mentioned code only exists in comm-central and not comm-1.9.2.

so for the moment we would have to find out for ourselves if a password prompt is open and observe if it is closed.

Is this possible?
Mozilla/5.0 (Windows; U; Windows NT 6.0; da; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2

I have 4 POP3 accounts - no IMAP accounts

If I deactivate Lightning I am only asked for the master password once.

But when lightning is activated I am asked for the master password exactly 3 times whether or nor any of the POP3 accounts are configured to receive mail (by any of the available options) or not.
Mozilla/5.0 (Windows; U; Windows NT 6.0; de; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2

After the last update (no changes in configuration or any settings) the problem vanished.

Before 3.1.2 I had the same problem as described with 3 IMAP accounts.
Mozilla/5.0 (X11; U; Linux i686 (x86_64); pt-BR; rv:1.9.2.8) Gecko/20100802 Lightning/1.0b2 Thunderbird/3.1.2

Many e-mails accounts, just 1 Google calendar and the problem persists. I have 2 master password been asked.
Hello all,

this is a friendly reminder, the following caps are just to make it more obvious when skimming over the comments:


==================================================
PLEASE DON"T COMMENT WITH HOW MANY PROMPTS YOU GET

We know this is a problem, and depending on your
situation, you may have 2 to N prompts. Thats ok,
this is all the same core problem.

Given this works as expected for Firefox/Toolkit, its highly
unlikely that a newer


==================================================

Its very hard for us to maintain an overview of the technical comments in this bug with all those "this happens for me too" comments. 

Thanks for caring,
Philipp
That should of course mean:
Given this works as expected for Firefox/Toolkit, its highly
unlikely that a newer version of Thunderbird alone will fix this issue.
Returning this Bug to unassigned, since I currently don't have much time to look into it and I hope someone else will look into this important issue.
Assignee: Mozilla → nobody
Status: ASSIGNED → NEW
Duplicate of this bug: 600389
(In reply to comment #58)
> In answer to #57: I also faced this annoying problem with TB3.0. After
> upgrading to 3.0.1b (and corresponding lightning/gdata provider) and adding the
> StartupMaster extension, the problem seems gone ...
> (PS: not sure whether StartupMaster is really necessary for TB. It is though
> certainly still necessary for latest FF beta, hinting that the underlying
> toolkit problems are still not really holistically fixed ...)

I can confirm that StartupMaster corrects the problem for Google Calendars and email. However, if you have an .ics file located on an FTP server - it still prompts you to log into the FTP server. It does fill in the password for you but prompts each time. 

So shouldn't StartupMaster serve as a good starting point to solving this? I have great respect for the Open Source Firefox and Thunderbird/Lightening projects but it looks like this was reported in 2006? and it's listed as New?

I can tell you that we extensively use Thunderbird and Lightening with many of our 500 users. These multiple prompts are really making our users not want to use Lightening with Thunderbird. For us this isn't a minor bug. Yes, it only requires re-entering the password and then the system works but imagine have a large number of shared Calendars N - now enter your password N + 1 times.

If I can help debugging, I'm willing to help but it sounds like it is just a matter of someone picking up and working on this long standing bug.
Temporary work-around (not recommended in unsecure environments): Add the FTP-password to the calendar URI so you won't be asked for a password until the real bug gets fixed, e.g.: ftp://username:password@ftp.calendar.com/calendar.ics

 This helps in getting rid of the multiple password dialogs which pop up especially when the computer is running on its own for several hours.
Duplicate of this bug: 612038
Duplicate of this bug: 629707
This patch is only usable with lightning and thunderbird.
This patch uses the interface nsIMsgAsyncPrompter of thunderbird. 
It only shows a single request for password at a time (master password or account password).
Should I attempt to install this myself, or will this be included in a Thunderbird/Lightning update soon? & can I use the installation procedure given in bug #542998 comment 22 (https://bugzilla.mozilla.org/show_bug.cgi?id=542998#c22)?
(In reply to comment #122)
> Created attachment 528856 [details] [diff] [review]
> patch that requires the master password once
> 
> This patch is only usable with lightning and thunderbird.
> This patch uses the interface nsIMsgAsyncPrompter of thunderbird. 
> It only shows a single request for password at a time (master password or
> account password).

Didn't work for me.

Mozilla/5.0 (Windows; U; Windows NT 6.1; de; rv:1.9.2.17) Gecko/20110414 Lightning/1.0b2 Thunderbird/3.1.10 + GData Provider 0.7.1

I also don't find where asyncPromptAuth or promptAuth are used.
This patch fixes the issue for me, on the calendar side at least.

Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9.2.17) Gecko/20110429 Lightning/1.0b3pre Thunderbird/3.1.10

I have two IMAP mailboxes and several calendars.  Before there were many prompts at startup; now there are only two. (There is only one prompt if I get rid of one of the IMAP mailboxes.)

@Ronny:  What happens if you apply this patch to the current Lightning code base, using a nightly snapshot or Mercurical?
(In reply to comment #125)
> @Ronny:  What happens if you apply this patch to the current Lightning code
> base, using a nightly snapshot or Mercurical?

works now :)
@Philipp Kewisch, @Stefan Sitter, @Martin Schröder:

Is this an acceptable patch? It seems to work under Windows and Linux.
Comment on attachment 528856 [details] [diff] [review]
[for beta]patch that requires the master password once

Yes, I will likely grant review here. The only issue here is that we are relying on an interface provided by Thunderbird. There are two cases where this might be bad:

1) Sunbird doesn't implement this (which is ok, since we don't support SB atm)
2) Seamonkey or Postbox might not implement this interface.

I would rather go for a solution that works at least in one case but we should contact other parties though to see if they implement it.
Attachment #528856 - Flags: review?(philipp)
Assignee: nobody → philippe.martinak
Status: NEW → ASSIGNED
Keywords: helpwanted
Attachment #528856 - Attachment description: patch that requires the master password once → [for beta]patch that requires the master password once
(In reply to comment #128)
> Comment on attachment 528856 [details] [diff] [review] [review]
> [for beta]patch that requires the master password once
> 
> Yes, I will likely grant review here. The only issue here is that we are
> relying on an interface provided by Thunderbird. There are two cases where
> this might be bad:
> 
> 1) Sunbird doesn't implement this (which is ok, since we don't support SB
> atm)
> 2) Seamonkey or Postbox might not implement this interface.
> 
> I would rather go for a solution that works at least in one case but we
> should contact other parties though to see if they implement it.

Note that Lightning (1.0b3pre with TB 3.1.10, Fedora 14 x86_64) currently also has the following problem which seems related (and I bet is fixed by this patch):

* Lightning's own password manager requests are nor serialized.

I am getting 3 password manager prompts simultaneously on each TB start: 2 from lightning (for 2 calendars) and 1 (always the last one) from TB for imap. That really does not scale when you want to use Lightning in a group-ware environment, subscribing to all team members' calendars.

Michael
(In reply to comment #129)
> Note that Lightning (1.0b3pre with TB 3.1.10, Fedora 14 x86_64) currently
> also has the following problem which seems related (and I bet is fixed by
> this patch):
> 
> * Lightning's own password manager requests are nor serialized.
> 
> I am getting 3 password manager prompts simultaneously on each TB start: 2
> from lightning (for 2 calendars) and 1 (always the last one) from TB for
> imap. That really does not scale when you want to use Lightning in a
> group-ware environment, subscribing to all team members' calendars.
> 
> Michael

@Michael: please see comment 125, this seems to be addressed.
So is this patch working?
I'm a total dork when it comes to implementing things like this (should have a double-click thingy which goes full-auto), so can anyone explain to me how to install this in my Lighting?
Tested on FreeBSD, TB-1.3.10+lightning-1.0 patched with this patch:
Two prompts only (with 5 calendars), this is not perfect but becomes useable !
Please commit it !
@marinus:  Until this patch is accepted and rolled into an automatic nightly build, you have to compile a custom version of Lightning that includes this patch.  This could be an involved process if you have not done it before; you need to download the latest Thunderbird 3.1/Lightning 1.0 (or "comm-1.9.2") source code from the Mercurial version control system; apply the patch from this bug report to the source code; configure the build system for Lightning; run the build; and finally install the .xpi file that is created.  See https://developer.mozilla.org/en/Build_Documentation
Comment on attachment 528856 [details] [diff] [review]
[for beta]patch that requires the master password once

Both Postbox and Seamonkey support the async prompter, so I think we have good reasons to take this. r=philipp
Attachment #528856 - Flags: review?(philipp) → review+
Pushed to comm-central <http://hg.mozilla.org/comm-central/rev/84251abfe297>
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Trunk
Backported to comm-miramar <http://hg.mozilla.org/releases/comm-miramar/rev/d10008fff7ab>
Target Milestone: Trunk → 1.0b4
Changeset http://hg.mozilla.org/comm-central/rev/84251abfe297
applied to Lightning 1.0b2 / Thunderbird 3.1.10 on Win32 XP and fails!
Before change, masterpassword is asked many times at the same moment, but 1 typing + many cancels works.
After change, masterpassword is asked many times, one after one, with password typing necessary each time!

--> NOT FIXED!
Could you instead test this with a latest nightly, together with a Thunderbird 5 beta? It may well be that there are more fixes in the core platform, that improve the situation.
I'm sorry, but I need a stable version (no test environnement, only production).
It's why I installed a build environnement and compile comm-1.9.2 to get Lightning with Thunderbird 3.1.10... but without any success.
I'm afraid, I'll wait for a new stable version of Thunderbird with this correction included...
Thunderbird 5.0
Lightning 1.0b4
Provider for Google Calendar 0.8
Two master password prompts at startup.
So, still broken. 
Only thing it changed is, that instead of 3 prompts I get 2 (I have 2 remote calendars, one Google and one webdav).
What I dontr understand is, why it's even possible to get multiple master password prompts. Shouldn't password manager deal with this?
Thank you Virgo.
(In reply to comment #140)
> What I don't understand is, why it's even possible to get multiple master
> password prompts. Shouldn't password manager deal with this?

One more fact with Thunderbird 3.1.10 and Lightning 1.0b2 with master password set:
. about 10 POP & IMAP e-mail accounts, passwords registered
. about 20 webdav calendars with only one DAViCal account
  - if webdav password registered, about 20 master password prompts
  - if webdav password not registered, only 1 webdav login+password prompted + 1 master password prompt
Today's beta uplift is not transplanting this cset (http://hg.mozilla.org/releases/comm-beta/rev/6a406cf2cc0b ) to the new head, and this bug does not indicate its on aurora or what, so please verify this is correct where you need it.
I am observing this behaviour with Thunderbird 6.0 / Lightning 1.0b5 under Windows 7 SP1.  This behaviour has been consistent since the days of Thunderbird 2 / Lightning 0.6(?).  (I've lived with it as a minor yet constant annoyance for years, mitigated by the fact I only reboot my PC when absolutely necessary.)  I use several Google calendars, and need to enter the master password 3-4 times on start up.

Could someone with appropriate permissions re-open this bug until it's actually fixed?
Hi Callek,

The change set you mention is the same than http://hg.mozilla.org/releases/comm-miramar/rev/d10008fff7ab I test in june, and did not solve the problem on Lightning 1.0b2 / Thunderbird 3.1.10 on Win32 XP but aggravate it.

So, no problem with not transplanting this cset, but this bug should be re-open to fix it in an other way.

Note that Lightning password prompt rise before TB splash screen and before TB master password prompt when calendar password is not registered.
So, I suppose Lightning extension startup faster than TB startup could be a cause of this bug.

Could it be reopened ? Shall I create a new one ?
Cyrill, Callek's comment is relevant for tree management, and is about the situation post-1.0b5. This fix is not contained in 1.0b2, but only in 1.0b5. Nevertheless its possible that this bug is not fully fixed so please do open a new bug if this still persists on 1.0b5 (as Christi mentioned). A reference to that bug here would be nice.
It is still there in 1.0b5 for me unless I use StartupMaster.
No way to test Lightning 1.0b5 with TB 3.1, so I built a new (VM) Linux machine specially to test this fix.

With TB 6.0 + Lightning 1.0b5, I found this bug fixed (but not very clean) in normal conditions, and still buggy in timeout conditions.

See new created bug https://bugzilla.mozilla.org/show_bug.cgi?id=682474
This is still happening, I'm running TB 7.0 and lightning 1.0b7 on Mac and have to enter the master password twice on every restart.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.6; rv:7.0) Gecko/20110922 Thunderbird/7.0
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Mozilla/5.0 (Windows NT 5.1; rv:7.0) Gecko/20110922 Thunderbird/7.0 
+ LG1.0b7 
+ GCal Provider 0.9pre
= 3 requests for master password on every (re)start.

The bug is still alive.
It's probably not the solution people are generally looking for, but I installed the Provider for Google Calendar add-on and let everything run through the Google Calendar. I can even sync Lightning Calendar now with my Android phone and it doesn't ask for a password anymore.

Maybe a solution for some of you until this issue is resolved.
WinXP, TB 7.0, LG1.0b7
about 10 pop or imap email account on 3 servers
1 DAViCal account to access about 30 CalDAV calendars on 1 LAN server

In normal conditions (no timeout), master password asked only once, but master password window displays fist and hidden by main TB window at startup.

Timeout conditions not tested
(see https://bugzilla.mozilla.org/show_bug.cgi?id=682474).
This problem does not occur when StartupMaster addon is installed. Also, I like the behavior that the the main screen is only visible after entered the correct password.
Is it possible to implement the code or the same kind of behavior of StartupMaster into Thunderbird itself?
(In reply to Coyote from comment #152)
> This problem does not occur when StartupMaster addon is installed. Also, I
> like the behavior that the the main screen is only visible after entered the
> correct password.
> Is it possible to implement the code or the same kind of behavior of
> StartupMaster into Thunderbird itself?

That's a great workaround tip - thanks!  Also, yes it would be great if enabling Master Password in Thunderbird created a user experience like StartupMaster where you enter it first in order to start the application. Otherwise using a Master Password in Thunderbird doesn't really do much protecting since an intruder could still view all my currently downloaded emails.
Same here on Ubuntu Oneric with Thunderbird 7.0.1, Lightning 1.0b7 and Provider for Google Kalender 0.8. 
The password is always asked a second time otherwise the Calendar would not load. The second password window is always in the background and just clicking OK without entering the Password is enough.
Please file a new bug for any remaining issues.  bugs with patches delivered should stay marked FIXED, as noted in comment 145.

If possible, new bug should be based on testing with builds newer than version 7, from these choices 

[1] Daily - pre-alpha, version 10
use ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-central/ with lightning and provider addon from ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-central/

[2] Aurora - alpha, version 9
use ftp://ftp.mozilla.org/pub/thunderbird/nightly/latest-comm-aurora/ with lightning and provider addon from ftp://ftp.mozilla.org/pub/calendar/lightning/nightly/latest-comm-aurora/
Status: REOPENED → RESOLVED
Closed: 8 years ago8 years ago
Resolution: --- → FIXED
If patch does not fix the bug, then why should a new bug be created for it? It's still same problem. And comment 145 does not give any reason for this.
I think after over 150 comments its time for a new bug. We're not saying this issues doesn't exist, but rather that it would be better to post a new bug so its easier to overview whats going wrong after the previous patch has been checked in.
This new bug is already filed: https://bugzilla.mozilla.org/show_bug.cgi?id=682474
See comment 147
But that bug is different. He says, that second password prompt shows up after 10 minutes of waiting. I have currently Lightning 1.0b7 and Thunderbird 7.0.1 and I get two master password prompts immediatly at startup. There is now waiting involved.
I get a password prompt at start-up for every calendar I have installed.
Then, depending on how I have set the refresh/reload time I get a password prompt for every reload.

I assume that this 10 minutes of waiting refers to his calendar refresh/reload time.
Why not just incorporate StartupMaster into the build. It solves this problem which has gone unfixed for years.
(In reply to Wayne Mery (:wsmwk) from comment #155)
> Please file a new bug for any remaining issues.  bugs with patches delivered
> should stay marked FIXED, as noted in comment 145.
> 

ok, i've not read the the mozilla messaging policy on bugs lifecycle, you may be right.
Maybe the policy is false or maybe the bugzilla "reopen" feature should not be available... 

I'm bored by that functional breakdown in the Master Password mozilla's product feature : i've already voted for 4 bugs related to that since 2006...

I'm switching to #682474 and waiting for bug triage...
Summer of 2012 and STILL we have to install StartupMaster to camouflage this bug?

Sad, very sad..
And why does it say "resolved Fixed" here?
I'm running Win7 Ultimate and Thunderbird 13.0.1 and I'm not seeing this bug anymore. I did before, but it seems to be gone...?
Win7 Ultimate and Thunderbird 15.0 still requests the Master Password twice, once for mail and once for Lightning.
Win XP + TB 12 + L 1.4: master password is asked once + once per 10 minutes wait before entering master password.
i'm also seeing this with:

windows 7 ultimate 64bit german
thunderbird 16.0.1 english
lightning 18
google calendar provider 0.17

please fix this!
I get multiple requests for the master password
- Thunderbird 16.02
- Lightning 1.8
- SOGo-Connector 10.0.3
- Windows 7

It looks as if there is a pop-up for every mail-account. If I type in the master password on the i.e. third pop-up, only the mail in the third account and above are fetched. If I close all the additional pop-ups until the first one (the one hidden behind the main window, see below) then everything works as expected.

Another annoying behavior is that the first pop-up window is at the bottom of the window stack, even behind the main window. I would like it to be the top-most.

In my opinion, the original bug might be solved, but there is another popping up ;-)

Othmar
Othmar and other, please see the new report filed as bug 682474.
You need to log in before you can comment on or make changes to this bug.