Last Comment Bug 484166 - Make use of firefox search icon
: Make use of firefox search icon
Status: RESOLVED FIXED
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: Trunk
: All Linux
: -- enhancement (vote)
: Thunderbird 3.0b3
Assigned To: Bryan Clark (DevTools PM) [@clarkbw]
:
:
Mentors:
Depends on: 506626
Blocks:
  Show dependency treegraph
 
Reported: 2009-03-19 04:32 PDT by Andreas Nilsson (:andreasn)
Modified: 2009-08-08 21:58 PDT (History)
5 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch against nightly (385 bytes, patch)
2009-03-19 04:46 PDT, Andreas Nilsson (:andreasn)
no flags Details | Diff | Splinter Review
hg patch using ff search icon (859 bytes, patch)
2009-03-30 16:46 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details | Diff | Splinter Review
version 2, which includes the necessary jar.nm file change (2.53 KB, patch)
2009-03-30 16:49 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details | Diff | Splinter Review
screenshot of search icons compared (9.79 KB, image/png)
2009-03-30 16:50 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details
search box w/ arrow on left side (2.93 KB, image/png)
2009-03-30 17:06 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details
screenshot of philor's suggestion in action (2.90 KB, image/png)
2009-03-31 04:50 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details
middle aligned new dropdown arrow against the new search (3.84 KB, patch)
2009-03-31 05:08 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details | Diff | Splinter Review
screenshot of the RTL quick search (3.87 KB, image/png)
2009-04-02 15:53 PDT, Bryan Clark (DevTools PM) [@clarkbw]
no flags Details
updated patch w/ RTL fix (3.94 KB, patch)
2009-04-02 15:56 PDT, Bryan Clark (DevTools PM) [@clarkbw]
philringnalda: review+
Details | Diff | Splinter Review
[checked in] update w/ fuzz fixes (2.75 KB, patch)
2009-04-22 13:50 PDT, Bryan Clark (DevTools PM) [@clarkbw]
clarkbw: review+
Details | Diff | Splinter Review
screenshot of the search icon in pinstripe (69.44 KB, image/png)
2009-07-28 06:42 PDT, Andreas Nilsson (:andreasn)
no flags Details

Description Andreas Nilsson (:andreasn) 2009-03-19 04:32:55 PDT
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.0.7) Gecko/2009030422 Ubuntu/8.10 (intrepid) Firefox/3.0.7 Ubiquity/0.1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b4pre) Gecko/20090318 Shredder/3.0b3pre

Firefox have a much nicer search icon than Thunderbird currently.

Reproducible: Always
Comment 1 Andreas Nilsson (:andreasn) 2009-03-19 04:46:51 PDT
Created attachment 368230 [details] [diff] [review]
patch against nightly

As the icon is already shipped inside global, all that's needed is to change the url.
Comment 2 Tyler Downer [:Tyler] 2009-03-19 07:23:38 PDT
Comment on attachment 368230 [details] [diff] [review]
patch against nightly

Not sure who this should go to.
Comment 3 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-26 17:50:13 PDT
Cool, this looks super easy. :)  I'll make a patch out of this on Saturday.  Maybe I can bump another review over to philor
Comment 4 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-30 16:46:56 PDT
Created attachment 370100 [details] [diff] [review]
hg patch using ff search icon

here's the patch that changes us over to using the FF search icon.  I noticed that the drop down arrow intersects the new search icon because it is at a different angle than ours currently is.  Not sure if that's intended, will attach screenshot.
Comment 5 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-30 16:49:53 PDT
Created attachment 370102 [details] [diff] [review]
version 2, which includes the necessary jar.nm file change

missed including the jar.nm file
Comment 6 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-30 16:50:34 PDT
Created attachment 370103 [details]
screenshot of search icons compared

here's the comparison of the search icons TB2 vs. TB3 + previous patch
Comment 7 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-30 17:06:23 PDT
Created attachment 370107 [details]
search box w/ arrow on left side

andreas: i tried this alternate version where I took the gif, auto-cropped it, and converted it to a png.  Then changed this css in the searchBox.css

.quick-search-button-dropmarker {
  margin-top: 14px;
  list-style-image: url("chrome://messenger/skin/icons/search-arrow.png");
}

If that's something we want to do we instead, we can change the patch to that.  

Hopefully we can get philor to review it once we've got a patch that's ready.
Comment 8 Phil Ringnalda (:philor) 2009-03-30 17:20:36 PDT
What happens if you just get rid of (or decrease, I don't know if some is required to not have it clear at the top) the margin-top on the dropmarker, which is shoving it down toward the bottom? Isn't the natural and normal spot for a dropmarker vertically centered, and it was only being pushed down because we were using a Windows-style leaning-right magnifying glass that needed the dropmarker shoved down below its glass?

Are there native apps that use the (I presume that's native direction) leaning-right magnifying glass with a dropmarker, and if so where do they put it?
Comment 9 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-31 04:50:42 PDT
Created attachment 370178 [details]
screenshot of philor's suggestion in action

(In reply to comment #8)
> What happens if you just get rid of (or decrease, I don't know if some is
> required to not have it clear at the top) the margin-top on the dropmarker,
> which is shoving it down toward the bottom? Isn't the natural and normal spot
> for a dropmarker vertically centered, and it was only being pushed down because
> we were using a Windows-style leaning-right magnifying glass that needed the
> dropmarker shoved down below its glass?

It's amazing how simple that is.  Here's the screenshot showing what that looks like.  I only bumped the margin-start up 1px so it doesn't overrun the search icon.

> Are there native apps that use the (I presume that's native direction)
> leaning-right magnifying glass with a dropmarker, and if so where do they put
> it?

I couldn't find a single other use of our next generation search icon w/ drop marker, the future must not be evenly distributed.
Comment 10 Andreas Nilsson (:andreasn) 2009-03-31 05:06:20 PDT
Bryan: that looks great!

Couldn't find any search icons with drop downs either. Evolution, Banshee and Transmission all use search icons that pops up a menu when you click them, but none of them use any arrow.
Comment 11 Bryan Clark (DevTools PM) [@clarkbw] 2009-03-31 05:08:18 PDT
Created attachment 370179 [details] [diff] [review]
middle aligned new dropdown arrow against the new search

here's the patch that makes it happen.

updated jar.mn file
removed the old Search-bar icon
converted search-arrow.gif to search-arrow.png
css changes to make it all happen
Comment 12 Phil Ringnalda (:philor) 2009-04-02 07:25:05 PDT
How close to working in RTL is Gnomestripe's searchbox? Can we drop in bug 481860's -moz-transform: scaleX(-1) to flip the image, and get everything happy?
Comment 13 Bryan Clark (DevTools PM) [@clarkbw] 2009-04-02 15:53:29 PDT
Created attachment 370741 [details]
screenshot of the RTL quick search

(In reply to comment #12)
> How close to working in RTL is Gnomestripe's searchbox? Can we drop in bug
> 481860's -moz-transform: scaleX(-1) to flip the image, and get everything
> happy?

Got it working.  Had to figure out how to test in the RTL mode.  Ended up writing a blog entry on it. http://clarkbw.net/blog/2009/04/02/testing-rtl-in-thunderbird/

Will attach patch for review in a sec.
Comment 14 Bryan Clark (DevTools PM) [@clarkbw] 2009-04-02 15:56:39 PDT
Created attachment 370743 [details] [diff] [review]
updated patch w/ RTL fix

here's the updated patch for review.  Only real change is the addition of the chromedir="rtl" selector.  I could have done a more specific child selector, but it doesn't look very pretty.

#quick-search-button[chromedir="rtl"] > stack > hbox > .quick-search-button-image
Comment 15 Phil Ringnalda (:philor) 2009-04-21 22:53:13 PDT
Comment on attachment 370743 [details] [diff] [review]
updated patch w/ RTL fix

Sorry to be so slow - you've picked up a bit of rot in the jar.mn hunk, but other than that it looks great.
Comment 16 Bryan Clark (DevTools PM) [@clarkbw] 2009-04-22 13:50:21 PDT
Created attachment 374134 [details] [diff] [review]
[checked in] update w/ fuzz fixes

(In reply to comment #15)
> Sorry to be so slow - you've picked up a bit of rot in the jar.mn hunk, but
> other than that it looks great.

Thanks Phil!  Updated to fix the rot issues.  carrying forward the review+
Comment 17 Bryan Clark (DevTools PM) [@clarkbw] 2009-04-22 14:44:52 PDT
I should probably continue in here or spin out other bugs for qute and pinstripe themes to do the same thing.
Comment 18 Mark Banner (:standard8) 2009-04-23 01:47:19 PDT
Comment on attachment 374134 [details] [diff] [review]
[checked in] update w/ fuzz fixes

Checked in: http://hg.mozilla.org/comm-central/rev/69b81aa3618c

I'll let Bryan decide where he wants to do pinstripe and qute.
Comment 19 Andreas Nilsson (:andreasn) 2009-07-28 05:35:14 PDT
Filed bug and patch for Vista (and XP) icon: https://bugzilla.mozilla.org/show_bug.cgi?id=506626

Need to check the status on pinstripe.
After that I think we can close this.
Comment 20 Andreas Nilsson (:andreasn) 2009-07-28 06:42:21 PDT
Created attachment 391070 [details]
screenshot of the search icon in pinstripe

Here is a screenshot of Thunderbird on OS X. Firefox main window at the top, Thunderbird in the middle and Firefox bookmarks in the bottom. The icons in FX bookmarks and TB looks the same.
Comment 21 Markus Stange [:mstange] 2009-07-28 10:08:59 PDT
I fixed Mac in bug 491360.

Note You need to log in before you can comment on or make changes to this bug.