non-resolving hosts should have the URL filled out when opening in a new window

RESOLVED DUPLICATE of bug 70682

Status

P3
enhancement
RESOLVED DUPLICATE of bug 70682
18 years ago
10 years ago

People

(Reporter: acraigwest, Assigned: gagan)

Tracking

Trunk
Future

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; WinNT4.0; en-US; m18) Gecko/20000810
BuildID:    20000081008

When I open a link in a new window, but the hostname fails to resolve, I get a
Mozilla window with a blank URL line. It would be preferable if the URL that did
not resolve were in the line, so that I could attempt to re-load the page.
This would be useful in cases where there are transient DNS problems. In my
case, we have a firewall that has a broken DNS which fails on any host which is
not in its cache, but succeeds on the next attempt. As a workaround, I have to
open the link twice, and close the blank window.

Reproducible: Always
Steps to Reproduce:
1.NA
2.
3.

Actual Results:

Expected Results:

Comment 1

18 years ago
asa - any ideas where this should go? Netwerking or event handling?

Comment 2

18 years ago
over to Editor first.  Confirmed with 081108 on NT
Assignee: asa → beppe
Status: UNCONFIRMED → NEW
Component: Browser-General → Editor
Ever confirmed: true
QA Contact: doronr → sujay

Comment 3

18 years ago
moving to networking, this is not an editor issue
Assignee: beppe → gagan
Component: Editor → Networking
QA Contact: sujay → tever
(Assignee)

Updated

18 years ago
Target Milestone: --- → Future

Comment 4

18 years ago
*** Bug 58882 has been marked as a duplicate of this bug. ***

Comment 5

18 years ago
*** Bug 58882 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
*** Bug 58882 has been marked as a duplicate of this bug. ***
(Reporter)

Comment 7

18 years ago
Is anybody working on this? If I get some time in the near future, I'll give it
a go...
*** Bug 66245 has been marked as a duplicate of this bug. ***

Comment 9

18 years ago
A very easy way to reproduce this is to go offline (click on the plug in the
bottom left corner) and then Ctrl-Click on some link. You're getting a new,
totally blank window - no warning, no error, nothing. (Okay, the last part would
be bug 45421.)
Expected: going online again and hitting reload would load that page.
*** Bug 68463 has been marked as a duplicate of this bug. ***
A patch for this just got attached to bug 70682.

Comment 12

18 years ago
*** Bug 71580 has been marked as a duplicate of this bug. ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE
Since bug 70682 ("When opening a link in new window, the URL is not filled
before the page is starting to load") has a patch attached, marking duplicate.

*** This bug has been marked as a duplicate of 70682 ***

Updated

16 years ago
Component: Networking → URL Bar
QA Contact: tever → claudius
Product: Core → SeaMonkey
You need to log in before you can comment on or make changes to this bug.