Closed Bug 485305 Opened 12 years ago Closed 12 years ago

browser window shakes when you preview a persona

Categories

(Mozilla Labs Graveyard :: Personas Plus, defect, P2)

defect

Tracking

(Not tracked)

RESOLVED FIXED

People

(Reporter: samuel.sidler+old, Assigned: sgupta)

References

()

Details

Wow, so... I didn't have Personas but I installed it to try it out. The preview when I hover is not only jarring, it's confusing.

First off, the entire browser changes when I hover something. That's jarring in and of itself, but *also* the content area moves around in a weird way and back again. This is a really, really jarring affect. Like I'm extra tired and hopped up on caffeine so my eye sight is bad.

Secondly, this behavior is confusing. When I hover, I think the site is changing my Persona even though I never asked it to! By asking, I discovered this wasn't the case, but it's a non-obvious behavior.

This is especially bad if I'm just scrolling a gallery and my Persona keeps changing. Was this behavior even tested on a few end-users? It bothers me in all sort of ways and I'm more "advanced" than most users...

(Apparently once I clicked on one of the images to preview (see bug 485304) and it selected it. Now I don't know how to get back to my old Persona because I don't know what it was called or where it is in the Gallery. Super annoying.)
Priority: -- → P2
Assignee: cbeard → sgupta
I talked to Sam about this a bit, and he demonstrated it on his laptop, and I realized that this is caused by Personas changing the size of the window by one pixel and then quickly changing it back when it applies a persona on Mac in order to make the titlebar color change get applied.

The code that does that looks like this:

  // FIXME: Incredibly gross hack in order to force a window redraw
  // event that ensures that the titlebar color change is applied.
  ...
  if (window.windowState != Ci.nsIDOMChromeWindow.STATE_MINIMIZED) {
    window.resizeTo(parseInt(window.outerWidth)+1, window.outerHeight);
    window.resizeTo(parseInt(window.outerWidth)-1, window.outerHeight);
  }

I thought I'd filed a Core bug about this, but it turns out I didn't, so I've filed bug 485451.
Depends on: 485451
Summary: Website: Preview on hover is jarring and confusing → browser window shakes when you preview a persona
So bug 485451 is fixed, which means we can get rid of gross hack?

Also, is this the same as the bug that causes the titlebar to be kinda fugly on OSX?
(In reply to comment #2)
> Also, is this the same as the bug that causes the titlebar to be kinda fugly on
> OSX?

Oh, no, that's bug 494927
(In reply to comment #2)
> So bug 485451 is fixed, which means we can get rid of gross hack?

Yes, so I've removed the gross hack <http://hg.mozilla.org/labs/personas/rev/ce6559554cf7> and pushed an updated development build <https://people.mozilla.com/~cbeard/personas/dist/personas-dev.xpi>.


(In reply to comment #3)
> (In reply to comment #2)
> > Also, is this the same as the bug that causes the titlebar to be kinda fugly on
> > OSX?
> 
> Oh, no, that's bug 494927

Actually bug 494927 is about getting Personas' toolbarbutton icons into core.  I think you're thinking about bug 486536, which is about the ability to specify the titlebar text color.

Besides the text color issue, there's also some fugliness in the shadowing of the titlebar buttons (Close, Minimize, Maximize, Hide Toolbars), which use the same color shadow no matter what the titlebar background color, which is particularly noticeable with dark titlebar background colors like the black one specified by the Abstract Black persona <http://www.getpersonas.com/persona/3469>.  I don't think we have a bug on this issue yet, and I'm not sure if it's something fixable.
Status: NEW → RESOLVED
Closed: 12 years ago
Resolution: --- → FIXED
Product: Mozilla Labs → Mozilla Labs Graveyard
You need to log in before you can comment on or make changes to this bug.