Open Bug 485887 Opened 15 years ago Updated 1 year ago

File upload using the standard upload control keeps file open (perhaps also a file handle leak)

Categories

(Firefox :: File Handling, defect)

x86
Windows XP
defect

Tracking

()

REOPENED

People

(Reporter: ivo, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8

File uploads, for example attaching files to a webmail, keep the file open after the upload is done.

This results in not being able to remove or delete the file after you are done sending it. As a result I first have to open process manager, close the file handle and then I'm able to delete it.

File stays open until I close the browser. Have not tested if it is closed if you upload another file.

Reproducible: Always

Steps to Reproduce:
1. Upload a file via any web page
2. Try to delete the file that you have successfully uploaded
3.
Did you searched before filing this bug ?
Do you use livehttpheaders or Firebug ?
Did you tested it in the Firefox safemode before reporting this bug ?
( http://support.mozilla.com/en/kb/Safe+Mode )
This bug still exists in 3.0.8. It happens in both normal and safe mode. File handles remain open after uploading the files. 

Forcing the handle to close, by an external tool does not seem to do any harm to FF.
I have tested this in Firefox 3.0.10 and it appears to be a problem with Firebug when you have the Net panel enabled.  I turned off the Net panel and the problem disappears.  I also tested this in safe mode and it does not keep the file open.
How did this not get nominated for 3.5?

It seems to be related to Firebug though, even without the Net panel enabled.  I can't reproduce this in a fresh profile.  Process Explorer is handy to see whether the handle is being kept open or not.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: blocking-firefox3.6?
Firebug and Live HTTP Headers have both been known to cause this, see:

https://www.mozdev.org/bugs/show_bug.cgi?id=19262
https://bugzilla.mozilla.org/show_bug.cgi?id=479778

Since comment 2 suggests this happens in safe mode, let's ignore those potential causes?

This could also be a dupe of bug 459384.
not able to delete a file uploaded, before closing the fire fox!
I can confirm that this bug is still occurring in ff3.5.1. I also have both firebug (1.4.2) and LiveHttpHeaders (0.15) add-ons installed.

Using Process Explorer (on Microsoft Windows Vista SP2), I am unable to forceably close the file handle (error is "file handle is invalid").

Also, it appears that uploading another file releases the first file handle, so this probably isn't a file handle leak... it's just that the last file uploaded is stuck open by ff/fb/lh.
Blocking for further investigation; QA, can we get a confirmation of this?
Flags: blocking-firefox3.6? → blocking-firefox3.6+
Keywords: qawanted
Would be helpful to know which sites reporters are seeing this on specifically - I see mention of webmail as well as other sites but no sites specifically.
The site is irrelevant; anywhere where you do a file upload.  Bugzilla attachment, webmail attachment, flickr photo.
Spent some time trying to reproduce this in the QA lab on the XP machine using FF 3.5.2. Here are some of the things that I did:

1. Installed both Firebug and Live HTTP headers
2. Uploaded file to flickr, bugzilla test installation, gmail, etc.

I had the Firebug netpanel open when I was performing these operations but I was not able to repro. If someone can give me an exact set of STR and a site that it happens on, it would be very helpful.
Marcia,

When uploading my attachment for tb bug #508609, I ran into this issue. As far as I can recall, I did nothing special: I created an empty file on my desktop, gave it a name, clicked "add attachment" in bugzilla, chose the file and clicked "upload". The file was locked until I uploaded another file (at which point, that new file was locked and the old one was released).

I have noticed that it does not happen every single time (which, I know, is very irritating when trying to come up with a fix).

In any case, one need go no further than Mozilla's bugzilla to find a site where this has occurred.
When I experienced this I was on 3.0.x (I don't remember the version). I just installed 3.5.3 and do not see the problem anymore (though some of my add ons still need updated). Here was my steps:
* Using Notepad, create a .sql file (leave notepad open)
* import that .sql file with phpMyAdmin (basically file upload) from a local install to a local database (successful so notepad does not hold locks)
* edit the file in the still open notepad and save (cannot save file is locked)

To clear the lock I had to close all my FF windows.
Assignee: nobody → ddahl
Attempted to reproduce this on Firefox 3.5.3, to no avail.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1.3) Gecko/20090824 Firefox/3.5.3

Installed Firebug - other than Firebug the profile was new, was able to upload and delete file without any problems. Deleting by right-click->delete, right click on recycle bin and empty.

Attempted this several times with and without firebug installed. Just tested with txt files.
also tested on Windows 7 / Fx 3.5.3, cannot reproduce. reporter: Can you reproduce this bug using Firefox 3.5.3?
Not blocking, potentially RESO WFM?
Flags: blocking-firefox3.6+ → blocking-firefox3.6-
Yeah, RESO WFM. Reporter can reopen if it can be reproduced reliably.
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → WORKSFORME
Hi I'm the original reporter. Seems to be fixed for me in 3.5.3.
Resolution: WORKSFORME → FIXED
I can still reproduce this basically all the time on trunk -- same symptoms as original bug, the handle stays open if I upload a file.  Firebug is installed, but all the panels are disabled.  I have:

Firebug 1.5.0
Flashblock 1.5.11.2
Weave 1.0rc2
Tree Style Tab 0.8.2009122501
Stylish 1.0.7

Handle is visible using Process Explorer.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Keywords: qawanted
I can reproduce this bug in safe mode with:

Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.9.2.8) Gecko/20100722 Firefox/3.6.8

I used the file upload at google mail. Sometimes (?) it is sufficient to close the GMail-Tab to release the file.
Added "using the standard upload control" to disambiguate from issues with drag-and-drop upload (e.g. bug 578096)
Summary: File upload keeps file open (perhaps also a file handle leak) → File upload using the standard upload control keeps file open (perhaps also a file handle leak)
Still happens in 3.6.13

I too have firebug installed, but it's not current open (Console: off, Net: off, Script: off. Suspended)
Still happens in 10.0.2 (!) What an epic bug o_O
I am running Firefox on Windows 7 64 bit.

After I upload a file using Firefox's built in upload file dialog the file appears to be locked e.g. If I try to move that file subsequently to a different directory I receive the error message: "The action can't be completed because the file is open in Firefox".
Assignee: ddahl → nobody
Happens to me on Firefox 27.0.1 on Windows 64 bits

I have the following addons: 

Clear Cache	1.4	
Firebug	1.12.7	
FireQuery	1.4.1	
FireShot	0.98.48	
Rainbow	1.6	
Selenium IDE	2.4.0	
Selenium IDE Button	1.2.0	
Selenium IDE: C# Formatters	2.4.0	
Selenium IDE: Java Formatters	2.4.0	
Selenium IDE: Python Formatters	2.4.0	
Selenium IDE: Ruby Formatters	2.4.0	
SQLite Manager	0.8.1	
Tilt	1.0.1	
Web Developer	1.2.5
Still reproducible in Firefox 34.0 safe mode on Windows 7 x64.

Build: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:34.0) Gecko/20100101 Firefox/34.0
Firebug 2.0.7 is installed but not enabled.

Noticed while uploading to YouTube, but happens on other sites I tested as well (imgur, Facebook, flickr).
Just stumbled upon this bug. Manifestation:
-Local file in Windows 8.1 worked fine in gmail upload (remove after upload works, no file handle open)
-Network file (upload file from network share) does not work. I have to close Firefox, and only after closing Firefox I am able to remove the file.

FF 34.05 (vanilla), Windows 8.1
See Also: → 1085140
Also happens uploading PDFs to Google Drive using drag and drop. Last file uploaded remains locked until firefox process is terminated.
Severity: normal → S3
You need to log in before you can comment on or make changes to this bug.