Address book lost on sudden shutdown

RESOLVED DUPLICATE of bug 148169

Status

Thunderbird
Address Book
--
critical
RESOLVED DUPLICATE of bug 148169
9 years ago
8 years ago

People

(Reporter: bugzilla, Unassigned)

Tracking

({dataloss})

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.0.8) Gecko/2009032609 Firefox/3.0.8 (.NET CLR 3.5.30729)
Build Identifier: Version 2.0.0.21 (20090302)

I have my thunderbird stored on a usb stick within a truecrypt partition (including the profile). I forget sometimes(getting less) to plugin the usb stick after hibernation. If now thunderbird crashes it usually destroys the adress book somehow. I couldn't really pin the bug but it happend 4 times in 2 months now. Of course it might happen that one thing or another breaks... but this broke on a constant basis. All other informations( like rss feeds, email accounts, settings, etc. were still available ) were still available! Just the adress book is gone ... completly.

Reproducible: Sometimes

Steps to Reproduce:
1.Use thunderbird profile on a usb stick
2.Save some adresses
3.a Suddenly disconnect the usb stick
3.b Hibernate the computer, remove the usb stick, boot the computer
3.c Let Thunderbird crash
Actual Results:  
Adress book is gone.

Expected Results:  
Adress book should be able to be restored (from former safed data) if really broken for some reason. More preferable is if it never breaks.

Addon's:
 - Adblock Plus
 - Attachment Sizes
 - Enigmail
 - Lightning
 - MinimizeToTray
 - Provider for Exchange 2007 WS
 - withAttach
Can you provide crash ID ? (as explained here : http://kb.mozillazine.org/Talkback)

Does it also happens in safe mode ?
(Reporter)

Comment 2

9 years ago
There is no crash id(if the address book crashes, half the computer crashes with it ...).

I didn't try out safe mode.
(Reporter)

Comment 3

9 years ago
Oh: Next start is normal, just the address book is gone.

Updated

9 years ago
Summary: Adress book lost on sudden shutdown → Address book lost on sudden shutdown

Comment 4

9 years ago
is " I forget sometimes(getting less) to plugin the usb stick after hibernation" a necessary step to cause this?
Keywords: dataloss
(Reporter)

Comment 5

9 years ago
I stated the possible ways which i found to make it happen in the bug report: 
3.a Suddenly disconnect the usb stick
3.b Hibernate the computer, remove the usb stick, boot the computer
3.c Let Thunderbird crash

Comment 6

8 years ago
this sounds like a testcase for bug 148169
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 148169
You need to log in before you can comment on or make changes to this bug.