Closed Bug 486826 Opened 11 years ago Closed 11 years ago

firefox isn't using its overridden netError.dtd

Categories

(Firefox Build System :: General, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: mkmelin, Assigned: johnath)

References

Details

(Keywords: regression, verified1.9.1)

Attachments

(1 file)

Working on bug 483011 in surprisingly notice that firefox isn't actually using it's overridden netError.dtd, anymore! 

Looks like fallout from bug 411037, at least 
http://hg.mozilla.org/releases/mozilla-1.9.1/rev/d049116865bd

Should probably be

% override chrome://global/locale/netError.dtd chrome://browser/locale/netError.dtd

% override chrome://global/locale/netErrorApp.dtd chrome://browser/locale/netError.dtd

At least making that corresponding change worked for my thunderbird patch.

---

STR: 
1) File | Work offline
2) load a page not in cache
3) See the text

Results: not the text from http://mxr.mozilla.org/comm-central/source/mozilla/browser/locales/en-US/chrome/overrides/netError.dtd#55 but from http://mxr.mozilla.org/comm-central/source/mozilla/dom/locales/en-US/chrome/netError.dtd#28
Flags: blocking-firefox3.5?
Summary: firefox isn't using it's overridden netError.dtd → firefox isn't using its overridden netError.dtd
Is this Linux only?
(In reply to comment #1)
> Is this Linux only?

Not according to your screenshot, no.
OS: Linux → All
Hardware: x86 → All
(In reply to comment #0)
> Should probably be
> 
> % override chrome://global/locale/netError.dtd
> chrome://browser/locale/netError.dtd
> 
> % override chrome://global/locale/netErrorApp.dtd
> chrome://browser/locale/netError.dtd
> 
> At least making that corresponding change worked for my thunderbird patch.

This is understandably confusing, but is fall out from Kairo's work in bug 403800.

The override here:

http://mxr.mozilla.org/mozilla-central/source/browser/locales/jar.mn#78

*is* correct, in that it says "replace the global netErrorApp.dtd, a file which contains supplemental strings likely to be replaced by implementors, with our own file - confusingly named netError.dtd instead of netErrorApp.dtd."

Given that firefox's version of netError.dtd contains many of the strings in the global netError.dtd, and given that the inclusion of "netErrorApp.dtd" happens at the bottom of netError.dtd ( http://mxr.mozilla.org/mozilla-central/source/dom/locales/en-US/chrome/netError.dtd#86 ) this has the effect of "redefining" many of the entities.

I've never checked up on what "proper DTD" behaviour is on duplicate entities, but it seems like we're seeing a problem here, and that might well be it.

CC'ng kairo, since this traces back to his patch.
Depends on: 403800
I don't think this blocks, but we'd take a fix.
Assignee: nobody → johnath
Flags: blocking-firefox3.5? → blocking-firefox3.5-
Attached patch Fix the overrideSplinter Review
Magnus, re-reading my comment 4, I realize I was ambiguous.  When I said the override was "correct," I should have said it was "deliberate," in that it was intentional to separate out the "likely to be overridden" strings from the "likely to be just fine" ones.  However, as you've noted, Firefox provides substantially different text for most of the errors.

This one liner patch, as you suggest, replaces our partial override with a complete one.

I think this should land in 1.9.1 - these are the strings we intend to be showing. I'll copy l10n on this bug so that they know it's here, but no strings are changing here in the tree - we're just correctly using the ones in browser/ again.
Attachment #371447 - Flags: review?(gavin.sharp)
Attachment #371447 - Flags: approval1.9.1?
Attachment #371447 - Flags: review?(gavin.sharp) → review+
Landed on mozilla-central 

http://hg.mozilla.org/mozilla-central/rev/6f49c04c3a6c
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
Comment on attachment 371447 [details] [diff] [review]
Fix the override

a191=beltzner
Attachment #371447 - Flags: approval1.9.1? → approval1.9.1+
verified FIXED on builds:


Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.2a1pre) Gecko/20090514 Minefield/3.6a1pre ID:20090514031229

and

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090514 Shiretoko/3.5b5pre ID:20090514031203
Status: RESOLVED → VERIFIED
Component: Build Config → General
Product: Firefox → Firefox Build System
You need to log in before you can comment on or make changes to this bug.