Boolean expressions for spamfiltering with folders for Subfilters..

RESOLVED DUPLICATE of bug 59339

Status

--
enhancement
RESOLVED DUPLICATE of bug 59339
10 years ago
10 years ago

People

(Reporter: michel, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

10 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.0.7) Gecko/2009021910 Firefox/3.0.7 (.NET CLR 3.5.30729)
Build Identifier: Version 2.0.0.21 (20090302).

Moin Moin.
Most Spam sender/recipient-structures are easy to understand but tedious to implement using the current filterexpression system, allowing only to select either(!!!!!!) "and",  "or"  or "none" conditions.
For example a condition like "%sender%==%recipient%" or "substring(%sender%,a,b)==substring(%recipient%,c,d)" with a to d being some numerical expressions would enrich the algebraic structur of the filter and, currently, filter out most of my otherwise unrecognisable spoam.
_Tschuess,
__Michael.

Reproducible: Always

Steps to Reproduce:
1.Edit a Spam filter.
2.
3.
Actual Results:  
Exclusive, single predicate boolean expression-chain.

Expected Results:  
The current design, plus an option to programme the boolean expression in a c++/vb/mathematica/whatever like syntax.
(Reporter)

Comment 1

10 years ago
How about allowing to create folders within the rules and to search within the expressions of a rule to allow to find a rule that matched a tagged email without having a close look at most of the active rules.
(Reporter)

Comment 2

10 years ago
How about storing the actual options (like whether a user selected "from " and " begins with") in a static variable or at least reproducing the last selection.
Right now any new entry switches its " begins with" option back to " contains".
(Reporter)

Comment 3

10 years ago
One more thing.
How a bout to allow for using already set tags meaning to rely on the results of already applied filters.
(In reply to comment #0)
> Most Spam sender/recipient-structures are easy to understand but tedious to
> implement using the current filterexpression system, allowing only to select
> either(!!!!!!) "and",  "or"  or "none" conditions.
> For example a condition like "%sender%==%recipient%" or
> "substring(%sender%,a,b)==substring(%recipient%,c,d)" with a to d being some
> numerical expressions would enrich the algebraic structur of the filter and,
> currently, filter out most of my otherwise unrecognisable spoam.

Bug 59339 or bug 297852 should satisfy your requests here.

(In reply to comment #1)
> How about allowing to create folders within the rules and to search within the
> expressions of a rule to allow to find a rule that matched a tagged email
> without having a close look at most of the active rules.

Bug 60764?

(In reply to comment #2)
> How about storing the actual options (like whether a user selected "from " and
> " begins with") in a static variable or at least reproducing the last
> selection.
> Right now any new entry switches its " begins with" option back to " contains".

Hmm, I don't think we have a bug on this, but it's a very minor UX thing.

(In reply to comment #3)
> One more thing.
> How a bout to allow for using already set tags meaning to rely on the results
> of already applied filters.

If you're adding tags via, you could add a custom header to filter on the keywords or label header, as appropriate. I think this can also catch junk status as well.

Oh, and how about having only a single bug or RFE per bug report?
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 59339
You need to log in before you can comment on or make changes to this bug.