Last Comment Bug 48820 - Make personal toolbar folder default to root bookmark folder ("bookmarks toolbar")
: Make personal toolbar folder default to root bookmark folder ("bookmarks tool...
Status: RESOLVED WONTFIX
: helpwanted
Product: SeaMonkey
Classification: Client Software
Component: Bookmarks & History (show other bugs)
: Trunk
: All All
: P3 enhancement with 1 vote (vote)
: ---
Assigned To: Ben Goodger (use ben at mozilla dot org for email)
: Claudius Gayle
:
Mentors:
Depends on: 36339
Blocks: 157199
  Show dependency treegraph
 
Reported: 2000-08-13 04:30 PDT by Matthew Paul Thomas
Modified: 2004-11-22 17:25 PST (History)
12 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
my netscape with bookmarks root as "personal bookmarks folder" (66.23 KB, image/png)
2002-04-30 03:42 PDT, Igor Velkov
no flags Details

Description Matthew Paul Thomas 2000-08-13 04:30:35 PDT
From discussions in n.p.m.ui, Mozillazine, and my last comment in bug 39332:

It might be a good idea to abolish the `Personal Toolbar Folder' in Bookmarks, 
and turn the Personal Toolbar into a `Bookmarks Toolbar' which shows the first 
few bookmarks/folders (however many fit in the toolbar) from the bookmarks list.

In effect, this would be equivalent to making the root bookmarks folder the same 
as the Personal Toolbar folder.

This change would achieve the following.

1.  It would make the origin (and means of customization) of the toolbar more
    obvious.

2.  It would remove confusion about the purpose of the Personal Toolbar folder in
    the bookmarks list.

3.  It would help prevent the problem that users need to insert commonly-used
    bookmarks twice -- once in the Personal Toolbar folder, and once in its
    `logical' position (e.g. in the same folder as other bookmarks on the same
    topic).

4.  By implicitly encouraging users to put their most-used bookmarks and bookmark
    folders at the beginning of their bookmarks list, it would serve to improve
    users' bookmark organization, and therefore make their bookmark access
    quicker overall.
Comment 1 Henri Sivonen (:hsivonen) (Not reading bugmail or doing reviews until 2016-10-03) 2000-08-13 14:18:56 PDT
How is point 3 going to be accomplished if the first bookmarks on the list get displayed in 
the bookmark bar, but the topic group for the bookmark at the top of the list?

Is the really confusion as suggested in point 2?

I am not against the suggestion--just asking.
Comment 2 Barney Barumba 2000-08-14 03:15:35 PDT
IMHO, you want to achieve two things:

1. Make it simple and intuitive for people who run it 'straight from the box'.

2. Allow people to configure it as they wish.

To this end, what is wrong with keeping the N4.x concepts of:

  1. Set as Toolbar Folder
  2. Set as Bookmark Menu
  3. Set as New Bookmarks Folder

Maybe combine 2 & 3.

If you set (default) these to the root then you have the simple 'bookmarks is
personal toolbar' approach, but it also allows customisation if you desire
something different.

It seems to me there are two types of bookmarks: permanent and temporary. By
permanent I mean (what I think is) the generally accepted concept of frequently
revisited sites. But in a browsing session I may come across a some pages which
I wish to look at later, but only once, and which will never make it on to my
'permanent' list. By forcing me to put these in the same place as my permanent
bookmarks you are actually making it harder for me to manage them, as when I
come to remove the temporary ones I have to check which ones they are.

As far as the confusion issue goes, I am of the view that as long as the default
setup is simple: 'if you don't understand it then don't fiddle with it'. I
entirely appreciate that not everyone wants to spend time configuring things and
would like to be able to install and run as is, but I don't feel that those of
us who do should be forced to a lowest common denominator of functionality.

Just my 2c worth.
Comment 3 leger 2000-08-25 08:00:09 PDT
Reassigning from bdonohoe to hangas
Comment 4 Jesse Ruderman 2000-11-30 10:09:54 PST
I use my personal toolbar for bookmarklets, and forcing those bookmarklets to 
also be at the top of my bookmarks menu would make it *more difficult* to 
organize my bookmarks into categories and have the list of categories fit on 
one screen.  I like barney.b@iname.com's idea of letting the user specify which 
folder has the personal toolbar bookmarks, though.
Comment 5 Andrew Thompson 2000-11-30 19:09:24 PST
Hmm, not sure I unerstand how this is more difficult.

Presently, presumably, the first 6-8 (depending on your screen size) items in 
your personal toolbar folder fit in your personal toolbar. (be they themselves 
folders or single items).

After this change, the first 6-8 items in your bookmarks would fit. Since new 
bookmarks default to the end of the list, what's the difference?

Did I miss something... curious...?
Comment 6 Jesse Ruderman 2000-12-01 01:02:56 PST
At 800x600, the personal toolbar holds about 8 bookmarks, and the bookmarks 
menu shows about 23 bookmarks without scrolling.  If the personal toolbar 
folder and the root bookmarks folder are the same, I can only have reasonably 
fast access to 23 items instead of 31, which would give me more excuses for not 
keeping my bookmarks organized well.

Also, I use the personal toolbar and bookmarks menu for different purposes.  
Items on my personal toolbar are tools to do things with the current page (show 
http source) or to do things with information on the current page (open a new 
window with the links on the current page containing a specified word, open a 
calculator window).  Items in my bookmarks folder are sites that I want to be 
able to find later (by searching or by using a hierarchy of menus) or sites 
that I want to remember to look at later.
Comment 7 Andrew Thompson 2000-12-01 17:20:53 PST
Yes. I understand. Very reasonable.

Hopefully a helpful suggestion though - you know you can put folders on the 
personal toolbar? Presumably the 8 bookmarks you'd lose could go in a folder in 
your personal toolbar, at the end, after the caclulator etc. Dunno. Might work 
for you, might not.

Ultimately this decision is all about balance - I think there's a broad feeling 
that the current setup is confusing. If we can give novices a better experience 
and power users like ourselves can still get (nearly) equivalent functionality 
then I think simpler is better. 

One for Netscape's User Testing Lab ?
Comment 8 Jesse Ruderman 2000-12-02 12:40:46 PST
It seems to me that it would be easier for a user to figure out that the links 
at the top of the window correspond to the bookmarks in the "personal toolbar" 
folder than it would be to figure out that they can make the personal 
toolbar /not/ be the as the root bookmarks folder.
Comment 9 Zach Lipton [:zach] 2001-02-27 19:22:51 PST
Chaning the qa contact on these bugs to me. MPT will be moving to the 
owner of this component shortly. I would like to thank him for all his hard 
work as he moves roles in mozilla.org...Yada, Yada, Yada...
Comment 10 Asa Dotzler [:asa] 2001-03-08 20:16:47 PST
updating to new owner. sorry for the spam.
Comment 11 Ian Pottinger 2002-01-14 18:32:40 PST
I think this is a prime example of a great feature hiding behind complexity.  It
took my quite a while to realize that the "Personal Toolbar" was customizible
and I *still* find myself pointing out this feature to experienced users of
mozilla browser including 4.x users.

Whatever hiarchy existed above or beside the "Personal Toolbar Folder" can still
exsist in appropriately name folders within it.
Comment 12 Ian Pottinger 2002-04-03 22:24:19 PST
adding self to cc list
Comment 13 Igor Velkov 2002-04-30 03:42:53 PDT
Created attachment 81652 [details]
my netscape with bookmarks root as "personal bookmarks folder"

Yes, its great feature. I use it more 3 years in Netscape Communicator 4.x. Its

very, very sutable. look to the illustration
Comment 14 Jonas Jørgensen 2002-09-19 01:21:50 PDT
.
Comment 15 John Morrison 2002-09-19 14:38:54 PDT
Alrighty, then...

.
Comment 16 Jonas Jørgensen 2002-09-20 06:47:59 PDT
jrgm: How about only renaming the PT to "Bookmarks Toolbar", or only making the
default PT folder be the bookmarks root, or both of those two, _without_
removing the menu command to change the PT folder? Is that WONTFIX too?
Comment 17 Esben Mose Hansen 2002-09-24 10:15:03 PDT
If this bug is marked WONTFIX, a *reason* needs to given. If a reason doesn't
turn up real soon, I'll reopen this.

This is just the kind if incident that create code forks. Bugs should NEVER be
closed without a reason. 
Comment 18 timeless 2002-09-24 10:42:35 PDT
comment 6
Comment 19 timeless 2002-09-24 12:57:00 PDT
the ability to set the bookmarks root as the personal toolbar folder is not what
was wontfixed. the fact is that there is no bookmark root atm, the next
bookmarks landing will create a root again, and if there's a folder, then it
/can/ be the personal toolbar folder (ignoring a bug reported to phoenix which
has the landing complaining that the IE folder can't be).
Comment 20 Jason Bassford 2002-09-26 08:08:01 PDT
> the ability to set the bookmarks root as the personal toolbar folder
> is not what was wontfixed. the fact is that there is no bookmark root atm

Which is why you would mark it future or create a dependency on an existing bug
for having a bookmark root - as was done just recently with bug 36339...

If that is the ONLY reason for marking this WONTFIX it's not valid.  I'll go
ahead an reopen it myself.  Any future WONTFIX needs to have a valid reason.
Comment 21 Jason Bassford 2002-09-26 08:20:56 PDT
R.e. comment 6 - that's not sufficient.

a) They are not necessarily mutually exclusive (we need not abolish the Personal
Toolbar as per comment 0 but rather only have the opion of having it use
bookmark root if so desired).

b) This bug could be morphed to simply add a Bookmarks Toolbar which is
(partly/mostly) the point of this bug and which would make everybody happy.

c) The concept of the "Personal" toolbar could be expanded so that you could put
whatever you wanted on it, avoiding confusion between functions.  Of course,
that falls into customization...

In any case, there are ways of accomodating this bug and also getting around the
argument against it in comment 6.
Comment 22 timeless 2002-09-26 10:03:21 PDT
look, if you guys keep morphing the bugs then it will be impossible to keep a
bug wontfix. this bug is polluted and useless (nobody).

The summary someone else picked just doesn't match the original request. I'm
resolving Comment 0 as WontFix based on Comment 6. If you want *ANYTHING* ELSE
then file a new bug. I'll make sure it isn't resovled as a duplicate of this
bug. Just leave this bug alone.

DO NOT MORPH BUGS.
Comment 23 Jason Bassford 2002-09-26 10:23:42 PDT
Opened bug 170994.
Comment 24 Jesse Ruderman 2002-12-26 21:34:14 PST
Making it possible to set the root of bookmarks as the personal toolbar folder
is part of bug 36339.  This bug is about making the personal toolbar folder
*default* to the root of bookmarks, in order to aid discoverability.

Note You need to log in before you can comment on or make changes to this bug.