Play a sound when Download Completes (again)

RESOLVED FIXED

Status

SeaMonkey
Download & File Handling
RESOLVED FIXED
9 years ago
9 years ago

People

(Reporter: Callek, Assigned: neil@parkwaycc.co.uk)

Tracking

({fixed-seamonkey2.0})

Trunk
fixed-seamonkey2.0
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 2 obsolete attachments)

(Reporter)

Description

9 years ago
Created attachment 374907 [details] [diff] [review]
WIP 1

This is a very basic implementation (and still a WIP) of playing sounds when a download completes....

(formatting slightly funky as I just had to hand-edit a diff due to including part of the bits meant for here in another patch)
(Assignee)

Comment 1

9 years ago
You'd want to check the play sound pref every time you download for a start.

Updated

9 years ago
Duplicate of this bug: 280439

Updated

9 years ago
Blocks: 519332
(Assignee)

Comment 3

9 years ago
Created attachment 403863 [details] [diff] [review]
Proposed patch

Since we can't reasonably expect Callek to finish the patch soon...

* Removed comment markers in pref-downloads.js
* Add code to disable sound controls on startup
* Uncommented elements in pref-downloads.xul (sadly not as easy as .js)
* Add code to nsSuiteGlue.js to actually play the sound
  (very loosely based on Callek's patch)
Assignee: bugspam.Callek → neil
Attachment #374907 - Attachment is obsolete: true
Status: NEW → ASSIGNED
Attachment #403863 - Flags: review?(iann_bugzilla)

Comment 4

9 years ago
Comment on attachment 403863 [details] [diff] [review]
Proposed patch

You have a clash of accesskeys "a" is used in two places. You could change "Play a sound" to "P" and then have "Show an alert" as "S"
Attachment #403863 - Flags: review?(iann_bugzilla) → review-
(Assignee)

Comment 5

9 years ago
Created attachment 403905 [details] [diff] [review]
With locale changes
Attachment #403863 - Attachment is obsolete: true
Attachment #403905 - Flags: review?(iann_bugzilla)

Updated

9 years ago
Attachment #403905 - Flags: review?(iann_bugzilla)
Attachment #403905 - Flags: review+
Attachment #403905 - Flags: approval-seamonkey2.0+
(Assignee)

Comment 6

9 years ago
Pushed changeset 16d24cd30915 to comm-central.
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago
Keywords: fixed-seamonkey2.0
Resolution: --- → FIXED

Updated

9 years ago
Blocks: 423281
You need to log in before you can comment on or make changes to this bug.