Closed Bug 492964 Opened 13 years ago Closed 13 years ago

Get New Messages for <selected account> is trying to get messages for all the accounts when using global inbox

Categories

(Thunderbird :: General, defect)

defect
Not set
normal

Tracking

(Not tracked)

VERIFIED FIXED
Thunderbird 3.0b3

People

(Reporter: wladow, Assigned: mkmelin)

References

Details

(Keywords: regression)

Attachments

(1 file)

Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1b5pre) Gecko/20090514 Shredder/3.0b3pre

1. Use the toolbar button for getting new messages or choose File -> Get New Messages for
2. Select one of your accounts
3. Watch the status bar - Shredder is checking all your accounts for new messages instead of just the selected one

-> regression
If you select the account after having asked to fetch email - the default is to check all email accounts.

> -> regression

When did it regress ?
(In reply to comment #1)
> If you select the account after having asked to fetch email - the default is to
> check all email accounts.
Sure, but I'm talking strictly about a single account. Maybe the first step isn't that clear - by "use the toolbar button" I meant to open its dropdown menu so you can choose an account 

> > -> regression
> 
> When did it regress ?
Sorry, too busy right now to look for a regression range, but it regressed lately for sure. Beta 2 works as expected as well.
I don't seem to be able to reproduce this using:
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9.1b5pre) Gecko/20090514 Lightning/1.0pre Shredder/3.0b3pre ID:20090514031430

Winxp sp3
Vlado Valastiak, is there any error message which relates to the problem at Error Console?
Bug 296655 had to re-factor code for the getting mail for account part, so maybe I messed up something there...
(In reply to comment #4)
> Vlado Valastiak, is there any error message which relates to the problem at
> Error Console?
Nope

(In reply to comment #5)
> Bug 296655 had to re-factor code for the getting mail for account part, so
> maybe I messed up something there...
Yeah, it seems so.

Regression window:
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b5pre) Gecko/20090509 Shredder/3.0b3pre build 20090509031542
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b5pre) Gecko/20090510 Shredder/3.0b3pre build 20090510031449

and that's the time slot when bug 296655 landed
Sorry, can't reproduce this using
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9.1b5pre) Gecko/20090514 Lightning/1.0pre Shredder/3.0b3pre

Have you made sure all extensions are disabled?

If that's not the problem, do you have more backgroud info to reproduce?
It's strange that no one is able to reproduce this. The only ext I have is DOMi and it's disabled for now. I can see this bug with -safe-mode too.

I noticed this is related to POP3 accounts. I've got 2 IMAP accounts, 5 POP3 accounts, newsgroup and feeds accounts as well. This is happening only if I want to check a POP3 account - if I click on one of those five, Shredder will check all of them.
Or in other words it doesn't need to be necessarily related to POP3, but to Local Folders - all my POP3s are using global Inbox while the other accounts have their own folders.
Ah, global inbox is the key!
Assignee: nobody → mkmelin+mozilla
Blocks: 296655
Status: NEW → ASSIGNED
Flags: blocking-thunderbird3+
OS: Windows Vista → All
Hardware: x86 → All
Summary: Get New Messages for <selected account> is trying to get messages for all the accounts → Get New Messages for <selected account> is trying to get messages for all the accounts when using global inbox
Target Milestone: --- → Thunderbird 3.0b3
Attached patch proposed fixSplinter Review
Moved the GetNewMessagesInFolders functionality into mailWindowOverlay.js as it was only ever called from there.

The basic problem was that where GetNewMessagesInFolders([inboxFolder]); was called it needed the server to be another server than inboxFolder.server
Attachment #377848 - Flags: review?(philringnalda)
Attachment #377848 - Flags: review?(philringnalda) → review+
changeset:   2661:0f818e54a43b
http://hg.mozilla.org/comm-central/rev/0f818e54a43b

->FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
Verified with Mozilla/5.0 (Windows; U; Windows NT 6.0; sk; rv:1.9.1pre) Gecko/20090521 Shredder/3.0b3pre

Thanks for the fix.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.