add an error console message when we encounter an unsupported codec

RESOLVED DUPLICATE of bug 1188676

Status

()

RESOLVED DUPLICATE of bug 1188676
10 years ago
3 years ago

People

(Reporter: blizzard, Unassigned)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

10 years ago
Related to bug #494035.  Would be nice to have an error message in the error console when we encounter a codec we don't know about.  Would help with debugging quite a bit.
Boriss and I talked some about having the error UI show a bit more information, see some notes in bug 481040 (before we scaled it back for 1.9.1). Maybe we should look again at having more detailed error messages for 1.9.2...

Comment 2

7 years ago
I just get a spinner on
http://www.marketwatch.com/video/asset/mozilla-ceo-on-h-p-shakeup-and-privacy-issues-2011-09-22/FF1370FD-3C64-4450-9B95-83226F8DE195#!FF1370FD-3C64-4450-9B95-83226F8DE195

In addition to showing an error message, we could offer to display the video using a helper app or plugin.  I was able to watch this video by selecting "Save Video As..." from the context menu and opening the file in VLC.
Depends on: 708150

Updated

7 years ago
OS: Mac OS X → All

Comment 3

5 years ago
The error console now shows the unsupported codec:

HTTP "Content-Type" of "audio/aacp" is not supported. Load of media resource http://173.193.20.157:7050/; failed.

The frustrating part is that message is only in the console. The only thing the front end gets through the onerror is 4 (unsupported format) so nothing sensible can be shown to the user.

Is there any way to get more information when the error happens?
Bug 513405 made the (default) controls say "Video format or MIME type is not supported." (among other things). Is that not happening here?

Comment 5

5 years ago
Created attachment 809890 [details]
audio.html

No, the audio player simply disappears.

This example is flawed because the format is AAC, but it still shows the problem.

When you click on AAC, the load fails and the player disappears. Click on MP3, it comes back.

Comment 6

5 years ago
(In reply to Justin Dolske [:Dolske] from comment #4)
> Bug 513405 made the (default) controls say "Video format or MIME type is not
> supported." (among other things). Is that not happening here?

Maybe the difference here is audio versus video?
Hmm, could be, I think for <audio> we only show the controlBar, and not the statusOverlay. Though I don't see offhand how we do that, so maybe I'm imaging that.
Component: Audio/Video → Audio/Video: Playback
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WONTFIX
Duplicate of this bug: 566796

Comment 9

3 years ago
Why was this WONTFIXed?
Please see comment #9.
Flags: needinfo?(ajones)
You are right. This was wontfixed in error. We need to report more useful errors to the console.
Flags: needinfo?(ajones)
Resolution: WONTFIX → DUPLICATE
Duplicate of bug: 1188676
You need to log in before you can comment on or make changes to this bug.