{perf} Big files make layout really buggy and slow.

VERIFIED DUPLICATE of bug 6048

Status

()

P3
normal
VERIFIED DUPLICATE of bug 6048
20 years ago
19 years ago

People

(Reporter: magnus, Assigned: buster)

Tracking

Trunk
x86
Windows 98
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [Perf], URL)

(Reporter)

Description

20 years ago
I was trying out viewer and apprunner at my c64 music page
( http://sid.genline.nu ) is has an very large indexfile.
The layout engine shows nasty graphicsbugs. I don't know why.
The rendering takes like 30seconds+ on my dual pII 400mhz which is s l o w.

Updated

20 years ago

Comment 1

20 years ago
It's not too surprising, because we haven't yet optimized for really large files
and this file is 880K.

Kipp, there are two problems. The first is a known problem, that we don't flush
the content sink until the outer-most UL (of which all the remaining content is
nested) is complete. That means nothing displays until the entire document has
loaded.

Once that problem is fixed, we can visit the second problem, which is that it
scrolls very very slowly.

Updated

20 years ago
Severity: major → normal
Status: NEW → ASSIGNED
Target Milestone: M6
Summary: Big files makes layout rally buggy and slow. → {perf} Big files make layout really buggy and slow.

Comment 2

20 years ago
*** Bug 6513 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Summary: {perf} Big files make layout really buggy and slow. → Big files make layout really buggy and slow.
Whiteboard: [Perf]

Comment 3

20 years ago
*** Bug 8160 has been marked as a duplicate of this bug. ***

Updated

20 years ago
Blocks: 8691

Updated

20 years ago
Severity: normal → major
Priority: P3 → P5
Summary: Big files make layout really buggy and slow. → {perf} Big files make layout really buggy and slow.

Updated

20 years ago
Severity: major → normal

Comment 4

20 years ago
Just verifying that this page still loads very slow and also scrolls very slow.
I am using a PentiumPro 200 with 64MB RAM running Win98 and i used the
latest NECKO build 1999080508...and it took 50+ seconds to load.
(Reporter)

Comment 5

19 years ago
Well the gfx bugs are sure gone (has been 4 a while now).
I'm using build 1999091310.
The scrolling is much faster, but resize is still too slow.
Another bug i found out with this page is that the progressbar is "done" after
the html file (http://sid.genline.nu/index.html) containing the
frameset (<1Kb) is loaded, but the frame that contains the most data is still
loading.... Should i file a new bug on this one???

Updated

19 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → DUPLICATE

Comment 6

19 years ago
I only need one open bug for the large file reflow speed issue; please do file a
bug against the browser group about the progressbar issue. Thanks.



*** This bug has been marked as a duplicate of 6048 ***

Updated

19 years ago
Status: RESOLVED → VERIFIED

Comment 7

19 years ago
Marking as verified duplicate of 6048.

Updated

19 years ago
Target Milestone: M17 → M10
You need to log in before you can comment on or make changes to this bug.