Closed Bug 49614 Opened 20 years ago Closed 19 years ago

Mozilla doesn't line-break tooltips

Categories

(Core :: Layout, defect, P3)

defect

Tracking

()

VERIFIED DUPLICATE of bug 67127
Future

People

(Reporter: liquidx, Assigned: vishy)

References

()

Details

(Keywords: helpwanted, Whiteboard: [xul1.0-layout-popups])

Attachments

(1 file)

If you put your mouse over the links on the middle section of the page, there
are comments which are displayed as tooltips in the mozilla rendering process.

Problem 1 : Mozilla does not recognise the 'escape codes' for the line breaks in
the contents of the TITLE parameter of the <a> tag.

Problem 2 : Because of Problem 1, the tooltip is relegated to the top of the
screen and you can only read the length of the screen worth of tooltip.
related: bug 42764, "Long URLs on personal toolbar yield huge tooltips".
massive update for QA contact.
QA Contact: petersen → lorca
Is this a dup of bug 48134 ?
tooltip problem.  assigning to trudelle
Assignee: clayton → trudelle
confirmed on WinNT build id 2000100608
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Linux → All
Hardware: PC → All
Status: NEW → ASSIGNED
Target Milestone: --- → Future
I'm not seeing the problem using the 100708 branch verification build on Win98.
 Based on the description though, this doesn't seem to fit the profile for rtm
bugs.  ->future.
Bug #57599 is about problem 2.
->pinkerton, possible dup?
Assignee: trudelle → pinkerton
Status: ASSIGNED → NEW
--> xpapps who owns the look/feel of the tooltips
Assignee: pinkerton → vishy
I recommend handling this such that all leading and trailing white space is
removed, and all internal white space is collapsed to a single space character.
The display of an A title should fill a box that has a reasonable width based on
the user agent, maybe a third of the screen width. I highly recommend against
allowing authors to format these titles with white space and line breaks, since
one common use for these is for audable user agents to speak the title text for
blind surfers, as according to the W3C accessability guidelines.
Reassigning QA Contact for all open and unverified bugs previously under Lorca's
care to Gerardo as per phone conversation this morning.
QA Contact: lorca → gerardok
qa contact updated.
QA Contact: gerardok → bsharma
SPAM. HTML Element component deprecated, changing component to Layout. See bug
88132 for details.
Component: HTML Element → Layout

*** This bug has been marked as a duplicate of 67127 ***
Blocks: 42764, 83268
Status: NEW → RESOLVED
Closed: 19 years ago
QA Contact: bsharma → tpreston
Resolution: --- → DUPLICATE
Summary: <a> tag's TITLE parameter exceeeding screen length → Mozilla doesn't line-break tooltips
Whiteboard: [xul1.0-layout-popups]
Verified Duplicate
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.