wordpress image upload broken in 3.5b99

VERIFIED FIXED in mozilla1.9.2a1

Status

()

Core
JavaScript Engine
--
major
VERIFIED FIXED
9 years ago
9 years ago

People

(Reporter: thamood, Unassigned)

Tracking

({regression, verified1.9.1})

Trunk
mozilla1.9.2a1
regression, verified1.9.1
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9.1 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fixed by bug 496790])

(Reporter)

Description

9 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.1b99) Gecko/20090605 Firefox/3.5b99

i just updated to the latest 3.5 preview and whenever i want to upload a picture using the upload tool instead of getting the frame in the middle of the screen like always i go to a direct link!!!

Reproducible: Always

Steps to Reproduce:
1.open any Wordpress passed blog
2.create a new post
3.try to upload a picture!!


Expected Results:  
a frame should appear instead of redirecting me to a page
(Reporter)

Updated

9 years ago
Flags: blocking-firefox3.5?

Comment 1

9 years ago
I'm pretty sure this is because we broke their JS library. Should be fixed on trunk.
--> Core::JS

Whimboo, Blizz: can you confirm and see if it's indeed fixed on trunk?

Rob: will the suspected fix for this be merging to 1.9.1?
Assignee: nobody → general
Component: General → JavaScript Engine
Flags: blocking-firefox3.5?
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → 1.9.1 Branch
Flags: blocking1.9.1?
No, the redirection still happens with Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090609 Minefield/3.6a1pre ID:20090609031152
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows Vista → All
Hardware: x86 → All
Version: 1.9.1 Branch → Trunk
Keywords: regression, regressionwindow-wanted
It regressed between b4 and today. I'll bisect and find the regression range.
Ok the latest tracemonkey build fixed this problem: Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.2a1pre) Gecko/20090609 Minefield/3.6a1pre ID:20090609031128
Probably fixed by bug #496790.
OS: All → Windows Vista
Hardware: All → x86
Version: Trunk → 1.9.1 Branch
Depends on: 496790
OS: Windows Vista → All
Hardware: x86 → All
Whiteboard: [fixed by bug 496790]
Version: 1.9.1 Branch → Trunk
Regressed when the patch on bug 494235 was checked in. Adding bug to dependency list.

Given the status of bug 496790 it should be already fixed on trunk. I'll check it with my debug build when it is ready.
Blocks: 494235
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Keywords: regressionwindow-wanted
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1

Updated

9 years ago
Flags: blocking1.9.1? → blocking1.9.1+

Updated

9 years ago
Duplicate of this bug: 497142
Verified: I could reproduce this bug before, but I thought I broke my Fx profile. The problem is fixed for me, on today's nightly and Wordpress 2.7.1.
Status: RESOLVED → VERIFIED
Frederic, you tested on all platforms? If not I can also verify that it is fixed on Windows, Linux, and OS X.
I am sorry, I only verified on OS X. Thanks for pointing that out, Henrik.

Updated

9 years ago
Summary: wordpress iframes → wordpress image upload broken in 3.5b99

Updated

9 years ago
Duplicate of this bug: 497312

Updated

9 years ago
Keywords: fixed1.9.1
Verified fixed on 1.9.1 with builds on all platforms like Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.1pre) Gecko/20090614 Shiretoko/3.5pre ID:20090614030748
Keywords: fixed1.9.1 → verified1.9.1
You need to log in before you can comment on or make changes to this bug.