If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

mochitest-browser-chrome: browser_394759.js intermittent "textbox is null" failure and timeout

VERIFIED FIXED in Firefox 3.7a3

Status

()

Firefox
Session Restore
--
major
VERIFIED FIXED
8 years ago
5 years ago

People

(Reporter: ted, Assigned: mak)

Tracking

({intermittent-failure})

Trunk
Firefox 3.7a3
x86
Windows XP
intermittent-failure
Points:
---
Dependency tree / graph
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(status1.9.2 beta1-fixed)

Details

(Whiteboard: [test which aborts the suite] )

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
I haven't looked to see if this has been happening more in the past, but it just happened now:
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1245066605.1245073662.3293.gz
WINNT 5.2 mozilla-central unit test on 2009/06/15 04:50:05  

Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js...
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
I think I saw this once locally as well (but couldn't reproduce). I'm touching this test file in bug 493823, so maybe when that gets checked in this will go away. I don't expect it too since that bug is just making sure another test gets run, but one can hope.
WINNT 5.2 mozilla-1.9.1 unit test on 2009/06/22 21:57:53
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1245733073.1245739263.15876.gz&fulltext=1

Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js...
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
WINNT 5.2 mozilla-central test everythingelse
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1246885635.1246888334.13786.gz&fulltext=1

Updated

8 years ago
Whiteboard: [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1247643762.1247650331.9597.gz&fulltext=1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1248353844.1248361667.16751.gz
WINNT 5.2 mozilla-central unit test on 2009/07/23 05:57:24  

Slightly different, though:

Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js...
TEST-INFO | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Console message: [JavaScript Error: "textbox is null" {file: "chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js" line: 70}]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js...
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js | sessionstore.js was removed

command timed out: 1200 seconds without output
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249035599.1249038654.16546.gz#err0

> Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js...
> TEST-INFO | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Console message: [JavaScript Error: "textbox is null" {file: "chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js" line: 70}]
> TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
> Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js...
> TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js | sessionstore.js was removed
> 
> command timed out: 1200 seconds without output
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249206898.1249216159.11903.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249267855.1249274778.12256.gz#err2
(In reply to comment #6)
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249035599.1249038654.16546.gz#err0
> 
> > TEST-INFO | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Console message: [JavaScript Error: "textbox is null" {file: "chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js" line: 70}]

I just got this after loading about:config in a fresh profile:

SessionStore: TypeError: aBrowser.contentDocument.getElementById("textbox") is null
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249357806.1249360452.32582.gz
Duplicate of this bug: 508475
Since we're tracking both the timeout & the failure here, updating the summary so it's more obvious when searching the [orange] list.
Summary: browser_394759.js intermittent timeout → browser_394759.js intermittent timeout / failure

Comment 13

8 years ago
looks like another hang:

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1249924176.1249927243.28893.gz&fulltext=1
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1249945547.1249953894.30668.gz
WINNT 5.2 mozilla-central unit test on 2009/08/10 16:05:47
Here's one on 3.5

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1250086852.1250095393.31156.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250169138.1250176973.18739.gz
WINNT 5.2 mozilla-central unit test on 2009/08/13 06:12:18  
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
buildbot.slave.commands.TimeoutError: command timed out: 1200 seconds without output
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1250611997.1250622976.28774.gz
WINNT 5.2 mozilla-central unit test on 2009/08/18 09:13:17
(Reporter)

Comment 18

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1250879936.1250883081.30238.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/08/21 11:38:56  

Log:
Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js...
TEST-INFO | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Console message: [JavaScript Error: "textbox is null" {file: "chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js" line: 70}]
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
Running chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js...
TEST-PASS | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js | sessionstore.js was removed

Looks the same as comment 6, I guess. Does this give anyone any hints as to where this might be failing?
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251046985.1251049904.27868.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/08/23 10:03:05
Severity: normal → major
Summary: browser_394759.js intermittent timeout / failure → mochitest-browser-chrome: browser_394759.js intermittent "textbox is null" failure and timeout
Whiteboard: [orange] → [test which aborts the suite] [orange]
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251388823.1251397505.5745.gz
WINNT 5.2 mozilla-central unit test on 2009/08/27 09:00:23
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5/1251649318.1251657565.7093.gz
WINNT 5.2 mozilla-1.9.1 unit test on 2009/08/30 09:21:58
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5-Unittest/1251644058.1251646611.10403.gz
WINNT 5.2 mozilla-1.9.1 test everythingelse on 2009/08/30 07:54:18
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251666650.1251677515.28036.gz
WINNT 5.2 mozilla-central unit test on 2009/08/30 14:10:50
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1251740345.1251747118.27506.gz
WINNT 5.2 mozilla-1.9.2 unit test on 2009/08/31 10:39:05
(Assignee)

Comment 25

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1251835168.1251837959.10362.gz
WINNT 5.2 mozilla-central test everythingelse on 2009/09/01 12:59:28
Linux mozilla-central unit test on 2009/09/02 10:31:36
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1251912696.1251922800.16594.gz
Maybe not precisely this bug; not a "textbox is null failure", but still a timeout on this test.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1252363869.1252374134.28774.gz#err0
WINNT 5.2 mozilla-central unit test on 2009/09/07 15:51:09
WINNT 5.2 mozilla-central test everythingelse [testfailed] Started 15:50, finished 16:46
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1252623052.1252626335.13305.gz&fulltext=1
(Assignee)

Comment 29

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1252901103.1252910606.15957.gz#err0
WINNT 5.2 mozilla-central unit test on 2009/09/13 21:05:03
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1252953712.1252964598.20846.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1252971546.1252980867.25107.gz

Comment 32

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1253192872.1253202846.27105.gz
WINNT 5.2 mozilla-central unit test on 2009/09/17 06:07:52
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253579268.1253582417.23777.gz
WINNT 5.2 mozilla-1.9.2 test everythingelse on 2009/09/21 17:27:48
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253738557.1253741690.21286.gz
WINNT 5.2 mozilla-1.9.2 test everythingelse on 2009/09/23 13:42:37
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6-Unittest/1253968892.1253971675.31354.gz
WINNT 5.2 mozilla-1.9.2 test everythingelse on 2009/09/26 05:41:32
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254377506.1254380554.24425.gz#err2
WINNT 5.2 mozilla-central test opt everythingelse on 2009/09/30 23:11:46
Duplicate of this bug: 520087
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254604259.1254607095.2327.gz
WINNT 5.2 mozilla-central test opt everythingelse on 2009/10/03 14:10:59
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254926464.1254929321.11328.gz#err0
Also http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254920635.1254923280.7499.gz#err0 and http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254919124.1254921964.23822.gz
and also http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254916233.1254919403.24006.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1254932425.1254935789.21331.gz

This seems to be very frequent... Zpao, can you look at either fixing this, disabling the test, or bouncing to someone else to own?
Assignee: nobody → paul
(Assignee)

Comment 43

8 years ago
Looks like i could have a fix. give me a minute
(Assignee)

Comment 44

8 years ago
Created attachment 405180 [details] [diff] [review]
patch v1.0

Regardless what you see in this patch i only removed the window load event listener, and added an executeSoon after addTab (the diff looks more, not sure why).
This random orange on my vm was a persistent orange, and this fixes it, so i suppose is worth trying.
Assignee: paul → mak77
Status: NEW → ASSIGNED
Attachment #405180 - Flags: review?(paul)
Comment on attachment 405180 [details] [diff] [review]
patch v1.0

I love when executeSoon fixes things. r=zpao
Attachment #405180 - Flags: review?(paul) → review+
(In reply to comment #44)
> (the diff looks more, not sure
> why).

The diff shows lots of lines changing because your patch increases the indentation of all those lines. (since they're now in a newly-added { ... } block).

"diff -w" will ignore those whitespace changes (for the purpose of making patches easier to review).  See http://weblogs.mozillazine.org/bz/archives/020183.html for how to set up a custom "hg" command for this.
(Assignee)

Comment 47

8 years ago
Thanks Daniel, i knew about diff -w (even if i seem to recall there were issues in old versions on Windows), but actually i hoped the diff was better even without using it. for sure would have made this more readable, sorry Paul!

http://hg.mozilla.org/mozilla-central/rev/4f66b143dc54

i'll wait to see what's up on central before porting this to 1.9.2
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3.7a1
(Assignee)

Comment 48

8 years ago
at least it did not hurt :)
http://hg.mozilla.org/releases/mozilla-1.9.2/rev/af41d836e88f
status1.9.2: --- → beta1-fixed
WINNT 5.2 mozilla-central opt test everythingelse on 2009/11/15 10:10:32  
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258308632.1258311732.15065.gz
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
(In reply to comment #49)
> WINNT 5.2 mozilla-central opt test everythingelse on 2009/11/15 10:10:32  
> http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1258308632.1258311732.15065.gz

Could http://hg.mozilla.org/mozilla-central/rev/fa212b6a9d72 have caused this?
(Assignee)

Comment 51

8 years ago
at this point everything is possible, i can't see how though.
Since the failure from comment 49 didn't have any output from that test except for the JS error (which I think is unrelated to the timeout), I guess the question is: Did fa212b6a9d72 touch code that is critical for the first expected output from that test?
(Assignee)

Comment 53

8 years ago
yes the js error is unrelated, it's usually caused by about:config itself

the first test that runs is test_basic, nothing changed before the first test inside it, so to me the changes look unrelated.
changes could cause timeouts later in the test, but not there.
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5-Unittest/1259099805.1259102565.18798.gz
WINNT 5.2 mozilla-1.9.1 test everythingelse
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox-Unittest/1259225865.1259229216.26478.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.5-Unittest/1260839365.1260842120.21731.gz
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1262343722.1262348257.15006.gz
Linux mozilla-central opt test everythingelse on 2010/01/01 03:02:02
s: moz2-linux-slave02
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_394759_privatebrowsing.js | Only one browser window should be open initially - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_524745.js | Timed out
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_528776.js | number of open browser windows according to nsIWindowMediator - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_528776.js | number of open browser windows according to getBrowserState - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_528776.js | number of open browser windows according to nsIWindowMediator - Got 3, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_528776.js | number of open browser windows according to getBrowserState - Got 3, expected 2
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_528776.js | number of open browser windows according to nsIWindowMediator - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/components/sessionstore/test/browser/browser_528776.js | number of open browser windows according to getBrowserState - Got 2, expected 1
TEST-UNEXPECTED-FAIL | chrome://mochikit/content/browser/browser/fuel/test/browser_Browser.js | There should be one browser window open - Got 2, expected 1

(didn't have the "textbox is null" failure)
Linux mozilla-central debug test mochitest-other on 2010/02/09 17:57:57
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265767077.1265771803.23716.gz

Comment 59

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1265902824.1265906699.16829.gz
Linux mozilla-central debug test mochitest-other on 2010/02/11 07:40:24
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266002363.1266005337.8409.gz
Linux mozilla-central debug test mochitest-other on 2010/02/12 11:19:23
s: moz2-linux-slave08
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266441278.1266444015.19317.gz&fulltext=1
WINNT 5.2 mozilla-central debug test mochitest-other [testfailed] Started 13:14, finished 14:01
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1266440345.1266442647.14650.gz
WINNT 5.2 mozilla-1.9.2 opt test mochitest-other
Started 2010/02/17 12:59, finished 2010/02/17 13:38

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox3.6/1266505626.1266507432.26325.gz
WINNT 5.2 mozilla-1.9.2 opt test mochitest-other
Started 07:07, finished 07:38

Comment 63

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266613713.1266619845.5964.gz

Linux mozilla-central debug test mochitest-other [testfailed] Started 13:08, finished 14:51

Comment 64

8 years ago
http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266613713.1266619845.5964.gz

Linux mozilla-central debug test mochitest-other [testfailed] Started 13:08, finished 14:51

Comment 65

8 years ago
Linux mozilla-central debug test mochitest-other [testfailed] Started 15:00, finished 15:40

http://tinderbox.mozilla.org/showlog.cgi?log=Firefox/1266620424.1266622755.16605.gz
This test depended on the favicon's load event, since about:neterror from http://window4.example.com wouldn't dispatch a load event. I've made it listen to DOMContentLoaded instead:

http://hg.mozilla.org/mozilla-central/rev/a6fe7bb368a9#l2.25
Should we close this as FIXED?
(Assignee)

Comment 68

8 years ago
i'm marking so, since i don't see new reports from half of February.

We should probably sync 1.9.2 test if it is still reporting failures.
Status: REOPENED → RESOLVED
Last Resolved: 8 years ago8 years ago
Resolution: --- → FIXED
Flags: in-testsuite+
Target Milestone: Firefox 3.7a1 → Firefox 3.7a3
Marking verified since I cannot see a recent failure with this test.
Status: RESOLVED → VERIFIED
Comment hidden (Treeherder Robot)
Is this the same failure as previously indicated?  If so, can someone please reopen the bug and investigate?  Thanks.
(Assignee)

Comment 72

7 years ago
looks like some focus issue (the test timeouts and then comes back to life on focus)

I'd say it would be hard to believe this is the same failure after 2 months and logs are different, thus I'd suggest to file a new bug.
I have a fix for the *real* issue behind this bug in bug 570192.
Depends on: 570192
Comment hidden (Treeherder Robot)
Comment hidden (Treeherder Robot)
Blocks: 726505
Keywords: intermittent-failure
Whiteboard: [test which aborts the suite] [orange] → [test which aborts the suite]
You need to log in before you can comment on or make changes to this bug.