Last Comment Bug 500906 - 22 causes Visual Basic runtime error - 21 and previous OK
: 22 causes Visual Basic runtime error - 21 and previous OK
Status: VERIFIED DUPLICATE of bug 499958
:
Product: Thunderbird
Classification: Client Software
Component: General (show other bugs)
: unspecified
: x86 Windows 2000
: -- major (vote)
: ---
Assigned To: Nobody; OK to take it and work on it
:
:
Mentors:
Depends on:
Blocks:
  Show dependency treegraph
 
Reported: 2009-06-27 04:22 PDT by Doug Lockwood
Modified: 2009-07-02 05:03 PDT (History)
2 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments

Description Doug Lockwood 2009-06-27 04:22:10 PDT
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-GB; rv:1.9.0.10) Gecko/2009042316 Firefox/3.0.10
Build Identifier: 2.0.0.21

I use Visual Basic code that opens Thunderbird to send text message or email and it has been running perfectly well for years without any problems. After upgrade to 2.0.0.22 it now produces the following error message:
"Either there is no default mail client or the current mail client cannot fulfill the messaging request. Please run Microsoft Outlook and set it as the default mail client". NOT IN A ZILLION YEARS! When I uninstalled 2.0.0.20 and reinstalled 2.0.0.21 my VB code and Thunderbird worked together perfectly as they always have so problem is definitely with the upgrade. 


Reproducible: Always

Steps to Reproduce:
You need my code



I have a PDF file showing the code and various screen prints with error messages on them. Happy to send through. I'm back using 22.0.0.21 and everything's fine again but unless I get to hear this bug fixed will not be able to upgrade again.
Comment 1 Joshua Cranmer [:jcranmer] 2009-06-27 07:22:39 PDT

*** This bug has been marked as a duplicate of bug 499958 ***

Note You need to log in before you can comment on or make changes to this bug.