The default bug view has changed. See this FAQ.
Bug 503055 (bmo-upgrade-34)

Upgrade b.m.o to 3.4

RESOLVED FIXED

Status

()

bugzilla.mozilla.org
General
--
enhancement
RESOLVED FIXED
8 years ago
6 years ago

People

(Reporter: Frédéric Buclin, Assigned: justdave)

Tracking

Details

(Whiteboard: 11/15/2009 @ 6pm PST)

Attachments

(1 attachment)

(Reporter)

Description

8 years ago
Bugzilla 3.4rc1 will be released in the coming hours. We should upgrade b.m.o to 3.4rc1 once it's available to 1) catch remaining bugs and perf issues before we release 3.4 final next month, and 2) benefit from new features. ;)

Updated

8 years ago
Blocks: 484247
(Reporter)

Updated

8 years ago
Duplicate of this bug: 506748
(Reporter)

Updated

8 years ago
Summary: Upgrade b.m.o to 3.4rc1 → Upgrade b.m.o to 3.4
Assignee: nobody → justdave
Depends on: 515214
Depends on: 518073
No longer blocks: 484247
Depends on: 518517
Depends on: 518518
Depends on: 507483
(Reporter)

Updated

8 years ago
Depends on: 520734
Depends on: 523455
Alias: bmo-upgrade
Depends on: 523325, 521959
Depends on: 524511
Created attachment 408430 [details]
Mockup of possible bugzilla redesign

I'm attaching a mockup of a possible Bugzilla redesign I did awhile ago.  I was thinking about how to direct new users to the most common actions (e.g. reporting a bug) while not getting in the way of experienced users.  It's true that the large buttons of the currently proposed design easily direct people to the most common tasks, but it seems a bit like overkill at best and patronizing at worst.  I think we can find ways to direct the users' focus to the main paths in ways other than size.

I imagined something like the attachment would be a kind of intro/start screen, and the style of the other pages (e.g. bugs themselves) would be more minimal and fast loading, but with a similar visual style.
(In reply to comment #2)
> Created an attachment (id=408430) [details]
> Mockup of possible bugzilla redesign

Yeah, Ryan made this into a real template available at http://github.com/ryandoherty/Bugzilla-redesign.

We should probably split this off into a new bug.

Updated

8 years ago
Whiteboard: 10/29/2009 @ 9pm

Comment 4

8 years ago
Although I'm not working on the upgrade, I wanted to make a comment--if that date in the Status Whiteboard is the date that the upgrade will happen, then based on feedback received from Engineering during the 3.2 upgrade, I would strongly recommend that an announcehtml header pointing to the stage installation be put up on the current bugzilla.mozilla.org--one that includes a message that this is a major upgrade that will feature UI changes. After the last upgrade, it was communicated to me and the other Bugzilla developers and administrators that engineers did not have sufficient warning that the upgrade would be significant and change the UI.
The announcement won't go up there until all of the changes that need to be made to it before it can go live have been made, and that hasn't happened yet.  Personally I'm skeptical of being able to maintain that date, but that's still what we're aiming for at the moment.  If I don't get the blocker list cleared by tomorrow it's probably going to get pushed off, because I want a few days of everyone being able to see what they're going to get before it gets there.
Whiteboard: 10/29/2009 @ 9pm → tentatively 10/29/2009 @ 9pm
No way this is happening tonight, don't have the final product in place on the staging site yet, and it needs a few days of testing once that's done.
Whiteboard: tentatively 10/29/2009 @ 9pm → tentatively 11/3/2009 @ 9pm
Depends on: 438362, 453436

Updated

8 years ago
Whiteboard: tentatively 11/3/2009 @ 9pm → tentatively 11/5/2009 @ 9pm

Updated

8 years ago
Blocks: 504950

Updated

8 years ago
Blocks: 506825
No longer blocks: 504950
Depends on: 495989
Whiteboard: tentatively 11/5/2009 @ 9pm → 11/15/2009 @ 6pm
Whiteboard: 11/15/2009 @ 6pm → 11/15/2009 @ 6pm PST
preliminary security audit passed, we have an official go for upgrading tomorrow afternoon. :)  (as evident by the downtime notice already in the banner from a few hours ago)
(Reporter)

Updated

8 years ago
Depends on: 528805
No longer depends on: 524511
(Reporter)

Updated

8 years ago
Depends on: 528838
Depends on: 528882
(Reporter)

Updated

8 years ago
No longer depends on: 528882
(Reporter)

Updated

7 years ago
No longer depends on: 528838
No longer depends on: 520734
This was done.  Followup issues are being dealt with on bug 528846.
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → FIXED
Alias: bmo-upgrade → bmo-upgrade-34
Component: Bugzilla: Other b.m.o Issues → General
Product: mozilla.org → bugzilla.mozilla.org
You need to log in before you can comment on or make changes to this bug.