nsISound::playSystemSound("_moz_mailbeep"); is obsolete on Gecko1.9.2a1 and later

RESOLVED FIXED in Thunderbird 3.1b1

Status

Thunderbird
OS Integration
RESOLVED FIXED
9 years ago
8 years ago

People

(Reporter: masayuki, Assigned: standard8)

Tracking

Trunk
Thunderbird 3.1b1
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

|nsISound::playSystemSound("_moz_mailbeep");| is obsolete on Gecko1.9.2a1 and later. Use |nsISound::playEventSound(nsISound::EVENT_NEW_MAIL_RECIEVED);| instead.

This is not a bug for *current* thunderbird trunk build. But after Tb3, we should fix it.

http://mxr.mozilla.org/comm-central/source/mail/components/preferences/general.js#126
http://mxr.mozilla.org/comm-central/source/mailnews/base/src/nsStatusBarBiffManager.cpp#157

Updated

9 years ago
Status: NEW → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 503248
Hey, the product is different with bug 503248.
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
I've already got another bug I have to remember to fix (on the branch) after we branch for 3.0, with a little luck that'll remind me it's time to fix this on the trunk.
Assignee: nobody → philringnalda
Status: REOPENED → ASSIGNED
Whiteboard: [needs branch]
Target Milestone: --- → Future
Target Milestone: Future → Thunderbird 3.1a1
Actually, since the API has become broken and worthless on OS X since 1.8, I guess I won't be the one to fix this after all.
Assignee: philringnalda → nobody
Status: ASSIGNED → NEW
Whiteboard: [needs branch]
Target Milestone: Thunderbird 3.1a1 → Thunderbird 3.1b1
(In reply to comment #4)
> Actually, since the API has become broken and worthless on OS X since 1.8, I
> guess I won't be the one to fix this after all.

So what should we do with this bug Phil ?
(Assignee)

Updated

8 years ago
Duplicate of this bug: 594355
(Assignee)

Updated

8 years ago
Depends on: 594355
(Assignee)

Comment 7

8 years ago
I'm fixing this in bug 594355.
Assignee: nobody → bugzilla
Status: NEW → ASSIGNED
(Assignee)

Comment 8

8 years ago
This is now fixed with the checkin of bug 594355
(Assignee)

Updated

8 years ago
Status: ASSIGNED → RESOLVED
Last Resolved: 9 years ago8 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.