Note: There are a few cases of duplicates in user autocompletion which are being worked on.

Default alert sound not playing on Mac when new email arrives

RESOLVED FIXED in Thunderbird 3.3a1

Status

MailNews Core
Backend
RESOLVED FIXED
7 years ago
7 years ago

People

(Reporter: B, Assigned: standard8)

Tracking

unspecified
Thunderbird 3.3a1
x86
Mac OS X

Firefox Tracking Flags

(blocking-thunderbird3.1 .7+, thunderbird3.1 .7-fixed)

Details

(Whiteboard: [gs], URL)

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

7 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_4; en-us) AppleWebKit/533.17.8 (KHTML, like Gecko) Version/5.0.1 Safari/533.17.8
Build Identifier: Thunderbird 3.1.2 under MacOS 10.6.4 -- Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.6; en-US; rv:1.9.2.8) Gecko/20100802 Thunderbird/3.1.2

After upgrading from Version 2 to 3, the default alert sound no longer plays when new email arrives.  I then chose Preferences, selected General, and under "Play a  sound" (which is of course checked) I changed the selection from "System Alert Sound" to "Use the following sound  file" and put a .wav file there and this does work.  I have verified that my alert sound is functioning fine for other purposes, mute is not on, volume is high, etc., etc.  I checked this with two computers running the same Mac OS 10.6.4.

Reproducible: Always

Actual Results:  
new email alert sound not playing in Version 3, but changing to user defined sound file does work -- checked on two different computers, had worked fine before upgrading from Version 2 to 3 (3.1.2) under MacOS 10.6.4.

Expected Results:  
new email alert sound not should play in Version 3, just like it did in Version 2.
anything in Console.app when this happens (we have a bunch of issues around this , but nothing tangible as why it happens).
Sorry I wrongly assumed that cs.berkely.edu would know where console.app is, it's in /Application/utilities - and yes I'm asking you to look into it just after receiving an email and no sound being played.

Also please don't reply by email, reply here so more people can participate and help.
(Reporter)

Comment 3

7 years ago
There is nothing  in Console.app that seems related to this.

Just to be clear, regarding "when this happens", the problem always occurs -- to be more exact, the problem is not that anything happens, but the contrary, the problem is that there is never any alert
sound when new mail arrives (although my work-around has been to set up a custom .wav file
and that sounds does indeed play whenever there is new email arriving).
Mike, roland do you get that issue too ?

Comment 5

7 years ago
I could never get sound to play with 3.1a1pre, didn't try it with 3.1.1, but set it up to play one of the system ".aiff" files when upgraded to 3.1.2 -- that DOES work.  Changed pref to use "System Alert Sound", no sound plays.
(In reply to comment #5)
> I could never get sound to play with 3.1a1pre, didn't try it with 3.1.1, but
> set it up to play one of the system ".aiff" files when upgraded to 3.1.2 --
> that DOES work.  Changed pref to use "System Alert Sound", no sound plays.

Mike can you find the latest version that worked (let's get the regression window for that one)
Status: UNCONFIRMED → NEW
Component: General → OS Integration
Ever confirmed: true
Keywords: regression, regressionwindow-wanted
QA Contact: general → os-integration
Whiteboard: duptome

Comment 7

7 years ago
I never had a version that worked.  IIRC, even Eudora 8.0b7/8.0b8 (TB3.0b3/3.0b4) wouldn't play the "System Alert Sound".
Duplicate of this bug: 587657
Duplicate of this bug: 587118
blocking-thunderbird3.2: --- → ?
Status: NEW → RESOLVED
blocking-thunderbird3.2: ? → ---
Last Resolved: 7 years ago
Keywords: regression, regressionwindow-wanted
Resolution: --- → DUPLICATE
Whiteboard: duptome
Duplicate of bug: 503246
Urgh, actually not quite a duplicate.
Blocks: 503246
Status: RESOLVED → REOPENED
Resolution: DUPLICATE → ---
Assignee: nobody → bugzilla
blocking-thunderbird3.1: --- → .7+
Component: OS Integration → Backend
Product: Thunderbird → MailNews Core
QA Contact: os-integration → backend
Summary: default alert sound not playing when new email arrives in Version 3 → Default alert sound not playing on Mac when new email arrives
Whiteboard: [gs]
Created attachment 487310 [details] [diff] [review]
[checked in] The fix

PlaySystemSound and PlayEventSound are a no-op on Mac, therefore use Beep() and this ends up with the same sound that Thunderbird 2 used.

This also updates non-Mac to use the new function for the new mail sound rather than the old one, as per bug 503246.
Attachment #487310 - Flags: review?(bienvenu)
Status: REOPENED → ASSIGNED
Created attachment 487312 [details] [diff] [review]
1.9.2 fix

This fix for the 3.1 / 1.9.2 builds just changes the Mac interface to use Beep, and doesn't change the obsolete API to limit the affected platforms.
Attachment #487312 - Flags: review?(bienvenu)
Created attachment 487324 [details] [diff] [review]
1.9.2 fix v2

I realised that the 1.9.2 patch shouldn't remove DEFAULT_SYSTEM_SOUND, so this is the correct fix for 1.9.2.
Attachment #487312 - Attachment is obsolete: true
Attachment #487324 - Flags: review?(bienvenu)
Attachment #487312 - Flags: review?(bienvenu)

Comment 15

7 years ago
Comment on attachment 487310 [details] [diff] [review]
[checked in] The fix

my mac is beeping away annoyingly now :-)
Attachment #487310 - Flags: review?(bienvenu) → review+

Updated

7 years ago
Attachment #487324 - Flags: review?(bienvenu) → review+
Comment on attachment 487310 [details] [diff] [review]
[checked in] The fix

Checked in: http://hg.mozilla.org/comm-central/rev/8a850b6c8f62
Attachment #487310 - Attachment description: The fix → [checked in] The fix
Status: ASSIGNED → RESOLVED
Last Resolved: 7 years ago7 years ago
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 3.3a1
Attachment #487324 - Flags: approval-thunderbird3.1.7?
Attachment #487324 - Flags: approval-thunderbird3.1.7? → approval-thunderbird3.1.7+
Checked into 1.9.2: http://hg.mozilla.org/releases/comm-1.9.2/rev/9863b7a2b75c
status-thunderbird3.1: --- → .7-fixed
Is the system sound the bell sound?

I've been getting it for only some of the emails that arrive, like a third of them or something like that.
(In reply to comment #18)
> Is the system sound the bell sound?

Its the one configured under System Preferences -> Sound (at least on Mac 10.5).

> I've been getting it for only some of the emails that arrive, like a third of
> them or something like that.

Do you filter to Local Folders? iirc we don't do new mail alert when that happens.
(In reply to comment #19)
> (In reply to comment #18)
> > Is the system sound the bell sound?
> 
> Its the one configured under System Preferences -> Sound (at least on Mac
> 10.5).
> 
> > I've been getting it for only some of the emails that arrive, like a third of
> > them or something like that.
> 
> Do you filter to Local Folders? iirc we don't do new mail alert when that
> happens.

Yes, ok, that's it then.  I find it strange, but I turned the alert off anyways  ;-)
You need to log in before you can comment on or make changes to this bug.