Closed Bug 503597 Opened 11 years ago Closed 11 years ago

configure.in silently disables necko wifi when header is missing (Linux only)

Categories

(Firefox Build System :: General, defect, P2)

All
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED
mozilla1.9.2a1

People

(Reporter: dbaron, Assigned: dbaron)

References

Details

Attachments

(1 file)

Attached patch patchSplinter Review
On Linux only, configure.in silently disables NECKO_WIFI when iwlib.h isn't found.  This is inconsistent with other platforms (where we give an error saying to --disable-necko-wifi) and with the good practice of not disabling things silently (especially major new features of the browser).  (It wouldn't surprise me if some Linux distros end up shipping Firefox with wifi geolocation broken as a result.)

The attached patch makes this an error, consistent with the unknown platform case, but also provides some advice on getting iwlib.h.
Attachment #387957 - Flags: review?(dougt)
Attachment #387957 - Flags: review?(dougt)
Attachment #387957 - Flags: review?(doug.turner)
Attachment #387957 - Flags: review?(benjamin)
Attachment #387957 - Flags: review?(doug.turner) → review+
Attachment #387957 - Flags: review?(benjamin) → review+
http://hg.mozilla.org/mozilla-central/rev/6e11834d07c9
Status: ASSIGNED → RESOLVED
Closed: 11 years ago
Priority: -- → P2
Resolution: --- → FIXED
Target Milestone: --- → mozilla1.9.2a1
Depends on: 505203
Depends on: 505204
Backed out because tinderboxes need updating (particularly Linux x86_64 Firefox, which is effectively tier 1):
http://hg.mozilla.org/mozilla-central/rev/c0d86da16888
http://hg.mozilla.org/mozilla-central/rev/f3b0f579af93

See newly-filed dependent bugs.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
In the future, if adding a library dependency to configure.in, please get Build Config peer review.
Benjamin looks like a build config peer to me.
http://hg.mozilla.org/mozilla-central/rev/caa4e6ca1dbd
Status: REOPENED → RESOLVED
Closed: 11 years ago11 years ago
Resolution: --- → FIXED
s/iwlib-dev/libiw-dev/ for the Ubuntu/Debian package name
Yes, I've already been told, and I have a fix ready to land when the tree reopens.
typo fixed: http://hg.mozilla.org/mozilla-central/rev/35ecfeedac76

And sorry for being snappy above... thanks for letting me know.
Can Bug 509060 be caused by this bugfix?
Flags: in-testsuite-
Product: Core → Firefox Build System
You need to log in before you can comment on or make changes to this bug.