Setup mozilla-1.9.2 branch

RESOLVED FIXED

Status

Release Engineering
General
RESOLVED FIXED
9 years ago
4 years ago

People

(Reporter: joduinn, Assigned: bhearsum)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

Estimate need for this branch at end July. This would need all the usual builds/nightlies/unittests/talos/etc.
It's July 29th, so I'd think that we can Future this...

Anybody have this on their plates?
That is, I don't think that we can Future this.

Clarity.  I has it.
(Assignee)

Comment 3

8 years ago
I think I'll be the one heading up the work here - I plan to get started on it next week, after all the releases go out. Someone else can steal it if they want, though.
Assignee: nobody → bhearsum
Status: NEW → ASSIGNED
(Assignee)

Updated

8 years ago
Depends on: 508281
(Assignee)

Updated

8 years ago
Depends on: 508282
(Assignee)

Updated

8 years ago
Depends on: 508283
(Assignee)

Updated

8 years ago
Depends on: 508284
(Assignee)

Updated

8 years ago
Depends on: 508286
(Assignee)

Updated

8 years ago
Depends on: 508289
(Assignee)

Updated

8 years ago
Depends on: 508311
(Assignee)

Updated

8 years ago
Depends on: 507168
(Assignee)

Comment 4

8 years ago
A couple of random TODOs:
* update tree closure hook
* update cleanup and print_waits.py cronjobs on production-master, production-master02, talos-master
(Assignee)

Comment 5

8 years ago
* Poke mstange about tbpl
(Assignee)

Comment 6

8 years ago
* Create GECKO_1_9_2_BASE tag is all repositories.
(Assignee)

Comment 7

8 years ago
Created attachment 394283 [details]
script used to sync l10n-central/* to l10n-mozilla-1.9.2/*
(Assignee)

Comment 8

8 years ago
Created attachment 394285 [details]
log from l10n sync

Everything went fine here with the following exceptions:
* hi-IN and mr had to be pushed manually with '-f' because their tip commit was not on default
* fr and ru l10n-mozilla-1.9.2 repositories already had something pushed to them, they still need to be dealt with manually.
(Assignee)

Comment 9

8 years ago
(In reply to comment #4)
> A couple of random TODOs:
> * update tree closure hook

Done.
(Assignee)

Comment 10

8 years ago
(In reply to comment #5)
> * Poke mstange about tbpl

Emailed him about this.

(In reply to comment #6)
> * Create GECKO_1_9_2_BASE tag is all repositories.

Done, except for fr and ru.
(Assignee)

Comment 11

8 years ago
(In reply to comment #4)
> * update cleanup and print_waits.py cronjobs on production-master,
> production-master02, talos-master

Done
(Assignee)

Updated

8 years ago
Depends on: 510248
(Assignee)

Comment 12

8 years ago
> (In reply to comment #6)
> > * Create GECKO_1_9_2_BASE tag is all repositories.
> 
> Done, except for fr and ru.

These two are done now too.
(Assignee)

Updated

8 years ago
Depends on: 510495
(Assignee)

Updated

8 years ago
Depends on: 510497
(Assignee)

Comment 13

8 years ago
Dep bugs closed, this is done!
Status: ASSIGNED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → FIXED

Comment 14

8 years ago
FWIW, l10n server setup is still not up, there are some regressions that I haven't figured out yet how to resolve.

l10n 1.9.2 mxr indexing isn't up, not sure if that just needs time in bug 510495.

l10n builds on 1.9.2 don't have nightly updates on, tree variables on all builders are still wonky, not sure which bugs those are.
hi Axel;

This bug is already closed. I dont want your comments to get lost, so if you want us to do stuff here, please open.

(In reply to comment #14)
> FWIW, l10n server setup is still not up, there are some regressions that I
> haven't figured out yet how to resolve.
afaict, this is for you to do?


> l10n 1.9.2 mxr indexing isn't up, not sure if that just needs time in bug
> 510495.
bug510495 looks like the place to track this, per Aravind's last comment there. If its still a problem, please reopen bug#510495.


> l10n builds on 1.9.2 don't have nightly updates on, tree variables on all
> builders are still wonky, not sure which bugs those are.
Didnt realise you wanted l10n nightlies on 1.9.2 in addition to m-c. We can do that if thats what you want, please file a separate bug for this.

What tree variables are "still wonky"? If there is anything for RelEng to do here, please file a bug on this.

Comment 16

8 years ago
(In reply to comment #15)
> hi Axel;
> 
> This bug is already closed. I dont want your comments to get lost, so if you
> want us to do stuff here, please open.
> 
> (In reply to comment #14)
> > FWIW, l10n server setup is still not up, there are some regressions that I
> > haven't figured out yet how to resolve.
> afaict, this is for you to do?

Yes.

> > l10n 1.9.2 mxr indexing isn't up, not sure if that just needs time in bug
> > 510495.
> bug510495 looks like the place to track this, per Aravind's last comment there.
> If its still a problem, please reopen bug#510495.

Indexing seems to pick up there.

> > l10n builds on 1.9.2 don't have nightly updates on, tree variables on all
> > builders are still wonky, not sure which bugs those are.
> Didnt realise you wanted l10n nightlies on 1.9.2 in addition to m-c. We can do
> that if thats what you want, please file a separate bug for this.

That's bug 510524, marking as follow-up. I'm somewhat puzzled on how you seem to think that there'd be l10n branches for which we don't want l10n nightly updates.

> What tree variables are "still wonky"? If there is anything for RelEng to do
> here, please file a bug on this.

That's bug 508281, no builds happened yet to verify that it's fixed.
Blocks: 510524
Depends on: 510918
Depends on: 510913
Product: mozilla.org → Release Engineering
You need to log in before you can comment on or make changes to this bug.