Closed Bug 504480 Opened 10 years ago Closed 10 years ago

runtests.py.in needs to do a '-silent' run first, as runreftest.py does

Categories

(Testing :: Mochitest, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED
mozilla1.9.2b1

People

(Reporter: sgautherie, Assigned: sgautherie)

References

(Blocks 1 open bug)

Details

(Whiteboard: [fixed1.9.1.3])

Attachments

(4 files)

http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1247174853.1247180582.26912.gz&fulltext=1
Linux comm-1.9.1 unit test on 2009/07/09 14:27:33
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1247175081.1247184301.3679.gz&fulltext=1
OS X 10.4 comm-central unit test on 2009/07/09 14:31:21
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1247168125.1247174572.22098.gz&fulltext=1
OS X 10.5 comm-1.9.1 unit test on 2009/07/09 12:35:25
http://tinderbox.mozilla.org/showlog.cgi?log=SeaMonkey2.0/1247169817.1247174891.25889.gz&fulltext=1
WINNT 5.2 comm-1.9.1 unit test on 2009/07/09 13:03:37

Already have bug.

*****

[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090711 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/47bfcd275ede
 +http://hg.mozilla.org/comm-central/rev/291cbe3374b9)

No bug (on the one run I did). (Though I'm not sure why.)


[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2)

Multiple tests report the same 'Console message', like:
{
TEST-INFO | chrome://mochikit/content/browser/xpinstall/tests/browser_auth.js | Console message: No chrome package registered for chrome://chatzilla/skin/images/logo.png
}
Depends on: 481406
This is a bug in the test harness. Because it forces the application to start without an EM restart to enable detected extensions any extensions aren't registered properly
Assignee: rginda → nobody
Component: ChatZilla → Mochitest
Product: Other Applications → Testing
QA Contact: chatzilla → mochitest
Ah, got it!

Previous summary:
mochitest-browser-chrome: multiple "TEST-INFO | ... | Console message: No chrome package registered for chrome://chatzilla/skin/images/logo.png"
Assignee: nobody → sgautherie.bz
Blocks: runtests.py
Severity: minor → normal
Status: NEW → ASSIGNED
Depends on: 468913
Hardware: x86 → All
Summary: mochitest-browser-chrome: multiple "TEST-INFO | ... | Console message: No chrome package registered for chrome://chatzilla/skin/images/logo.png" → runtests.py.in needs to do a '-silent' run first, as runreftest.py does
Target Milestone: --- → mozilla1.9.2a1
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2 + bug 503724 patch)
Attachment #389054 - Flags: review?(neil)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2 + bug 503724 patch)
Attachment #389059 - Flags: review?(jwalden+bmo)
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2 + bug 503724 patch)
Attachment #389072 - Flags: review?(sdwilsh)
Depends on: 504730
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.2a1pre) Gecko/20090715 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/d190d9b6ccd1
 +http://hg.mozilla.org/comm-central/rev/773809454cf2 + bug 503724 patch)
Attachment #389080 - Flags: review?(mnyromyr)
Depends on: 446281
Comment on attachment 389059 [details] [diff] [review]
(Bv1) Fix runtests.py.in, Sync' runreftest.py
[Checkin: Comment 15 & 16]


http://build.mozilla.org/tryserver-builds/sgautherie.bz@free.fr-try-1c43fe4cc6f7
Linux and MacOSX passed.
Windows was unexpectedly "all" broken :-<
but it passed on my local SM 2.1, though I didn't run mochitest-plain.
Attachment #389054 - Flags: review?(neil) → review+
Keywords: checkin-needed
Whiteboard: [c-n: Av1-SM, after SM2.0b1]
Comment on attachment 389072 [details] [diff] [review]
(Cv1-DOMi) popupOverlay.xul: un-duplicate 6 ids
[Checkin: Comment 9]

r=sdwilsh
Attachment #389072 - Flags: review?(sdwilsh) → review+
Attachment #389072 - Attachment description: (Cv1-DOMi) popupOverlay.xul: un-duplicate 6 ids → (Cv1-DOMi) popupOverlay.xul: un-duplicate 6 ids [Checkin: Comment 9]
Comment on attachment 389072 [details] [diff] [review]
(Cv1-DOMi) popupOverlay.xul: un-duplicate 6 ids
[Checkin: Comment 9]


http://hg.mozilla.org/dom-inspector/rev/491e4703f2d3
Comment on attachment 389080 [details] [diff] [review]
(Dv1-SM) test_idcheck.xul: enable CZ and DOMi
[Checkin: Comment 17]

r=me, given that the actual tests pass.
Attachment #389080 - Flags: review?(mnyromyr) → review+
Whiteboard: [c-n: Av1-SM, after SM2.0b1] → [c-n: Av1-SM, after SM2.0b1; Dv1-SM depends on Bv1 first]
Comment on attachment 389054 [details] [diff] [review]
(Av1-SM) pref-debug?.xul: un-duplicate 'debugqa_preferences'
[Checkin: Comment 11]


http://hg.mozilla.org/comm-central/rev/15e04f02d044
Attachment #389054 - Attachment description: (Av1-SM) pref-debug?.xul: un-duplicate 'debugqa_preferences' → (Av1-SM) pref-debug?.xul: un-duplicate 'debugqa_preferences' [Checkin: Comment 11]
Keywords: checkin-needed
Whiteboard: [c-n: Av1-SM, after SM2.0b1; Dv1-SM depends on Bv1 first] → [c-n: Dv1-SM depends on Bv1 first]
sgautherie: see bug 417355. Is it a dupe of this one, with a different patch?
Duplicate of this bug: 417355
Comment on attachment 389059 [details] [diff] [review]
(Bv1) Fix runtests.py.in, Sync' runreftest.py
[Checkin: Comment 15 & 16]

Ted, maybe you could be the one doing the review?
Attachment #389059 - Flags: review?(ted.mielczarek)
Attachment #389059 - Flags: review?(ted.mielczarek)
Attachment #389059 - Flags: review?(jwalden+bmo)
Attachment #389059 - Flags: review+
Comment on attachment 389059 [details] [diff] [review]
(Bv1) Fix runtests.py.in, Sync' runreftest.py
[Checkin: Comment 15 & 16]


http://hg.mozilla.org/mozilla-central/rev/c83cda2f5f54
Attachment #389059 - Attachment description: (Bv1) Fix runtests.py.in, Sync' runreftest.py → (Bv1) Fix runtests.py.in, Sync' runreftest.py [Checkin: Comment 15]
Comment on attachment 389059 [details] [diff] [review]
(Bv1) Fix runtests.py.in, Sync' runreftest.py
[Checkin: Comment 15 & 16]


http://hg.mozilla.org/releases/mozilla-1.9.1/rev/5984f8afb5b7
Attachment #389059 - Attachment description: (Bv1) Fix runtests.py.in, Sync' runreftest.py [Checkin: Comment 15] → (Bv1) Fix runtests.py.in, Sync' runreftest.py [Checkin: Comment 15 & 16]
Comment on attachment 389080 [details] [diff] [review]
(Dv1-SM) test_idcheck.xul: enable CZ and DOMi
[Checkin: Comment 17]


http://hg.mozilla.org/comm-central/rev/54a31dce7f85
Attachment #389080 - Attachment description: (Dv1-SM) test_idcheck.xul: enable CZ and DOMi → (Dv1-SM) test_idcheck.xul: enable CZ and DOMi [Checkin: Comment 17]
Status: ASSIGNED → RESOLVED
Closed: 10 years ago
Resolution: --- → FIXED
Whiteboard: [c-n: Dv1-SM depends on Bv1 first] → [fixed1.9.1.3]
Target Milestone: mozilla1.9.2a1 → mozilla1.9.2b1
Depends on: 509594
Blocks: 504730
No longer depends on: 504730
[Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9.3a1pre) Gecko/20090814 SeaMonkey/2.1a1pre] (home, optim default) (W2Ksp4)
(http://hg.mozilla.org/mozilla-central/rev/2a152f11d9c7
 +http://hg.mozilla.org/comm-central/rev/ccf2369fb4c7)

V.Fixed: no more "No chrome package registered for" logs.
Status: RESOLVED → VERIFIED
(In reply to comment #19)
> This regressed bug 485531

Ah: ... which you already fixed there :-)

Iiuc, it looks like my push triggered that regression though not "caused" the underlying issue.
Duplicate of this bug: 363321
You need to log in before you can comment on or make changes to this bug.